diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2019-12-02 13:45:37 -0500 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2019-12-06 22:38:10 +0000 |
commit | 6211c51c1c2fad724a1931613c33297227b12b03 (patch) | |
tree | b2b8366a47bf9e4bb56b65061e0c175231db6264 /recipes-bsp | |
parent | b890b26251554c0fc20e15bacdda9f877ba285fa (diff) | |
download | meta-ti-6211c51c1c2fad724a1931613c33297227b12b03.tar.gz |
transport-rtos: migrate to ti-pdk-fetch.bbclass
* Add new recipe for timesync-rtos
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/transport-rtos/bmet-eth-rtos_git.bb | 4 | ||||
-rw-r--r-- | recipes-bsp/transport-rtos/nimu-icss-rtos_git.bb | 4 | ||||
-rw-r--r-- | recipes-bsp/transport-rtos/nimu-rtos_git.bb | 4 | ||||
-rw-r--r-- | recipes-bsp/transport-rtos/timesync-rtos_git.bb | 31 | ||||
-rw-r--r-- | recipes-bsp/transport-rtos/transport.inc | 12 |
5 files changed, 37 insertions, 18 deletions
diff --git a/recipes-bsp/transport-rtos/bmet-eth-rtos_git.bb b/recipes-bsp/transport-rtos/bmet-eth-rtos_git.bb index 137476ed..f14161ff 100644 --- a/recipes-bsp/transport-rtos/bmet-eth-rtos_git.bb +++ b/recipes-bsp/transport-rtos/bmet-eth-rtos_git.bb | |||
@@ -13,9 +13,7 @@ DEPENDS_append = " qmss-lld-rtos \ | |||
13 | cppi-lld-rtos \ | 13 | cppi-lld-rtos \ |
14 | " | 14 | " |
15 | 15 | ||
16 | BMET_ETH_DESTSUFFIX = "git/bmet_eth" | 16 | TI_PDK_COMP = "ti.transport.bmet_eth" |
17 | |||
18 | S = "${WORKDIR}/${BMET_ETH_DESTSUFFIX}" | ||
19 | 17 | ||
20 | # HTML doc link params | 18 | # HTML doc link params |
21 | PDK_COMP_LINK_TEXT = "Baremetal Ethernet Transport" | 19 | PDK_COMP_LINK_TEXT = "Baremetal Ethernet Transport" |
diff --git a/recipes-bsp/transport-rtos/nimu-icss-rtos_git.bb b/recipes-bsp/transport-rtos/nimu-icss-rtos_git.bb index 4750e046..02ddc473 100644 --- a/recipes-bsp/transport-rtos/nimu-icss-rtos_git.bb +++ b/recipes-bsp/transport-rtos/nimu-icss-rtos_git.bb | |||
@@ -17,13 +17,11 @@ DEPENDS_append_c665x-evm = " emac-lld-rtos" | |||
17 | DEPENDS_append_c667x-evm = " pa-lld-rtos" | 17 | DEPENDS_append_c667x-evm = " pa-lld-rtos" |
18 | DEPENDS_append_omapl1 = " emac-lld-rtos" | 18 | DEPENDS_append_omapl1 = " emac-lld-rtos" |
19 | 19 | ||
20 | NIMU_ICSS_DESTSUFFIX = "git/ndk/nimu_icss" | 20 | TI_PDK_COMP = "ti.transport.ndk.nimu_icss" |
21 | 21 | ||
22 | # Build with make instead of XDC | 22 | # Build with make instead of XDC |
23 | TI_PDK_XDCMAKE = "0" | 23 | TI_PDK_XDCMAKE = "0" |
24 | 24 | ||
25 | S = "${WORKDIR}/${NIMU_ICSS_DESTSUFFIX}" | ||
26 | |||
27 | export PDK_NIMU_ICSS_ROOT_PATH ="${WORKDIR}/build" | 25 | export PDK_NIMU_ICSS_ROOT_PATH ="${WORKDIR}/build" |
28 | export DEST_ROOT="${S}" | 26 | export DEST_ROOT="${S}" |
29 | 27 | ||
diff --git a/recipes-bsp/transport-rtos/nimu-rtos_git.bb b/recipes-bsp/transport-rtos/nimu-rtos_git.bb index 1e3bc189..4389b1e8 100644 --- a/recipes-bsp/transport-rtos/nimu-rtos_git.bb +++ b/recipes-bsp/transport-rtos/nimu-rtos_git.bb | |||
@@ -9,9 +9,7 @@ LIC_FILES_CHKSUM = "file://nimu_eth.h;beginline=1;endline=35;md5=ee9c662c39d4584 | |||
9 | 9 | ||
10 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|c66x|omapl1|k3" | 10 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|c66x|omapl1|k3" |
11 | 11 | ||
12 | NIMU_DESTSUFFIX = "git/ndk/nimu" | 12 | TI_PDK_COMP = "ti.transport.ndk.nimu" |
13 | |||
14 | S = "${WORKDIR}/${NIMU_DESTSUFFIX}" | ||
15 | 13 | ||
16 | DEPENDS_append = " ti-ndk osal-rtos" | 14 | DEPENDS_append = " ti-ndk osal-rtos" |
17 | DEPENDS_append_ti33x = " starterware-rtos emac-lld-rtos" | 15 | DEPENDS_append_ti33x = " starterware-rtos emac-lld-rtos" |
diff --git a/recipes-bsp/transport-rtos/timesync-rtos_git.bb b/recipes-bsp/transport-rtos/timesync-rtos_git.bb new file mode 100644 index 00000000..556c1288 --- /dev/null +++ b/recipes-bsp/transport-rtos/timesync-rtos_git.bb | |||
@@ -0,0 +1,31 @@ | |||
1 | SUMMARY = "RTOS driver for timesync driver" | ||
2 | |||
3 | inherit ti-pdk | ||
4 | require recipes-bsp/transport-rtos/transport.inc | ||
5 | |||
6 | PR = "${INC_PR}.0" | ||
7 | |||
8 | LIC_FILES_CHKSUM = "file://timeSync_ver.h;beginline=23;endline=45;md5=4bd873035e47065aaa811e53622992e9" | ||
9 | |||
10 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|k2g" | ||
11 | |||
12 | DEPENDS_append = " ti-ndk \ | ||
13 | osal-rtos \ | ||
14 | pruss-lld-rtos \ | ||
15 | icss-emac-lld-rtos \ | ||
16 | nimu-icss-rtos \ | ||
17 | edma3-lld-rtos \ | ||
18 | " | ||
19 | |||
20 | TI_PDK_COMP = "ti.transport.timeSync" | ||
21 | |||
22 | # Build with make instead of XDC | ||
23 | TI_PDK_XDCMAKE = "0" | ||
24 | |||
25 | export PDK_TIMESYNC_ROOT_PATH ="${WORKDIR}/build" | ||
26 | export DEST_ROOT="${S}" | ||
27 | |||
28 | export NDK_INSTALL_PATH = "${NDK_INSTALL_DIR}" | ||
29 | export EDMA3LLD_BIOS6_INSTALLDIR = "${EDMA3_LLD_INSTALL_DIR}" | ||
30 | |||
31 | XDCPATH_append = ";${NDK_INSTALL_DIR}/packages" | ||
diff --git a/recipes-bsp/transport-rtos/transport.inc b/recipes-bsp/transport-rtos/transport.inc index 345cd6dd..866d7a34 100644 --- a/recipes-bsp/transport-rtos/transport.inc +++ b/recipes-bsp/transport-rtos/transport.inc | |||
@@ -2,16 +2,10 @@ LICENSE = "BSD-3-Clause" | |||
2 | 2 | ||
3 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 3 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
4 | 4 | ||
5 | TRANSPORT_GIT_URI = "git://git.ti.com/keystone-rtos/transport.git" | 5 | inherit ti-pdk-fetch |
6 | TRANSPORT_GIT_PROTOCOL = "git" | ||
7 | TRANSPORT_GIT_BRANCH = "master" | ||
8 | 6 | ||
9 | # Below commit ID corresponds to "DEV.TRANSPORT.01.00.00.17A" | 7 | TI_PDK_COMP = "ti.transport" |
10 | TRANSPORT_SRCREV = "9ed171c476a5606777d2dcb4e831c279a5160245" | ||
11 | 8 | ||
12 | BRANCH = "${TRANSPORT_GIT_BRANCH}" | 9 | PE = "1" |
13 | SRC_URI = "${TRANSPORT_GIT_URI};protocol=${TRANSPORT_GIT_PROTOCOL};branch=${BRANCH}" | ||
14 | 10 | ||
15 | SRCREV = "${TRANSPORT_SRCREV}" | ||
16 | PV = "01.00.00.17A" | ||
17 | INC_PR = "r0" | 11 | INC_PR = "r0" |