diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2015-11-04 01:47:25 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-11-04 09:59:44 -0500 |
commit | c252c773147b650727819a3a6e60be0111ad6e0f (patch) | |
tree | cf99cdca1012717180f219d4e02cdcc317754d77 /recipes-bsp | |
parent | 8618a97a988637fecfc6dc53e58e0684134a42a2 (diff) | |
download | meta-ti-c252c773147b650727819a3a6e60be0111ad6e0f.tar.gz |
qmss-lld: Clean up recipes
* Use INC_PR to track recipe revisions
* Define variables for GIT SRC_URI parameters
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/qmss-lld/qmss-lld-test_git.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/qmss-lld/qmss-lld.inc | 17 | ||||
-rw-r--r-- | recipes-bsp/qmss-lld/qmss-lld_git.bb | 1 |
3 files changed, 15 insertions, 5 deletions
diff --git a/recipes-bsp/qmss-lld/qmss-lld-test_git.bb b/recipes-bsp/qmss-lld/qmss-lld-test_git.bb index 438d8402..7c19364f 100644 --- a/recipes-bsp/qmss-lld/qmss-lld-test_git.bb +++ b/recipes-bsp/qmss-lld/qmss-lld-test_git.bb | |||
@@ -5,6 +5,8 @@ DEPENDS="common-csl-ip rm-lld cppi-lld qmss-lld" | |||
5 | 5 | ||
6 | include qmss-lld.inc | 6 | include qmss-lld.inc |
7 | 7 | ||
8 | PR = "${INC_PR}.0" | ||
9 | |||
8 | CHOICELIST = "yes no" | 10 | CHOICELIST = "yes no" |
9 | 11 | ||
10 | do_compile () { | 12 | do_compile () { |
diff --git a/recipes-bsp/qmss-lld/qmss-lld.inc b/recipes-bsp/qmss-lld/qmss-lld.inc index 29ef0ce0..efd681e4 100644 --- a/recipes-bsp/qmss-lld/qmss-lld.inc +++ b/recipes-bsp/qmss-lld/qmss-lld.inc | |||
@@ -1,14 +1,21 @@ | |||
1 | LICENSE = "BSD-3-Clause" | 1 | LICENSE = "BSD-3-Clause" |
2 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/qmss/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d" | 2 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/qmss/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d" |
3 | 3 | ||
4 | BRANCH ="master" | 4 | QMSS_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/qmss-lld.git" |
5 | SRC_URI = "git://git.ti.com/keystone-rtos/qmss-lld.git;destsuffix=git/ti/drv/qmss;protocol=git;branch=${BRANCH}" | 5 | QMSS_LLD_GIT_PROTOCOL = "git" |
6 | QMSS_LLD_GIT_BRANCH = "master" | ||
7 | QMSS_LLD_GIT_DESTSUFFIX = "git/ti/drv/qmss" | ||
6 | 8 | ||
7 | # commit ID corresponding to DEV.QMSS_LLD.02.01.00.11 | 9 | # commit ID corresponding to DEV.QMSS_LLD.02.01.00.11 |
8 | SRCREV = "2024ab2d411c1a6dd3f5e768a3cb30c2a685f1e4" | 10 | QMSS_LLD_SRCREV = "2024ab2d411c1a6dd3f5e768a3cb30c2a685f1e4" |
11 | |||
12 | BRANCH ="${QMSS_LLD_GIT_BRANCH}" | ||
13 | SRC_URI = "${QMSS_LLD_GIT_URI};destsuffix=${QMSS_LLD_GIT_DESTSUFFIX};protocol=${QMSS_LLD_GIT_PROTOCOL};branch=${BRANCH}" | ||
14 | SRCREV = "${QMSS_LLD_SRCREV}" | ||
15 | |||
9 | PV = "02.01.00.11" | 16 | PV = "02.01.00.11" |
17 | INC_PR = "r1" | ||
10 | 18 | ||
11 | DEVICELIST = "k2h k2k k2l k2e" | 19 | DEVICELIST = "k2h k2k k2l k2e" |
12 | 20 | ||
13 | BASEDIR = "${WORKDIR}/git" | 21 | S = "${WORKDIR}/${QMSS_LLD_GIT_DESTSUFFIX}" |
14 | S = "${BASEDIR}/ti/drv/qmss" | ||
diff --git a/recipes-bsp/qmss-lld/qmss-lld_git.bb b/recipes-bsp/qmss-lld/qmss-lld_git.bb index 38b07621..83c9a7e3 100644 --- a/recipes-bsp/qmss-lld/qmss-lld_git.bb +++ b/recipes-bsp/qmss-lld/qmss-lld_git.bb | |||
@@ -5,6 +5,7 @@ DEPENDS="common-csl-ip rm-lld" | |||
5 | 5 | ||
6 | include qmss-lld.inc | 6 | include qmss-lld.inc |
7 | 7 | ||
8 | PR = "${INC_PR}.0" | ||
8 | 9 | ||
9 | SRC_URI += "file://init_qmss.sh" | 10 | SRC_URI += "file://init_qmss.sh" |
10 | 11 | ||