summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-09-12 01:23:54 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-09-12 16:01:34 +0000
commit5e7d7971cfd9e253db6e984f6c029308a1a8da73 (patch)
tree75c255d9b1cd851e1227fc09f52b65126a658b05 /recipes-bsp
parent7a5897c7e77a4b3e6f459351dcefeb0e5ab8cc19 (diff)
downloadmeta-ti-5e7d7971cfd9e253db6e984f6c029308a1a8da73.tar.gz
ti-sgx-ddk-km: also support arm-oe-linux-gnueabi as a hardfp compiler
OE-built internal toolchain doesn't use "-gnueabihf" suffix and instead uses "-gnueabi" for both softfp and hardfp. For now we only support hardfp (user-space binaries are only available in hardfp), but would be nice to check for "callconvention-hard" before applying the patch. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-km-support-OpenEmbedded-hardfp-toolchain-w-o-gnueabi.patch34
-rw-r--r--recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb4
2 files changed, 37 insertions, 1 deletions
diff --git a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-km-support-OpenEmbedded-hardfp-toolchain-w-o-gnueabi.patch b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-km-support-OpenEmbedded-hardfp-toolchain-w-o-gnueabi.patch
new file mode 100644
index 00000000..071ce0ca
--- /dev/null
+++ b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-km-support-OpenEmbedded-hardfp-toolchain-w-o-gnueabi.patch
@@ -0,0 +1,34 @@
1From 755632b4f3a40996a12bc7816a9839af7112040a Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Mon, 9 Sep 2019 17:05:48 -0400
4Subject: [PATCH] km: support OpenEmbedded hardfp toolchain w/o -gnueabihf
5 suffix
6
7Signed-off-by: Denys Dmytriyenko <denys@ti.com>
8---
9 eurasia_km/eurasiacon/build/linux2/config/compiler.mk | 6 +++---
10 1 file changed, 3 insertions(+), 3 deletions(-)
11
12diff --git a/eurasia_km/eurasiacon/build/linux2/config/compiler.mk b/eurasia_km/eurasiacon/build/linux2/config/compiler.mk
13index dead2f9..2ba3e5e 100644
14--- a/eurasia_km/eurasiacon/build/linux2/config/compiler.mk
15+++ b/eurasia_km/eurasiacon/build/linux2/config/compiler.mk
16@@ -68,12 +68,12 @@ define calculate-compiler-preferred-target
17 ifneq ($$(filter aarch64-%,$$($(1)_compiler_preferred_target)),)
18 $(1)_compiler_preferred_target := aarch64-linux-gnu
19 endif
20+ ifneq ($$(filter arm-%-gnueabihf arm-oe-linux-gnueabi,$$($(1)_compiler_preferred_target)),)
21+ $(1)_compiler_preferred_target := arm-linux-gnueabihf
22+ endif
23 ifneq ($$(filter arm-%-gnueabi armv7a-cros-linux-gnueabi armv7hl-redhat-linux-gnueabi,$$($(1)_compiler_preferred_target)),)
24 $(1)_compiler_preferred_target := arm-linux-gnueabi
25 endif
26- ifneq ($$(filter arm-%-gnueabihf,$$($(1)_compiler_preferred_target)),)
27- $(1)_compiler_preferred_target := arm-linux-gnueabihf
28- endif
29 endif
30 endef
31
32--
332.7.4
34
diff --git a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb
index 8338ed71..c8dbe4f5 100644
--- a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb
+++ b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb
@@ -18,7 +18,9 @@ PROVIDES = "virtual/gpudriver"
18 18
19BRANCH = "ti-img-sgx/${PV}/k4.19" 19BRANCH = "ti-img-sgx/${PV}/k4.19"
20 20
21SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-linux.git;protocol=git;branch=${BRANCH}" 21SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-linux.git;protocol=git;branch=${BRANCH} \
22 file://0001-km-support-OpenEmbedded-hardfp-toolchain-w-o-gnueabi.patch \
23"
22 24
23S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
24 26