summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-17 10:27:25 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-17 10:27:25 +0100
commit5c5d12b005038db235534636212d161a07039263 (patch)
treee4868415e6c92c0a8a60436fed944502e36abfda /recipes-bsp
parenta7217aa256adb0df2a93c2fb83583d1f90bd9e94 (diff)
downloadmeta-ti-5c5d12b005038db235534636212d161a07039263.tar.gz
u-boot 2011.10rc: enable i2c2 for beaglebone
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.09git/0009-am335x-evm-enable-i2c2-pinmux-for-beaglebone.patch63
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.10rc.bb3
2 files changed, 65 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0009-am335x-evm-enable-i2c2-pinmux-for-beaglebone.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0009-am335x-evm-enable-i2c2-pinmux-for-beaglebone.patch
new file mode 100644
index 00000000..b97fa16b
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.09git/0009-am335x-evm-enable-i2c2-pinmux-for-beaglebone.patch
@@ -0,0 +1,63 @@
1From 2df6e88944b98466e0b1225a873bfed005cea4e4 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Wed, 16 Nov 2011 18:57:12 +0100
4Subject: [PATCH] am335x-evm: enable i2c2 pinmux for beaglebone
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 board/ti/am335x/mux.c | 18 ++++++++++++++++++
9 1 files changed, 18 insertions(+), 0 deletions(-)
10
11diff --git a/board/ti/am335x/mux.c b/board/ti/am335x/mux.c
12index d9956f3..313d5a5 100644
13--- a/board/ti/am335x/mux.c
14+++ b/board/ti/am335x/mux.c
15@@ -309,6 +309,12 @@ static struct module_pin_mux i2c1_pin_mux[] = {
16 {-1},
17 };
18
19+static struct module_pin_mux i2c2_pin_mux[] = {
20+ {OFFSET(uart1_ctsn), (MODE(3) | RXACTIVE | PULLUDEN | SLEWCTRL)}, /* I2C_DATA */
21+ {OFFSET(uart1_rtsn), (MODE(3) | RXACTIVE | PULLUDEN | SLEWCTRL)}, /* I2C_SCLK */
22+ {-1},
23+};
24+
25 #ifndef CONFIG_NO_ETH
26 static struct module_pin_mux rgmii1_pin_mux[] = {
27 {OFFSET(mii1_txen), MODE(2)}, /* RGMII1_TCTL */
28@@ -568,6 +574,7 @@ static struct evm_pin_mux low_cost_evm_pin_mux[] = {
29 static struct evm_pin_mux beaglebone_pin_mux[] = {
30 {uart0_pin_mux, PROFILE_ALL, DEV_ON_BASEBOARD},
31 {i2c1_pin_mux, PROFILE_ALL & ~PROFILE_2 & ~PROFILE_4, DEV_ON_BASEBOARD},
32+ {i2c2_pin_mux, PROFILE_ALL, DEV_ON_BASEBOARD},
33 #ifdef CONFIG_NAND
34 {nand_pin_mux, PROFILE_ALL & ~PROFILE_2 & ~PROFILE_3, DEV_ON_DGHTR_BRD},
35 #endif
36@@ -587,6 +594,7 @@ static struct evm_pin_mux beaglebone_pin_mux[] = {
37 static struct evm_pin_mux beaglebone_old_pin_mux[] = {
38 {uart0_pin_mux, PROFILE_ALL, DEV_ON_BASEBOARD},
39 {i2c1_pin_mux, PROFILE_ALL & ~PROFILE_2 & ~PROFILE_4, DEV_ON_BASEBOARD},
40+ {i2c2_pin_mux, PROFILE_ALL, DEV_ON_BASEBOARD},
41 #ifdef CONFIG_NAND
42 {nand_pin_mux, PROFILE_ALL & ~PROFILE_2 & ~PROFILE_3, DEV_ON_DGHTR_BRD},
43 #endif
44@@ -682,6 +690,16 @@ void enable_i2c0_pin_mux(void)
45 configure_module_pin_mux(i2c0_pin_mux);
46 }
47
48+void enable_i2c1_pin_mux(void)
49+{
50+ configure_module_pin_mux(i2c1_pin_mux);
51+}
52+
53+void enable_i2c2_pin_mux(void)
54+{
55+ configure_module_pin_mux(i2c2_pin_mux);
56+}
57+
58 void enable_uart0_pin_mux(void)
59 {
60 configure_module_pin_mux(uart0_pin_mux);
61--
621.7.2.5
63
diff --git a/recipes-bsp/u-boot/u-boot_2011.10rc.bb b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
index 51f71843..ebcb3530 100644
--- a/recipes-bsp/u-boot/u-boot_2011.10rc.bb
+++ b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
@@ -4,7 +4,7 @@ require u-boot.inc
4COMPATIBLE_MACHINE = "(ti33x)" 4COMPATIBLE_MACHINE = "(ti33x)"
5DEFAULT_PREFERENCE_ti33x = "99" 5DEFAULT_PREFERENCE_ti33x = "99"
6PV = "2011.09+git" 6PV = "2011.09+git"
7PR = "r24" 7PR = "r25"
8 8
9# SPL build 9# SPL build
10UBOOT_BINARY = "u-boot.img" 10UBOOT_BINARY = "u-boot.img"
@@ -20,6 +20,7 @@ SRC_URI = "git://arago-project.org/git/projects/u-boot-am33x.git;protocol=git;br
20 file://2011.09git/0006-am335x-evm-Fix-bone-pmic-shut-down-over-USB-power.patch \ 20 file://2011.09git/0006-am335x-evm-Fix-bone-pmic-shut-down-over-USB-power.patch \
21 file://2011.09git/0007-am335x_evm-switch-to-ext4.patch \ 21 file://2011.09git/0007-am335x_evm-switch-to-ext4.patch \
22 file://2011.09git/0008-HACK-am335x-evm-turn-d-cache-on-globally-turn-it-off.patch \ 22 file://2011.09git/0008-HACK-am335x-evm-turn-d-cache-on-globally-turn-it-off.patch \
23 file://2011.09git/0009-am335x-evm-enable-i2c2-pinmux-for-beaglebone.patch \
23 " 24 "
24 25
25SRCREV = "f63b270e47f62f4d1a05b2001357e215966c6f5a" 26SRCREV = "f63b270e47f62f4d1a05b2001357e215966c6f5a"