summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2015-05-27 20:10:38 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-06-01 10:47:44 -0400
commit7a9e78f4eacd66fe2224bf3b9920eee0c2fad71a (patch)
tree43ec5617e3da5001c538d36b01543ea9187d6852 /recipes-bsp
parentabe45eb438a06d9f0f1d57f3006c2c31b3461689 (diff)
downloadmeta-ti-7a9e78f4eacd66fe2224bf3b9920eee0c2fad71a.tar.gz
common-csl-ip-rtos: Add CSL RTOS package.
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb b/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb
new file mode 100644
index 00000000..5d4a552a
--- /dev/null
+++ b/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb
@@ -0,0 +1,33 @@
1require common-csl-ip.inc
2
3require recipes-ti/includes/ti-paths.inc
4require recipes-ti/includes/ti-staging.inc
5
6DEPENDS = "ti-xdctools ti-cgt6x-native ti-sysbios"
7
8S = "${WORKDIR}/ti/csl"
9
10export C6X_GEN_INSTALL_PATH="${STAGING_DIR_NATIVE}/usr"
11export XDCCGROOT="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x"
12export XDCPATH="${XDCCGROOT}/include;${XDC_INSTALL_DIR}/packages;${SYSBIOS_INSTALL_DIR}/packages"
13
14do_configure() {
15 sed -i "s/\ \"\.\\\\\\\\\"\ +//" src/Module.xs
16 find -name "*.xs" -exec sed -i "s/ofd6x\.exe/ofd6x/" {} \;
17 find -name "*.xs" -exec sed -i "s/sectti\.exe/sectti/" {} \;
18 find -name "*.xs" -exec sed -i "/\.chm/d" {} \;
19 find -name "*.xs" -exec sed -i "s/pasm\_dos/pasm\_linux/" {} \;
20}
21
22do_compile() {
23 ${XDC_INSTALL_DIR}/xdc .make
24 ${XDC_INSTALL_DIR}/xdc clean
25 ${XDC_INSTALL_DIR}/xdc release
26}
27
28do_install () {
29 install -d ${D}${PDK_INSTALL_DIR_RECIPE}/packages
30 find -name "*.tar" -exec tar xf {} -C ${D}${PDK_INSTALL_DIR_RECIPE}/packages \;
31}
32
33FILES_${PN} += "${PDK_INSTALL_DIR_RECIPE}/packages"