summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-01-13 12:19:52 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-01-13 12:23:17 +0100
commite9ca621a1bcab5bde5486d0e14439825f64c72e8 (patch)
treeec3d44a24fff879cc5615b9b9f74f8970bceee88 /recipes-bsp
parentc931af08075d36803e8124db4b1eaf2b3ed28a3e (diff)
downloadmeta-ti-e9ca621a1bcab5bde5486d0e14439825f64c72e8.tar.gz
TI-BSP: import matrix from OE
Added license checksums as well Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/ti/am-sysinfo_svn.bb24
-rw-r--r--recipes-bsp/ti/matrix-gui-common.inc42
-rw-r--r--recipes-bsp/ti/matrix-gui-common_1.3.bb8
-rw-r--r--recipes-bsp/ti/matrix-gui-common_1.4.bb8
-rw-r--r--recipes-bsp/ti/matrix-gui-e.inc47
-rw-r--r--recipes-bsp/ti/matrix-gui-e_1.3.bb5
-rw-r--r--recipes-bsp/ti/matrix-gui.inc50
-rw-r--r--recipes-bsp/ti/matrix-gui_1.3.bb4
-rw-r--r--recipes-bsp/ti/matrix-tui.inc52
-rwxr-xr-xrecipes-bsp/ti/matrix-tui/init24
10 files changed, 264 insertions, 0 deletions
diff --git a/recipes-bsp/ti/am-sysinfo_svn.bb b/recipes-bsp/ti/am-sysinfo_svn.bb
new file mode 100644
index 00000000..34830c95
--- /dev/null
+++ b/recipes-bsp/ti/am-sysinfo_svn.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "AM SysInfo"
2HOMEPAGE = "https://gforge.ti.com/gf/project/am_sysinfo/"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://mem_util/mem_util.c;beginline=1;endline=37;md5=8aa8e714ab729cfe8177298af8a5a25d"
5
6SECTION = "system"
7PRIORITY = "optional"
8
9SRCREV = "5"
10PV = "1.0"
11PR = "r1+svnr${SRCPV}"
12
13SRC_URI = "svn://gforge.ti.com/svn/am_sysinfo/;module=trunk;proto=https;user=anonymous;pswd=''"
14
15S = "${WORKDIR}/trunk"
16
17do_compile() {
18 ${CC} ${CFLAGS} ${LDFLAGS} -o mem_util/mem_util mem_util/mem_util.c
19}
20
21do_install() {
22 install -d ${D}/${bindir}
23 install -m 0755 ${S}/mem_util/mem_util ${D}/${bindir}
24}
diff --git a/recipes-bsp/ti/matrix-gui-common.inc b/recipes-bsp/ti/matrix-gui-common.inc
new file mode 100644
index 00000000..58f41d01
--- /dev/null
+++ b/recipes-bsp/ti/matrix-gui-common.inc
@@ -0,0 +1,42 @@
1DESCRIPTION = "Common files for all versions of Matrix GUI"
2HOMEPAGE = "https://gforge.ti.com/gf/project/matrix_gui/"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://main.cpp;beginline=1;endline=37;md5=a802a01a3a58f2ebb1e83c25f883f0c0"
5
6SECTION = "multimedia"
7PRIORITY = "optional"
8
9INC_PR = "r6"
10
11COMPATIBLE_MACHINE = "(dm365|omapl138|omap3|ti816x)"
12
13PLATFORM_dm365 = "dm365"
14PLATFORM_omapl138 = "omapl138"
15PLATFORM_omap3evm = "omap3530"
16PLATFORM_dm37x-evm = "dm3730"
17PLATFORM_am37x-evm = "am3715"
18PLATFORM_beagleboard = "am3715"
19PLATFORM_ti816x = "ti816x"
20PLATFORM_am180x-evm = "am180x"
21PLATFORM_am181x-evm = "am181x"
22PLATFORM_am3517-evm = "am3517"
23
24#Checkout the project repository to get access to the scripts and data
25#files.
26SRC_URI = "svn://gforge.ti.com/svn/matrix_gui/;module=trunk;proto=https;user=anonymous;pswd='' "
27
28S = "${WORKDIR}/trunk"
29
30PACKAGE_ARCH = ${MACHINE_ARCH}
31
32do_install() {
33 install -d ${D}/${bindir}
34 install -m 0755 ${S}/${PLATFORM}/bin/* ${D}/${bindir}/
35 install -d ${D}/${datadir}/matrix/html
36 install -m 0644 ${S}/${PLATFORM}/html/* ${D}/${datadir}/matrix/html
37 install -d ${D}/${datadir}/matrix/images
38 install -m 0644 ${S}/images/*.png ${D}/${datadir}/matrix/images/
39
40}
41
42FILES_${PN} += "${datadir}/matrix/*"
diff --git a/recipes-bsp/ti/matrix-gui-common_1.3.bb b/recipes-bsp/ti/matrix-gui-common_1.3.bb
new file mode 100644
index 00000000..a879720e
--- /dev/null
+++ b/recipes-bsp/ti/matrix-gui-common_1.3.bb
@@ -0,0 +1,8 @@
1require matrix-gui-common.inc
2
3# Use the mem_util application from am-sysinfo instead of a
4# prebuilt version in the repository.
5RRECOMMENDS_${PN} = "am-sysinfo"
6
7SRCREV = "156"
8PR = "${INC_PR}.0"
diff --git a/recipes-bsp/ti/matrix-gui-common_1.4.bb b/recipes-bsp/ti/matrix-gui-common_1.4.bb
new file mode 100644
index 00000000..c578a47b
--- /dev/null
+++ b/recipes-bsp/ti/matrix-gui-common_1.4.bb
@@ -0,0 +1,8 @@
1require matrix-gui-common.inc
2
3# Use the mem_util application from am-sysinfo instead of a
4# prebuilt version in the repository.
5RRECOMMENDS_${PN} = "am-sysinfo"
6
7SRCREV = "192"
8PR = "${INC_PR}.0"
diff --git a/recipes-bsp/ti/matrix-gui-e.inc b/recipes-bsp/ti/matrix-gui-e.inc
new file mode 100644
index 00000000..a04327b2
--- /dev/null
+++ b/recipes-bsp/ti/matrix-gui-e.inc
@@ -0,0 +1,47 @@
1DESCRIPTION = "Matrix GUI for Qt Embedded"
2HOMEPAGE = "https://gforge.ti.com/gf/project/matrix_gui/"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://main.cpp;beginline=1;endline=37;md5=a802a01a3a58f2ebb1e83c25f883f0c0"
5
6SECTION = "multimedia"
7PRIORITY = "optional"
8
9INC_PR = "r21"
10
11COMPATIBLE_MACHINE = "(dm365|omapl138|omap3|ti816x)"
12
13PLATFORM_dm365 = "dm365"
14PLATFORM_omapl138 = "omapl138"
15PLATFORM_omap3evm = "omap3530"
16PLATFORM_dm37x-evm = "dm3730"
17PLATFORM_am37x-evm = "am3715"
18PLATFORM_beagleboard = "am3715"
19PLATFORM_ti816x = "ti816x"
20PLATFORM_am180x-evm = "am180x"
21PLATFORM_am181x-evm = "am181x"
22PLATFORM_am3517-evm = "am3517"
23
24SRC_URI = "svn://gforge.ti.com/svn/matrix_gui/;module=trunk;proto=https;user=anonymous;pswd='' "
25
26S = "${WORKDIR}/trunk"
27
28INITSCRIPT_NAME = "matrix-gui-e"
29INITSCRIPT_PARAMS = "defaults 99"
30#INITSCRIPT_PARAMS = "start 99 3 . stop 99 3 ."
31
32CXXFLAGS_omapl138_append = " -DPlatform_omapl138 "
33CXXFLAGS_dm365_append = " -DPlatform_dm365 "
34PACKAGE_ARCH = ${MACHINE_ARCH}
35
36inherit qt4e update-rc.d
37
38do_install() {
39 install -d ${D}/${bindir}
40 install -m 0755 ${S}/matrix_gui ${D}/${bindir}/matrix_guiE
41 install -d ${D}${sysconfdir}/init.d/
42 install -c -m 0755 ${S}/${PLATFORM}/etc/init ${D}${sysconfdir}/init.d/matrix-gui-e
43
44}
45
46RRECOMMENDS_${PN} = "qt4-embedded-plugin-mousedriver-tslib qt4-embedded-fonts"
47RDEPENDS_${PN} += "matrix-gui-common"
diff --git a/recipes-bsp/ti/matrix-gui-e_1.3.bb b/recipes-bsp/ti/matrix-gui-e_1.3.bb
new file mode 100644
index 00000000..dd1b16b4
--- /dev/null
+++ b/recipes-bsp/ti/matrix-gui-e_1.3.bb
@@ -0,0 +1,5 @@
1require matrix-gui-e.inc
2
3SRCREV = "192"
4PR = "${INC_PR}.0"
5
diff --git a/recipes-bsp/ti/matrix-gui.inc b/recipes-bsp/ti/matrix-gui.inc
new file mode 100644
index 00000000..1b2968ed
--- /dev/null
+++ b/recipes-bsp/ti/matrix-gui.inc
@@ -0,0 +1,50 @@
1DESCRIPTION = "Matrix GUI for Qt X11"
2HOMEPAGE = "https://gforge.ti.com/gf/project/matrix_gui/"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://main.cpp;beginline=1;endline=37;md5=a802a01a3a58f2ebb1e83c25f883f0c0"
5
6SECTION = "multimedia"
7PRIORITY = "optional"
8
9INC_PR = "r19"
10
11COMPATIBLE_MACHINE = "(dm365|omapl138|omap3|ti816x)"
12
13PLATFORM_dm365 = "dm365"
14PLATFORM_omapl138 = "omapl138"
15PLATFORM_omap3evm = "omap3530"
16PLATFORM_dm37x-evm = "dm3730"
17PLATFORM_am37x-evm = "am3715"
18PLATFORM_beagleboard = "am3715"
19PLATFORM_ti816x = "ti816x"
20PLATFORM_am180x-evm = "am180x"
21PLATFORM_am181x-evm = "am181x"
22PLATFORM_am3517-evm = "am3517"
23
24SRC_URI = "svn://gforge.ti.com/svn/matrix_gui/;module=trunk;proto=https;user=anonymous;pswd='' "
25
26S = "${WORKDIR}/trunk"
27
28CXXFLAGS_omapl138_append = " -DPlatform_omapl138 "
29CXXFLAGS_dm365_append = " -DPlatform_dm365 "
30PACKAGE_ARCH = ${MACHINE_ARCH}
31
32inherit qt4x11
33
34do_install() {
35 install -d ${D}/${bindir}
36 install -m 0755 ${S}/matrix_gui ${D}/${bindir}
37 install -d ${D}${sysconfdir}/init.d/
38 install -c -m 0755 ${S}/${PLATFORM}/etc/x11/init ${D}${sysconfdir}/init.d/matrix-gui
39 install -d ${D}/${sysconfdir}/xdg/autostart
40 install -m 0755 ${S}/${PLATFORM}/etc/x11/matrix-gui.desktop ${D}/${sysconfdir}/xdg/autostart
41}
42
43FILES_${PN}-autostart = "${sysconfdir}/xdg/autostart/matrix-gui.desktop"
44
45#Make autostart package depend on matrix-gui package. Doesn't make sense
46#to install the autostart package without the underlying matrix-gui package.
47RDEPENDS_${PN}-autostart += "${PN}"
48PACKAGES =+ "${PN}-autostart"
49
50RDEPENDS_${PN} += "matrix-gui-common"
diff --git a/recipes-bsp/ti/matrix-gui_1.3.bb b/recipes-bsp/ti/matrix-gui_1.3.bb
new file mode 100644
index 00000000..53db8af1
--- /dev/null
+++ b/recipes-bsp/ti/matrix-gui_1.3.bb
@@ -0,0 +1,4 @@
1require matrix-gui.inc
2
3SRCREV = "192"
4PR = "${INC_PR}.0"
diff --git a/recipes-bsp/ti/matrix-tui.inc b/recipes-bsp/ti/matrix-tui.inc
new file mode 100644
index 00000000..1ad8aa89
--- /dev/null
+++ b/recipes-bsp/ti/matrix-tui.inc
@@ -0,0 +1,52 @@
1DESCRIPTION = "Matrix TUI"
2HOMEPAGE = "https://gforge.ti.com/gf/project/matrix_tui/"
3LICENSE = "BSD"
4SECTION = "multimedia"
5PRIORITY = "optional"
6DEPENDS = "libxml2 zlib ncurses"
7
8INC_PR = "r7"
9
10COMPATIBLE_MACHINE = "(omapl138|omap3)"
11
12PLATFORM_am37x-evm = "am3715"
13PLATFORM_beagleboard = "am3715"
14PLATFORM_am3517-evm = "am3517"
15PLATFORM_am180x-evm = "am180x"
16PLATFORM_am181x-evm = "am181x"
17PLATFORM_da850-omapl138-evm = "am180x"
18
19SRC_URI = "svn://gforge.ti.com/svn/matrix_tui/;module=trunk;proto=https;user=anonymous;pswd='' \
20 file://init \
21"
22
23S = "${WORKDIR}/trunk"
24
25# Do not auto-start TUI by default, uncomment otherwise
26#inherit update-rc.d
27#INITSCRIPT_NAME = "matrix-tui"
28#INITSCRIPT_PARAMS = "defaults 99"
29
30do_configure() {
31 sed -i -e 's:PATH=${LINUX_DEVKIT_PATH}/arm-none-linux-gnueabi:PATH ?= ${LINUX_DEVKIT_PATH}/arm-none-linux-gnueabi:' makefile.init
32 sed -i -e 's|LIBS :=|LIBS := ${LDFLAGS} |' Release/objects.mk
33}
34
35do_compile() {
36 # don't build debug version
37 touch debug
38 export CROSS_COMPILE=${TARGET_PREFIX}
39 export TUI_INCLUDE_PATH=${STAGING_INCDIR}
40 export XML_INCLUDE_PATH=${STAGING_INCDIR}/libxml2
41 export TUI_LIB_PATH=${STAGING_LIBDIR}
42 make release
43}
44
45do_install() {
46 export PLATFORM=${PLATFORM}
47 make DESTDIR=${D} install
48 install -d ${D}${sysconfdir}/init.d/
49 install -c -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/matrix-tui
50}
51
52FILES_${PN} += "${datadir}/matrix/*"
diff --git a/recipes-bsp/ti/matrix-tui/init b/recipes-bsp/ti/matrix-tui/init
new file mode 100755
index 00000000..e5813825
--- /dev/null
+++ b/recipes-bsp/ti/matrix-tui/init
@@ -0,0 +1,24 @@
1#! /bin/sh
2
3matrixtui="/usr/bin/matrix_tui"
4TUI_OPTS="/usr/share/matrix/xml/matrix.xml"
5
6test -x "$matrixtui" || exit 0
7
8case "$1" in
9 start)
10 echo -n "Starting Matrix TUI application"
11 start-stop-daemon --start --quiet --background --pidfile /var/run/matrix-tui.pid --exec $matrixtui -- $TUI_OPTS
12 echo "."
13 ;;
14 stop)
15 echo -n "Stopping Matrix TUI application"
16 start-stop-daemon --stop --quiet --pidfile /var/run/matrix-tui.pid
17 echo "."
18 ;;
19 *)
20 echo "Usage: /etc/init.d/matrix-tui {start|stop}"
21 exit 1
22esac
23
24exit 0