summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorGou, Hongmei <h-gou@ti.com>2017-07-12 01:09:28 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-09-05 17:58:50 -0400
commit6f783a4592375f0a10b611a49097adff61316bfe (patch)
tree2a3db34a8dbbc84d439cdda60d78b9767ca841f9 /recipes-bsp
parent350ccbc9a81b5765cba1ce45ba87f00b157700f9 (diff)
downloadmeta-ti-6f783a4592375f0a10b611a49097adff61316bfe.tar.gz
icss-emac-lld*: upstream version 1.0.0.7C with recipes for linux user space
Signed-off-by: Hongmei Gou <h-gou@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/icss-emac-lld/icss-emac-lld-test_git.bb47
-rw-r--r--recipes-bsp/icss-emac-lld/icss-emac-lld.inc22
-rw-r--r--recipes-bsp/icss-emac-lld/icss-emac-lld_git.bb26
3 files changed, 95 insertions, 0 deletions
diff --git a/recipes-bsp/icss-emac-lld/icss-emac-lld-test_git.bb b/recipes-bsp/icss-emac-lld/icss-emac-lld-test_git.bb
new file mode 100644
index 00000000..f62bf332
--- /dev/null
+++ b/recipes-bsp/icss-emac-lld/icss-emac-lld-test_git.bb
@@ -0,0 +1,47 @@
1DESCRIPTION = "TI ICSS-EMAC low level driver tests"
2
3DEPENDS="common-csl-ip pruss-lld icss-emac-lld osal"
4
5DEPENDS_append_ti33x = " starterware"
6DEPENDS_append_ti43x = " starterware"
7
8include icss-emac-lld.inc
9
10PR = "${INC_PR}.0"
11
12COMPATIBLE_MACHINE = "am57xx-evm|ti33x|ti43x"
13
14EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} ICSS_EMAC_SRC_DIR=${S}"
15
16do_compile_am57xx-evm () {
17# Build the tests
18 oe_runmake tests DEVICE="am571x" TARGET="SOC_AM571x"
19 oe_runmake clean
20 oe_runmake tests DEVICE="am572x" TARGET="SOC_AM572x"
21}
22
23do_compile_ti33x () {
24# Build the tests
25 oe_runmake tests DEVICE="am335x" TARGET="SOC_AM335x"
26}
27
28do_compile_ti43x () {
29# Build the tests
30 oe_runmake tests DEVICE="am437x" TARGET="SOC_AM437x"
31}
32
33do_install_am57xx-evm () {
34# Install the binary
35 oe_runmake installbin INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="am571x" TARGET="SOC_AM571x"
36 oe_runmake installbin INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="am572x" TARGET="SOC_AM572x"
37}
38
39do_install_ti33x () {
40# Install the binary
41 oe_runmake installbin INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="am335x" TARGET="SOC_AM335x"
42}
43
44do_install_ti43x () {
45# Install the binary
46 oe_runmake installbin INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="am437x" TARGET="SOC_AM437x"
47}
diff --git a/recipes-bsp/icss-emac-lld/icss-emac-lld.inc b/recipes-bsp/icss-emac-lld/icss-emac-lld.inc
new file mode 100644
index 00000000..8e2ffd4b
--- /dev/null
+++ b/recipes-bsp/icss-emac-lld/icss-emac-lld.inc
@@ -0,0 +1,22 @@
1LICENSE = "BSD-3-Clause"
2LIC_FILES_CHKSUM = "file://icss_emacDrv.h;beginline=1;endline=40;md5=88d270788c1d8516511304f11a28586d"
3
4COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|k2g-evm"
5PACKAGE_ARCH = "${MACHINE_ARCH}"
6
7ICSS_EMAC_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/icss-emac.git"
8ICSS_EMAC_LLD_GIT_PROTOCOL = "git"
9ICSS_EMAC_LLD_GIT_BRANCH = "master"
10ICSS_EMAC_LLD_GIT_DESTSUFFIX = "git/ti/drv/icss_emac"
11
12# Below commit ID corresponds to "DEV.ICSS_EMAC_LLD.01.00.00.07C"
13ICSS_EMAC_LLD_SRCREV = "08cb0540eeab7721fe82b603cb6285393f314117"
14
15BRANCH = "${ICSS_EMAC_LLD_GIT_BRANCH}"
16SRC_URI = "${ICSS_EMAC_LLD_GIT_URI};destsuffix=${ICSS_EMAC_LLD_GIT_DESTSUFFIX};protocol=${ICSS_EMAC_LLD_GIT_PROTOCOL};branch=${BRANCH}"
17
18SRCREV = "${ICSS_EMAC_LLD_SRCREV}"
19PV = "01.00.00.07C"
20INC_PR = "r0"
21
22S = "${WORKDIR}/${ICSS_EMAC_LLD_GIT_DESTSUFFIX}"
diff --git a/recipes-bsp/icss-emac-lld/icss-emac-lld_git.bb b/recipes-bsp/icss-emac-lld/icss-emac-lld_git.bb
new file mode 100644
index 00000000..272529b1
--- /dev/null
+++ b/recipes-bsp/icss-emac-lld/icss-emac-lld_git.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "TI ICSS-EMAC low level driver library"
2
3DEPENDS="common-csl-ip pruss-lld osal"
4
5include icss-emac-lld.inc
6
7PR = "${INC_PR}.0"
8
9COMPATIBLE_MACHINE = "am57xx-evm|ti33x|ti43x"
10
11TARGET_NAME_am57xx-evm = "SOC_AM572x"
12TARGET_NAME_ti33x = "SOC_AM335x"
13TARGET_NAME_ti43x = "SOC_AM437x"
14
15EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} TARGET=${TARGET_NAME}"
16
17do_compile () {
18# Build the lib
19 oe_runmake clean
20 oe_runmake lib
21}
22
23do_install () {
24# Install the lib
25 oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
26}