diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2015-02-26 01:23:55 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-02-26 12:12:11 -0500 |
commit | b490d090a1bb1f7fd0f4ecc507bb4518167ba72d (patch) | |
tree | ee13c032cc66c6d36f93af0b66eac1edbc3684d3 /recipes-bsp | |
parent | fe7542b7c5e13d802cf0c1367fe7c7487e89de01 (diff) | |
download | meta-ti-b490d090a1bb1f7fd0f4ecc507bb4518167ba72d.tar.gz |
cmem: Bump version to 4.10.0.1 and enable autoload of module.
* This version introduces the ability to configure CMEM through
the device tree.
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/cmem/cmem-mod_git.bb | 4 | ||||
-rw-r--r-- | recipes-bsp/cmem/cmem.inc | 6 | ||||
-rw-r--r-- | recipes-bsp/cmem/cmem_git.bb | 2 |
3 files changed, 7 insertions, 5 deletions
diff --git a/recipes-bsp/cmem/cmem-mod_git.bb b/recipes-bsp/cmem/cmem-mod_git.bb index 2bdf9c00..0cc0b464 100644 --- a/recipes-bsp/cmem/cmem-mod_git.bb +++ b/recipes-bsp/cmem/cmem-mod_git.bb | |||
@@ -3,10 +3,12 @@ DESCRIPTION = "Kernel module for contiguous memory allocation from userspace" | |||
3 | include cmem.inc | 3 | include cmem.inc |
4 | 4 | ||
5 | # This package builds a kernel module, use kernel PR as base and append a local | 5 | # This package builds a kernel module, use kernel PR as base and append a local |
6 | MACHINE_KERNEL_PR_append = "a+gitr${SRCPV}" | 6 | MACHINE_KERNEL_PR_append = "b+gitr${SRCPV}" |
7 | PR = "${MACHINE_KERNEL_PR}" | 7 | PR = "${MACHINE_KERNEL_PR}" |
8 | 8 | ||
9 | inherit module | 9 | inherit module |
10 | 10 | ||
11 | EXTRA_OEMAKE += '-f lu.mak KERNEL_INSTALL_DIR="${STAGING_KERNEL_DIR}" TOOLCHAIN_PREFIX="${TOOLCHAIN_PREFIX}" EXEC_DIR="${D}/lib/modules/${KERNEL_VERSION}/extra"' | 11 | EXTRA_OEMAKE += '-f lu.mak KERNEL_INSTALL_DIR="${STAGING_KERNEL_DIR}" TOOLCHAIN_PREFIX="${TOOLCHAIN_PREFIX}" EXEC_DIR="${D}/lib/modules/${KERNEL_VERSION}/extra"' |
12 | MAKE_TARGETS = "module" | 12 | MAKE_TARGETS = "module" |
13 | |||
14 | module_autoload_cmemk = "cmemk" | ||
diff --git a/recipes-bsp/cmem/cmem.inc b/recipes-bsp/cmem/cmem.inc index 79278398..ff7a8a04 100644 --- a/recipes-bsp/cmem/cmem.inc +++ b/recipes-bsp/cmem/cmem.inc | |||
@@ -1,11 +1,11 @@ | |||
1 | HOMEPAGE = "http://processors.wiki.ti.com/index.php/Category:CMEM" | 1 | HOMEPAGE = "http://processors.wiki.ti.com/index.php/Category:CMEM" |
2 | 2 | ||
3 | LICENSE = "GPLv2" | 3 | LICENSE = "GPLv2" |
4 | LIC_FILES_CHKSUM = "file://include/ti/cmem.h;beginline=1;endline=30;md5=b86138d4028fb8310b3b983024edc620" | 4 | LIC_FILES_CHKSUM = "file://include/ti/cmem.h;beginline=1;endline=30;md5=9b745e2765a6ba8a636c91aed4b02ac1" |
5 | 5 | ||
6 | BRANCH ?= "master" | 6 | BRANCH ?= "master" |
7 | # This corresponds to version 4.00.01.08 | 7 | # This corresponds to version 4.10.00.01 |
8 | SRCREV = "0b68dfe9f155a1978cdb2178e052dc0d6f1e705b" | 8 | SRCREV = "0d2fac7187ca1f6af62a98dee5b3621908cf5831" |
9 | 9 | ||
10 | SRC_URI = "git://git.ti.com/ipc/ludev.git;protocol=git;branch=${BRANCH}" | 10 | SRC_URI = "git://git.ti.com/ipc/ludev.git;protocol=git;branch=${BRANCH}" |
11 | 11 | ||
diff --git a/recipes-bsp/cmem/cmem_git.bb b/recipes-bsp/cmem/cmem_git.bb index b633d74a..540c2f63 100644 --- a/recipes-bsp/cmem/cmem_git.bb +++ b/recipes-bsp/cmem/cmem_git.bb | |||
@@ -4,7 +4,7 @@ include cmem.inc | |||
4 | 4 | ||
5 | RDEPENDS_${PN} = "cmem-mod" | 5 | RDEPENDS_${PN} = "cmem-mod" |
6 | 6 | ||
7 | PR = "r0+gitr${SRCPV}" | 7 | PR = "r1+gitr${SRCPV}" |
8 | 8 | ||
9 | PACKAGES =+ "${PN}-test" | 9 | PACKAGES =+ "${PN}-test" |
10 | 10 | ||