summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-03-02 03:07:54 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-03-01 21:06:30 +0000
commit3626c169121796728ebf5926eaf5c0ff5e3fd067 (patch)
treee158f1967c75ed01560bc73b0540929dad599ccd /recipes-bsp
parent84b3ff8da8311138e534cfb8930c08aa4b417c3e (diff)
downloadmeta-ti-3626c169121796728ebf5926eaf5c0ff5e3fd067.tar.gz
ti-sgx-ddk: remove old 1.14 version of DDK KM and UM
DDK 1.17 is now supported for same platforms. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-buildvars.mk-pass-Wno-cast-function-type.patch26
-rw-r--r--recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-srvkm-env-linux-osfunc.c-fix-gcc8-stringop-truncatio.patch34
-rw-r--r--recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.14.3699939.bb45
3 files changed, 0 insertions, 105 deletions
diff --git a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-buildvars.mk-pass-Wno-cast-function-type.patch b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-buildvars.mk-pass-Wno-cast-function-type.patch
deleted file mode 100644
index e1d2d10d..00000000
--- a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-buildvars.mk-pass-Wno-cast-function-type.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1From 287ca27cdf9004b4ba9bb0ce30d6139f707246f9 Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Sun, 14 Oct 2018 19:53:14 -0400
4Subject: [PATCH] buildvars.mk: pass -Wno-cast-function-type
5
6Signed-off-by: Denys Dmytriyenko <denys@ti.com>
7---
8 eurasia_km/eurasiacon/build/linux2/buildvars.mk | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/eurasia_km/eurasiacon/build/linux2/buildvars.mk b/eurasia_km/eurasiacon/build/linux2/buildvars.mk
12index f30e467..f00f852 100644
13--- a/eurasia_km/eurasiacon/build/linux2/buildvars.mk
14+++ b/eurasia_km/eurasiacon/build/linux2/buildvars.mk
15@@ -48,7 +48,7 @@
16
17 # These flags are used for kernel, User C and User C++
18 #
19-COMMON_FLAGS := -W -Wall
20+COMMON_FLAGS := -W -Wall -Wno-cast-function-type
21
22 # Some GCC warnings are C only, so we must mask them from C++
23 #
24--
252.7.4
26
diff --git a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-srvkm-env-linux-osfunc.c-fix-gcc8-stringop-truncatio.patch b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-srvkm-env-linux-osfunc.c-fix-gcc8-stringop-truncatio.patch
deleted file mode 100644
index 96e657d0..00000000
--- a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-srvkm-env-linux-osfunc.c-fix-gcc8-stringop-truncatio.patch
+++ /dev/null
@@ -1,34 +0,0 @@
1From 353d8b9313abc492e5938171cea4ac697fd991f0 Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Sun, 14 Oct 2018 19:41:49 -0400
4Subject: [PATCH] srvkm/env/linux/osfunc.c: fix gcc8 stringop-truncation error
5
6gcc8 now checks for strncpy function that potentially truncate the terminating
7NUL charcter from the source string. Fails like this:
8
9.../services4/srvkm/env/linux/osfunc.c:3051:13: error: 'strncpy' specified bound 50 equals destination size [-Werror=stringop-truncation]
10| strncpy(psEventObject->szName, pszName, EVENTOBJNAME_MAXLENGTH);
11| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
12| cc1: all warnings being treated as errors
13
14Signed-off-by: Denys Dmytriyenko <denys@ti.com>
15---
16 eurasia_km/services4/srvkm/env/linux/osfunc.c | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/eurasia_km/services4/srvkm/env/linux/osfunc.c b/eurasia_km/services4/srvkm/env/linux/osfunc.c
20index 02dfe9b..02c8e3b 100644
21--- a/eurasia_km/services4/srvkm/env/linux/osfunc.c
22+++ b/eurasia_km/services4/srvkm/env/linux/osfunc.c
23@@ -3048,7 +3048,7 @@ PVRSRV_ERROR OSEventObjectCreateKM(const IMG_CHAR *pszName, PVRSRV_EVENTOBJECT *
24 if(pszName)
25 {
26 /* copy over the event object name */
27- strncpy(psEventObject->szName, pszName, EVENTOBJNAME_MAXLENGTH);
28+ strncpy(psEventObject->szName, pszName, EVENTOBJNAME_MAXLENGTH-1);
29 }
30 else
31 {
32--
332.7.4
34
diff --git a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.14.3699939.bb b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.14.3699939.bb
deleted file mode 100644
index 4283587d..00000000
--- a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.14.3699939.bb
+++ /dev/null
@@ -1,45 +0,0 @@
1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the TI SoCs"
2HOMEPAGE = "https://git.ti.com/graphics/omap5-sgx-ddk-linux"
3LICENSE = "MIT | GPLv2"
4LIC_FILES_CHKSUM = "file://eurasia_km/README;beginline=13;endline=22;md5=74506d9b8e5edbce66c2747c50fcef12"
5
6inherit module
7
8COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15"
9
10MACHINE_KERNEL_PR_append = "p"
11PR = "${MACHINE_KERNEL_PR}"
12
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15DEPENDS = "virtual/kernel"
16
17PROVIDES = "omapdrm-pvr"
18
19RPROVIDES_${PN} = "omapdrm-pvr"
20RREPLACES_${PN} = "omapdrm-pvr"
21RCONFLICTS_${PN} = "omapdrm-pvr"
22
23BRANCH = "ti-img-sgx/${PV}/k4.14"
24
25SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-linux.git;protocol=git;branch=${BRANCH} \
26 file://0001-srvkm-env-linux-osfunc.c-fix-gcc8-stringop-truncatio.patch \
27 file://0001-buildvars.mk-pass-Wno-cast-function-type.patch"
28
29S = "${WORKDIR}/git"
30
31SRCREV = "76da7d73976f0a5dc04fdc84a3af899d6c2b1fe2"
32
33TARGET_PRODUCT_omap-a15 = "jacinto6evm"
34TARGET_PRODUCT_ti33x = "ti335x"
35TARGET_PRODUCT_ti43x = "ti437x"
36
37EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" TARGET_PRODUCT=${TARGET_PRODUCT}'
38
39do_compile_prepend() {
40 cd ${S}/eurasia_km/eurasiacon/build/linux2/omap_linux
41}
42
43do_install() {
44 make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B}/eurasia_km/eurasiacon/binary2_omap_linux_release/target/kbuild INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install
45}