summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2017-07-19 05:03:18 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-08-22 16:03:34 -0400
commit73540c8f5ef96ed34e08bc9dd7c0414c25787434 (patch)
tree02f35cf518c99053612156f87eab5603a0c02eac /recipes-bsp
parent66cdd7b418b07345d050aa3c6b0a639c7aafc791 (diff)
downloadmeta-ti-73540c8f5ef96ed34e08bc9dd7c0414c25787434.tar.gz
gpio-lld-rtos: Added rtos recipe for gpio lld
Upstreaming TI RTOS driver for General Purpose IO pins (GPIO) Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/gpio-lld/gpio-lld-rtos_git.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes-bsp/gpio-lld/gpio-lld-rtos_git.bb b/recipes-bsp/gpio-lld/gpio-lld-rtos_git.bb
new file mode 100644
index 00000000..be68c9ef
--- /dev/null
+++ b/recipes-bsp/gpio-lld/gpio-lld-rtos_git.bb
@@ -0,0 +1,42 @@
1SUMMARY = "TI RTOS driver for General Purpose IO (GPIO)"
2
3inherit ti-pdk
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://GPIO.h;beginline=1;endline=31;md5=8580f9c5c0de8d5d13518cf18a0122b8"
7
8COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|omapl1|c667x-evm|c665x-evm"
9PACKAGE_ARCH = "${MACHINE_ARCH}"
10
11GPIO_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/gpio-lld.git"
12GPIO_LLD_GIT_PROTOCOL = "git"
13GPIO_LLD_GIT_BRANCH = "master"
14GPIO_LLD_GIT_DESTSUFFIX = "git/ti/drv/gpio"
15
16# Below commit ID corresponds to "DEV.GPIO_LLD.01.00.00.07A"
17GPIO_LLD_SRCREV = "3abf90c7c3dabb456346da0ab308fab12ff590de"
18
19BRANCH = "${GPIO_LLD_GIT_BRANCH}"
20SRC_URI = "${GPIO_LLD_GIT_URI};destsuffix=${GPIO_LLD_GIT_DESTSUFFIX};protocol=${GPIO_LLD_GIT_PROTOCOL};branch=${BRANCH}"
21
22SRCREV = "${GPIO_LLD_SRCREV}"
23PV = "01.00.00.07A"
24PR = "r0"
25
26S = "${WORKDIR}/${GPIO_LLD_GIT_DESTSUFFIX}"
27
28DEPENDS_append = " osal-rtos \
29"
30DEPENDS_append_ti33x = " starterware-rtos \
31"
32DEPENDS_append_ti43x = " starterware-rtos \
33"
34
35# Build with make instead of XDC
36TI_PDK_XDCMAKE = "0"
37
38export PDK_GPIO_ROOT_PATH ="${WORKDIR}/build"
39export DEST_ROOT="${S}"
40
41# HTML doc link params
42PDK_COMP_LINK_TEXT = "GPIO LLD"