summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2018-06-27 23:03:31 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-06-27 19:20:04 +0000
commit6fd4a2c167d08ce31afe13a779451f5cf1053647 (patch)
tree3a128c1ddae4fe9bce481e5b2402506be7b1d348 /recipes-bsp
parentc8a6ca5eabb77803d9195e95f8121769df6b206f (diff)
downloadmeta-ti-6fd4a2c167d08ce31afe13a779451f5cf1053647.tar.gz
prueth-fw-bin: add AM65xx binary FW
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/prueth-fw/prueth-fw-bin_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-bsp/prueth-fw/prueth-fw-bin_git.bb b/recipes-bsp/prueth-fw/prueth-fw-bin_git.bb
new file mode 100644
index 00000000..b3bbb6bb
--- /dev/null
+++ b/recipes-bsp/prueth-fw/prueth-fw-bin_git.bb
@@ -0,0 +1,32 @@
1SUMMARY = "PRU Ethernet firmware for AM65xx"
2
3LICENSE = "TI-TFL"
4LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76"
5
6PV = "1.0.0"
7
8CLEANBROKEN = "1"
9
10COMPATIBLE_MACHINE = "am65xx-evm"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14SRCREV = "5d8d6e8b1ec0d95ea29ca5b1c4ca09c14a6b5166"
15BRANCH ?= "ti-linux-firmware-4.1.y"
16
17SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}"
18
19S = "${WORKDIR}/git"
20
21TARGET = "am65x-pru0-prueth-fw.elf am65x-pru1-prueth-fw.elf am65x-rtu0-prueth-fw.elf am65x-rtu1-prueth-fw.elf"
22
23do_install() {
24 install -d ${D}${base_libdir}/firmware/ti-pruss
25 for f in ${TARGET}; do
26 install -m 0644 ${S}/ti-pruss/$f ${D}${base_libdir}/firmware/ti-pruss/$f
27 done
28}
29
30FILES_${PN} = "${base_libdir}/firmware"
31
32INSANE_SKIP_${PN} = "arch"