diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2015-11-04 01:47:28 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-11-04 10:03:19 -0500 |
commit | 1e37806e858cf6b43216a9b53a1a906612b73188 (patch) | |
tree | b681cf3422770cfaaefdd2493b486424c424665b /recipes-bsp | |
parent | 36800c7c7c790aa1a637b2810e4e044a41855150 (diff) | |
download | meta-ti-1e37806e858cf6b43216a9b53a1a906612b73188.tar.gz |
sa-lld: Clean up recipes
* Use INC_PR to track recipe revisions
* Define variables for GIT SRC_URI parameters
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/sa-lld/sa-lld-test_git.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/sa-lld/sa-lld.inc | 18 | ||||
-rw-r--r-- | recipes-bsp/sa-lld/sa-lld_git.bb | 2 |
3 files changed, 17 insertions, 5 deletions
diff --git a/recipes-bsp/sa-lld/sa-lld-test_git.bb b/recipes-bsp/sa-lld/sa-lld-test_git.bb index 7cb0ac7a..4f74ab67 100644 --- a/recipes-bsp/sa-lld/sa-lld-test_git.bb +++ b/recipes-bsp/sa-lld/sa-lld-test_git.bb | |||
@@ -4,6 +4,8 @@ DEPENDS = "common-csl-ip cppi-lld qmss-lld pa-lld sa-lld" | |||
4 | 4 | ||
5 | include sa-lld.inc | 5 | include sa-lld.inc |
6 | 6 | ||
7 | PR = "${INC_PR}.0" | ||
8 | |||
7 | DEVICELIST = "k2h k2k k2l k2e" | 9 | DEVICELIST = "k2h k2k k2l k2e" |
8 | 10 | ||
9 | CHOICELIST = "no yes" | 11 | CHOICELIST = "no yes" |
diff --git a/recipes-bsp/sa-lld/sa-lld.inc b/recipes-bsp/sa-lld/sa-lld.inc index 80662796..47584b6e 100644 --- a/recipes-bsp/sa-lld/sa-lld.inc +++ b/recipes-bsp/sa-lld/sa-lld.inc | |||
@@ -3,11 +3,19 @@ COMPATIBLE_MACHINE = "keystone" | |||
3 | 3 | ||
4 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/sa/COPYING.txt;md5=4709d353574a9569e129ebdf20e732dd" | 4 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/sa/COPYING.txt;md5=4709d353574a9569e129ebdf20e732dd" |
5 | 5 | ||
6 | BRANCH = "master" | 6 | SA_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/sa-lld.git" |
7 | SRC_URI = "git://git.ti.com/keystone-rtos/sa-lld.git;destsuffix=git/ti/drv/sa;protocol=git;branch=${BRANCH}" | 7 | SA_LLD_GIT_PROTOCOL = "git" |
8 | SA_LLD_GIT_BRANCH = "master" | ||
9 | SA_LLD_GIT_DESTSUFFIX = "git/ti/drv/sa" | ||
10 | |||
8 | # Following commit DEV.SA_LLD.03.00.00.11A | 11 | # Following commit DEV.SA_LLD.03.00.00.11A |
9 | SRCREV = "bf5b097e868b20d23d386abc34a1902903d7d9ea" | 12 | SA_LLD_SRCREV = "bf5b097e868b20d23d386abc34a1902903d7d9ea" |
13 | |||
14 | BRANCH = "${SA_LLD_GIT_BRANCH}" | ||
15 | SRC_URI = "${SA_LLD_GIT_URI};destsuffix=${SA_LLD_GIT_DESTSUFFIX};protocol=${SA_LLD_GIT_PROTOCOL};branch=${BRANCH}" | ||
16 | SRCREV = "${SA_LLD_SRCREV}" | ||
17 | |||
10 | PV = "03.00.00.11" | 18 | PV = "03.00.00.11" |
19 | INC_PR = "r1" | ||
11 | 20 | ||
12 | BASEDIR = "${WORKDIR}/git" | 21 | S = "${WORKDIR}/${SA_LLD_GIT_DESTSUFFIX}" |
13 | S = "${BASEDIR}/ti/drv/sa" | ||
diff --git a/recipes-bsp/sa-lld/sa-lld_git.bb b/recipes-bsp/sa-lld/sa-lld_git.bb index 3df2c6cb..1cab6db9 100644 --- a/recipes-bsp/sa-lld/sa-lld_git.bb +++ b/recipes-bsp/sa-lld/sa-lld_git.bb | |||
@@ -4,6 +4,8 @@ DEPENDS = "common-csl-ip" | |||
4 | 4 | ||
5 | include sa-lld.inc | 5 | include sa-lld.inc |
6 | 6 | ||
7 | PR = "${INC_PR}.0" | ||
8 | |||
7 | do_compile () { | 9 | do_compile () { |
8 | # Now build the lld in the updated directory | 10 | # Now build the lld in the updated directory |
9 | make -f makefile_armv7 clean lib PDK_INSTALL_PATH=${STAGING_INCDIR} | 11 | make -f makefile_armv7 clean lib PDK_INSTALL_PATH=${STAGING_INCDIR} |