summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2017-07-19 05:03:26 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-08-16 13:49:00 -0400
commitdcb37f56dd394b7974a185486a913375962bc3da (patch)
treed0db70ce29642e904b99aebd4e564239aa44be0a /recipes-bsp
parente282ad0bf5518feee8e077b4decab5e53b26aa0e (diff)
downloadmeta-ti-dcb37f56dd394b7974a185486a913375962bc3da.tar.gz
tsip-lld-rtos: Add rtos recipe for tsip-lld
Upstreaming RTOS recipe for Telecom Serial Interface Port (TSIP) Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/tsip-lld/tsip-lld-rtos_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-bsp/tsip-lld/tsip-lld-rtos_git.bb b/recipes-bsp/tsip-lld/tsip-lld-rtos_git.bb
new file mode 100644
index 00000000..cae1b477
--- /dev/null
+++ b/recipes-bsp/tsip-lld/tsip-lld-rtos_git.bb
@@ -0,0 +1,26 @@
1SUMMARY = "TI RTOS low level driver for Telecom Serial Interface Port (TSIP)"
2
3inherit ti-pdk
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://tsip.h;beginline=1;endline=32;md5=dab2257b0b8a3678c26915f6eb49b71e"
7
8COMPATIBLE_MACHINE = "k2e-evm|c667x-evm"
9PACKAGE_ARCH = "${MACHINE_ARCH}"
10
11TSIP_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/tsip-lld.git"
12TSIP_LLD_GIT_PROTOCOL = "git"
13TSIP_LLD_GIT_BRANCH = "master"
14
15# Below commit ID corresponds to "DEV.TSIP_LLD.01.00.00.07A"
16TSIP_LLD_SRCREV = "211d2f1a5c3c7ec80349a18e6e6cae6c9e4df921"
17
18BRANCH = "${TSIP_LLD_GIT_BRANCH}"
19SRC_URI = "${TSIP_LLD_GIT_URI};protocol=${TSIP_LLD_GIT_PROTOCOL};branch=${BRANCH}"
20
21SRCREV = "${TSIP_LLD_SRCREV}"
22PV = "01.00.00.07"
23PR = "r0"
24
25# HTML doc link params
26PDK_COMP_LINK_TEXT = "TSIP LLD"