summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2017-07-01 02:40:18 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-07-11 19:16:02 -0400
commitd552e378f388b330e7743f24eb3a88fa038bb850 (patch)
tree1f310deff6f9126ec7b245889d54e3d9b00b60dc /recipes-bsp
parentfc1ad8a58449f72ebe44a485704627d3c4eb66d7 (diff)
downloadmeta-ti-d552e378f388b330e7743f24eb3a88fa038bb850.tar.gz
osal: Added rtos recipe and updated to 1.0.0.7 along with omapl1 support
Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/osal/osal-rtos_git.bb18
-rw-r--r--recipes-bsp/osal/osal.inc8
2 files changed, 22 insertions, 4 deletions
diff --git a/recipes-bsp/osal/osal-rtos_git.bb b/recipes-bsp/osal/osal-rtos_git.bb
new file mode 100644
index 00000000..da421b61
--- /dev/null
+++ b/recipes-bsp/osal/osal-rtos_git.bb
@@ -0,0 +1,18 @@
1inherit ti-pdk
2require recipes-bsp/osal/osal.inc
3
4PR = "${INC_PR}.0"
5
6S = "${WORKDIR}/${OSAL_GIT_DESTSUFFIX}"
7
8DEPENDS_append_ti33x = " starterware-rtos"
9DEPENDS_append_ti43x = " starterware-rtos"
10
11# Build with make instead of XDC
12TI_PDK_XDCMAKE = "0"
13
14export PDK_OSAL_ROOT_PATH ="${WORKDIR}/build"
15export DEST_ROOT="${S}"
16
17# HTML doc link params
18PDK_COMP_LINK_TEXT = "OSAL Library"
diff --git a/recipes-bsp/osal/osal.inc b/recipes-bsp/osal/osal.inc
index fa8cde8e..63ccca9b 100644
--- a/recipes-bsp/osal/osal.inc
+++ b/recipes-bsp/osal/osal.inc
@@ -1,7 +1,7 @@
1LICENSE = "BSD-3-Clause" 1LICENSE = "BSD-3-Clause"
2LIC_FILES_CHKSUM = "file://osal.h;beginline=1;endline=31;md5=ae7b9f0410f26c80dcf790ef3f622fad" 2LIC_FILES_CHKSUM = "file://osal.h;beginline=1;endline=31;md5=ae7b9f0410f26c80dcf790ef3f622fad"
3 3
4COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone" 4COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|omapl1"
5PACKAGE_ARCH = "${MACHINE_ARCH}" 5PACKAGE_ARCH = "${MACHINE_ARCH}"
6 6
7OSAL_GIT_URI = "git://git.ti.com/keystone-rtos/osal.git" 7OSAL_GIT_URI = "git://git.ti.com/keystone-rtos/osal.git"
@@ -9,12 +9,12 @@ OSAL_GIT_PROTOCOL = "git"
9OSAL_GIT_BRANCH = "master" 9OSAL_GIT_BRANCH = "master"
10OSAL_GIT_DESTSUFFIX = "git/ti/osal" 10OSAL_GIT_DESTSUFFIX = "git/ti/osal"
11 11
12# Below commit ID corresponding to "DEV.OSAL.01.00.00.06E" 12# Below commit ID corresponding to "DEV.OSAL.01.00.00.07"
13OSAL_SRCREV = "072ab0f76fa272ace5b1756075475f848c14221a" 13OSAL_SRCREV = "62ea536572d91a17321dfca287771a5b65e6e00d"
14 14
15BRANCH = "${OSAL_GIT_BRANCH}" 15BRANCH = "${OSAL_GIT_BRANCH}"
16SRC_URI = "${OSAL_GIT_URI};destsuffix=${OSAL_GIT_DESTSUFFIX};protocol=${OSAL_GIT_PROTOCOL};branch=${BRANCH}" 16SRC_URI = "${OSAL_GIT_URI};destsuffix=${OSAL_GIT_DESTSUFFIX};protocol=${OSAL_GIT_PROTOCOL};branch=${BRANCH}"
17 17
18SRCREV = "${OSAL_SRCREV}" 18SRCREV = "${OSAL_SRCREV}"
19PV = "01.00.00.06E" 19PV = "01.00.00.07"
20INC_PR = "r0" 20INC_PR = "r0"