summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2017-07-19 05:03:40 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-08-24 15:58:25 -0400
commitcd9c97c4c19b27ff89b0dadd80acbd43a921842b (patch)
tree926cc5073f7f5e23db02cf5d07af596c475e0bcb /recipes-bsp
parent6a6c603a8133de4a47e0e0ffae58c3f9b8a3ad4f (diff)
downloadmeta-ti-cd9c97c4c19b27ff89b0dadd80acbd43a921842b.tar.gz
serdes-diag-rtos: Add rtos recipe for serdes-diag
Upstreaming TI RTOS library for SERDES diagnostics Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/serdes-diag/serdes-diag-rtos_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-bsp/serdes-diag/serdes-diag-rtos_git.bb b/recipes-bsp/serdes-diag/serdes-diag-rtos_git.bb
new file mode 100644
index 00000000..cd828e06
--- /dev/null
+++ b/recipes-bsp/serdes-diag/serdes-diag-rtos_git.bb
@@ -0,0 +1,31 @@
1SUMMARY = "TI RTOS library for SERDES diagnostics"
2
3inherit ti-pdk
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://serdes_diag.h;beginline=1;endline=42;;md5=68e7ce6fdc0e9328fa7d0ec41c54420c"
7
8COMPATIBLE_MACHINE = "keystone|c66x"
9PACKAGE_ARCH = "${MACHINE_ARCH}"
10
11SERDES_DIAG_GIT_URI = "git://git.ti.com/keystone-rtos/serdes_diag.git"
12SERDES_DIAG_GIT_PROTOCOL = "git"
13SERDES_DIAG_GIT_BRANCH = "master"
14SERDES_DIAG_GIT_DESTSUFFIX = "git/ti/diag/serdes_diag"
15
16# Below commit ID corresponds to "DEV.DIAG_SERDES_SB.01.00.00.07"
17SERDES_DIAG_SRCREV = "65a0c2f6afc84dce03c706432667382700a08654"
18
19BRANCH = "${SERDES_DIAG_GIT_BRANCH}"
20SRC_URI = "${SERDES_DIAG_GIT_URI};destsuffix=${SERDES_DIAG_GIT_DESTSUFFIX};protocol=${SERDES_DIAG_GIT_PROTOCOL};branch=${BRANCH}"
21
22SRCREV = "${SERDES_DIAG_SRCREV}"
23PV = "01.00.00.07"
24PR = "r0"
25
26S = "${WORKDIR}/${SERDES_DIAG_GIT_DESTSUFFIX}"
27
28# HTML doc link params
29PDK_COMP_LINK_TEXT = "SERDES Diagnostics"
30
31INSANE_SKIP_${PN} = "arch"