summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2017-09-19 02:49:08 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-09-28 13:42:41 -0400
commit1cfec69db91fbcdc077f1fe4c3a4db2fdf367e94 (patch)
treebc80811eab349130e0c0c2c363e0c03c89e775ea /recipes-bsp
parent9a3ab72144e25bcdf7f596e475563b0239ac7c35 (diff)
downloadmeta-ti-1cfec69db91fbcdc077f1fe4c3a4db2fdf367e94.tar.gz
cmb-addon-rtos: Adding CMB rtos recipe
Circular Microphone array board (CMB) RTOS software Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/cmb-addon/cmb-addon-rtos_git.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-bsp/cmb-addon/cmb-addon-rtos_git.bb b/recipes-bsp/cmb-addon/cmb-addon-rtos_git.bb
new file mode 100644
index 00000000..4d698638
--- /dev/null
+++ b/recipes-bsp/cmb-addon/cmb-addon-rtos_git.bb
@@ -0,0 +1,41 @@
1SUMMARY = "TI RTOS software supporting circular microphone array board"
2require recipes-ti/includes/ti-paths.inc
3inherit ti-pdk
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://cmbaddonver.h;beginline=8;endline=47;md5=d0cb159bf210cfafed63042da01c83e0"
7
8COMPATIBLE_MACHINE = "k2g|omapl137-evm"
9
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11
12CMB_ADDON_GIT_URI = "git://git.ti.com/processor-sdk/circmicarray-addon.git"
13CMB_ADDON_GIT_PROTOCOL = "git"
14CMB_ADDON_GIT_BRANCH = "master"
15CMB_ADDON_GIT_DESTSUFFIX = "git/ti/addon"
16
17# Below commit ID corresponds to "DEV.CMB.01.01.00.00"
18CMB_ADDON_SRCREV = "29c05572b82251bac73cd685afcffdb8549eaaaf"
19
20SRCREV = "${CMB_ADDON_SRCREV}"
21PV = "01.01.00.00"
22PR = "r0"
23
24BRANCH = "${CMB_ADDON_GIT_BRANCH}"
25SRC_URI = "${CMB_ADDON_GIT_URI};destsuffix=${CMB_ADDON_GIT_DESTSUFFIX};protocol=${CMB_ADDON_GIT_PROTOCOL};branch=${BRANCH}"
26
27
28S = "${WORKDIR}/git/ti/addon/cmb"
29
30DEPENDS_append = " ti-sysbios \
31 gpio-lld-rtos \
32 i2c-lld-rtos \
33 mcasp-lld-rtos \
34 board-rtos \
35"
36
37export PDK_CMB_ROOT_PATH = "${WORKDIR}/build"
38export DEST_ROOT="${S}"
39
40# Build with make instead of XDC
41TI_PDK_XDCMAKE = "0"