summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2014-10-08 00:44:58 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-10-07 15:28:31 -0400
commitfe53dc3cbd322cf6db3edf2eeb2ba72263b0ea36 (patch)
tree89d382176643486185e901ddd9233b1ebe6cc116 /recipes-bsp
parent0b17797a12ec3f385052d080ca56e17687482aab (diff)
downloadmeta-ti-fe53dc3cbd322cf6db3edf2eeb2ba72263b0ea36.tar.gz
uio-module-drv: Add new recipe for user space io driver
- Provides User space IO driver for on-chip modules Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/uio-module-drv/uio-module-drv_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
new file mode 100644
index 00000000..a363d5fa
--- /dev/null
+++ b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
@@ -0,0 +1,21 @@
1DESCRIPTION="User space IO (UIO) driver for on-chip modules"
2
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2b7c96eb2aed7b0f6f922214dbde9016"
5
6BRANCH ?= "master"
7# This corresponds to version 01.00.01.00A
8SRCREV = "3bce5bfec7a7865e278410e3c4484f878b9038b6"
9PV = "1.0.1"
10
11SRC_URI = "git://git.ti.com/keystone-linux/uio-module-drv.git;protocol=git;branch=${BRANCH}"
12
13# This package builds a kernel module, use kernel PR as base and append a local
14MACHINE_KERNEL_PR_append = "a+gitr${SRCPV}"
15PR = "${MACHINE_KERNEL_PR}"
16
17S = "${WORKDIR}/git"
18
19module_auto_load_uio-module-drv = "uio-module-drv"
20
21inherit module