diff options
author | Khem Raj <raj.khem@gmail.com> | 2014-09-21 13:05:38 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2014-09-22 12:30:00 -0400 |
commit | 3735bc41089cc7ba32f5550ce18c3bb0d20f3a32 (patch) | |
tree | 27fae6312f98ec4873bfd414ae68fd16949da984 /recipes-bsp | |
parent | 9c2ae7b791a08ad95f31413dcce594a7ca1c9601 (diff) | |
download | meta-ti-3735bc41089cc7ba32f5550ce18c3bb0d20f3a32.tar.gz |
am33x-cm3: Add TOOLCHAIN_OPTIONS to redefined CC
This error will show up when using sstate which was generated
using a different buiid time sysroot. Since we override CC we
still need to honor --sysroot which is specified via TOOLCHAIN_OPTIONS
Fixes
| DEBUG: Executing shell function do_compile
| CC src/sys_exec/sys_init.o
| In file included from src/sys_exec/rsc_table.h:13:0,
| from src/sys_exec/sys_init.c:19:
|
/home/ubuntu/work/angstrom/build/tmp-angstrom_next-glibc/sysroots/x86_64-linux/usr/lib/arm-angstrom-linux-gnueabi/gcc/arm-angstrom-linux-gnueabi/4.9.2/include/stdint.h:9:26:
fatal error: stdint.h: No such file or directory
| # include_next <stdint.h>
| ^
| compilation terminated.
| make: *** [src/sys_exec/sys_init.o] Error 1
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/am33x-cm3/am33x-cm3_git.bb | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-bsp/am33x-cm3/am33x-cm3_git.bb b/recipes-bsp/am33x-cm3/am33x-cm3_git.bb index e5728ab0..0b0a776d 100644 --- a/recipes-bsp/am33x-cm3/am33x-cm3_git.bb +++ b/recipes-bsp/am33x-cm3/am33x-cm3_git.bb | |||
@@ -17,7 +17,7 @@ S = "${WORKDIR}/git" | |||
17 | FLOATABI = "${@base_contains("TUNE_FEATURES", "vfp", base_contains("TUNE_FEATURES", "callconvention-hard", " -mfloat-abi=hard", " -mfloat-abi=softfp", d), "" ,d)}" | 17 | FLOATABI = "${@base_contains("TUNE_FEATURES", "vfp", base_contains("TUNE_FEATURES", "callconvention-hard", " -mfloat-abi=hard", " -mfloat-abi=softfp", d), "" ,d)}" |
18 | 18 | ||
19 | do_compile() { | 19 | do_compile() { |
20 | make CROSS_COMPILE="${TARGET_PREFIX}" CC="${TARGET_PREFIX}gcc ${FLOATABI}" | 20 | make CROSS_COMPILE="${TARGET_PREFIX}" CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${FLOATABI}" |
21 | } | 21 | } |
22 | 22 | ||
23 | do_install() { | 23 | do_install() { |