diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2015-11-04 01:47:13 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-11-04 09:57:12 -0500 |
commit | 20f7def0e4a9af82455b92a534fa83bd1cc09b6c (patch) | |
tree | 98abd6a8632f127c77dfb79f6de81ba89a38b011 /recipes-bsp | |
parent | 4aaf561265664aa08072428c47827403f5fc6cfd (diff) | |
download | meta-ti-20f7def0e4a9af82455b92a534fa83bd1cc09b6c.tar.gz |
hplib: Clean up recipes
* Use INC_PR to track recipe revisions
* Define variables for GIT SRC_URI parameters
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/hplib/hplib-test_git.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/hplib/hplib.inc | 13 | ||||
-rw-r--r-- | recipes-bsp/hplib/hplib_git.bb | 2 |
3 files changed, 14 insertions, 3 deletions
diff --git a/recipes-bsp/hplib/hplib-test_git.bb b/recipes-bsp/hplib/hplib-test_git.bb index 574fa2a7..4ba79dbd 100644 --- a/recipes-bsp/hplib/hplib-test_git.bb +++ b/recipes-bsp/hplib/hplib-test_git.bb | |||
@@ -6,6 +6,8 @@ DEPENDS = "common-csl-ip qmss-lld sa-lld pktlib hplib" | |||
6 | 6 | ||
7 | include hplib.inc | 7 | include hplib.inc |
8 | 8 | ||
9 | PR = "${INC_PR}.0" | ||
10 | |||
9 | CHOICELIST = "yes no" | 11 | CHOICELIST = "yes no" |
10 | 12 | ||
11 | S = "${WORKDIR}/git/ti/runtime/hplib" | 13 | S = "${WORKDIR}/git/ti/runtime/hplib" |
diff --git a/recipes-bsp/hplib/hplib.inc b/recipes-bsp/hplib/hplib.inc index e4211ee0..7ed47a56 100644 --- a/recipes-bsp/hplib/hplib.inc +++ b/recipes-bsp/hplib/hplib.inc | |||
@@ -2,9 +2,16 @@ COMPATIBLE_MACHINE = "keystone" | |||
2 | 2 | ||
3 | DEVICELIST = "k2h k2k k2l k2e" | 3 | DEVICELIST = "k2h k2k k2l k2e" |
4 | 4 | ||
5 | BRANCH = "master" | 5 | HPLIB_GIT_URI = "git://git.ti.com/keystone-rtos/hplib.git" |
6 | SRC_URI = "git://git.ti.com/keystone-rtos/hplib.git;protocol=git;branch=${BRANCH}" | 6 | HPLIB_GIT_PROTOCOL = "git" |
7 | HPLIB_GIT_BRANCH = "master" | ||
7 | 8 | ||
8 | # Below Commit ID corresponds to "DEV.HPLIB.01.01.00.06" | 9 | # Below Commit ID corresponds to "DEV.HPLIB.01.01.00.06" |
9 | SRCREV = "1cbe6a41926c131d9cab63b40d43807c6e56e2fd" | 10 | HPLIB_SRCREV = "1cbe6a41926c131d9cab63b40d43807c6e56e2fd" |
11 | |||
12 | BRANCH = "${HPLIB_GIT_BRANCH}" | ||
13 | SRC_URI = "${HPLIB_GIT_URI};protocol=${HPLIB_GIT_PROTOCOL};branch=${BRANCH}" | ||
14 | SRCREV = "${HPLIB_SRCREV}" | ||
15 | |||
10 | PV = "01.01.00.06+git${SRCPV}" | 16 | PV = "01.01.00.06+git${SRCPV}" |
17 | INC_PR = "r1" | ||
diff --git a/recipes-bsp/hplib/hplib_git.bb b/recipes-bsp/hplib/hplib_git.bb index da8853bd..1423de5b 100644 --- a/recipes-bsp/hplib/hplib_git.bb +++ b/recipes-bsp/hplib/hplib_git.bb | |||
@@ -7,6 +7,8 @@ RDEPENDS_${PN} = "hplib-mod" | |||
7 | 7 | ||
8 | include hplib.inc | 8 | include hplib.inc |
9 | 9 | ||
10 | PR = "${INC_PR}.0" | ||
11 | |||
10 | CHOICELIST = "yes no" | 12 | CHOICELIST = "yes no" |
11 | 13 | ||
12 | S = "${WORKDIR}/git/ti/runtime/hplib" | 14 | S = "${WORKDIR}/git/ti/runtime/hplib" |