summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-01-29 13:45:58 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2012-01-30 16:26:41 +0100
commit149faa376984f0e2b894b74858303c7bd432124e (patch)
tree74105526087a806f8fc59a528a7f626d2178616f /recipes-bsp
parentbfbb1cc110671ec18947f602f2293dfda1d54c6e (diff)
downloadmeta-ti-149faa376984f0e2b894b74858303c7bd432124e.tar.gz
u-boot 2011.12: fix beagleboard C4 memory detection
Test results (which emberassingly enough lack an actual C4): BeagleBoard B6: OMAP3530-GP ES2.1, CPU-OPP2, L3-165MHz, Max CPU Clock 600 mHz OMAP3 Beagle board + LPDDR/NAND I2C: ready DRAM: 128 MiB NAND: 256 MiB [..] Beagle Rev Ax/Bx BeagleBoard C3: OMAP3530-GP ES3.0, CPU-OPP2, L3-165MHz, Max CPU Clock 600 mHz OMAP3 Beagle board + LPDDR/NAND I2C: ready DRAM: 256 MiB NAND: 256 MiB [..] Beagle Rev C1/C2/C3 BeagleBoard C5: OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz OMAP3 Beagle board + LPDDR/NAND I2C: ready DRAM: 256 MiB NAND: 512 MiB [..] Beagle Rev C4 BeagleBoard xM A: OMAP3630/3730-GP ES1.1, CPU-OPP2, L3-165MHz, Max CPU Clock 1 Ghz OMAP3 Beagle board + LPDDR/NAND I2C: ready DRAM: 512 MiB NAND: 0 MiB [..] Beagle xM Rev A BeagleBoard xM C: OMAP3630/3730-GP ES1.2, CPU-OPP2, L3-165MHz, Max CPU Clock 1 Ghz OMAP3 Beagle board + LPDDR/NAND I2C: ready DRAM: 512 MiB NAND: 0 MiB [..] Beagle xM Rev C Acked-by: Tom Rini <trini@ti.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0001-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch4
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0002-beagleboard-add-support-for-TCT-Beacon-board.patch4
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch4
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0004-omap4-common-mount-root-RO.patch4
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0005-omap4-common-use-ext4-by-default.patch4
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0006-OMAP-MMC-Add-delay-before-waiting-for-status.patch (renamed from recipes-bsp/u-boot/u-boot/2011.12/U-Boot-OMAP-MMC-Add-delay-before-waiting-for-status.patch)19
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch43
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0008-Revert-armv7-disable-L2-cache-in-cleanup_before_linu.patch (renamed from recipes-bsp/u-boot/u-boot/2011.12/0001-Revert-armv7-disable-L2-cache-in-cleanup_before_linu.patch)6
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0009-Beagleboard-Correct-memory-size-on-rev-C4.patch37
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0010-OMAP3-Correct-get_sdr_cs_offset-mask.patch37
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.12.bb11
11 files changed, 146 insertions, 27 deletions
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0001-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch b/recipes-bsp/u-boot/u-boot/2011.12/0001-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch
index 07ab75b1..02f91c51 100644
--- a/recipes-bsp/u-boot/u-boot/2011.12/0001-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0001-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch
@@ -1,7 +1,7 @@
1From d0556964b6bd443e8b60d5c0b3326795a02cc8a7 Mon Sep 17 00:00:00 2001 1From e435374789db01c9499ec169b295496f039ec401 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net> 2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Sun, 27 Nov 2011 14:43:58 +0100 3Date: Sun, 27 Nov 2011 14:43:58 +0100
4Subject: [PATCH 1/5] beagleboard: mount rootfs RO instead of RW at boot 4Subject: [PATCH 01/10] beagleboard: mount rootfs RO instead of RW at boot
5 5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> 6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7--- 7---
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0002-beagleboard-add-support-for-TCT-Beacon-board.patch b/recipes-bsp/u-boot/u-boot/2011.12/0002-beagleboard-add-support-for-TCT-Beacon-board.patch
index 5af34a15..df3a09e0 100644
--- a/recipes-bsp/u-boot/u-boot/2011.12/0002-beagleboard-add-support-for-TCT-Beacon-board.patch
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0002-beagleboard-add-support-for-TCT-Beacon-board.patch
@@ -1,7 +1,7 @@
1From 28e5cc1f13d817f75638c72eae853e53510a1ab2 Mon Sep 17 00:00:00 2001 1From 7c1bb614d0235c69e118f0552cbf46047f557b8c Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net> 2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Sat, 8 Oct 2011 21:56:35 +0200 3Date: Sat, 8 Oct 2011 21:56:35 +0200
4Subject: [PATCH 2/5] beagleboard: add support for TCT Beacon board 4Subject: [PATCH 02/10] beagleboard: add support for TCT Beacon board
5 5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> 6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7--- 7---
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch b/recipes-bsp/u-boot/u-boot/2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch
index 31c40639..71dd2bb2 100644
--- a/recipes-bsp/u-boot/u-boot/2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch
@@ -1,7 +1,7 @@
1From fe9c653a0b0a3fa49d269b697c2058a6a55aa42b Mon Sep 17 00:00:00 2001 1From c8c3b1adff56c49f20732846a7087e95f6916e61 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net> 2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Sun, 27 Nov 2011 14:53:56 +0100 3Date: Sun, 27 Nov 2011 14:53:56 +0100
4Subject: [PATCH 3/5] beagleboard: add support for scanning loop-through expansionboards like the uLCD-lite 4Subject: [PATCH 03/10] beagleboard: add support for scanning loop-through expansionboards like the uLCD-lite
5 5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> 6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7--- 7---
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0004-omap4-common-mount-root-RO.patch b/recipes-bsp/u-boot/u-boot/2011.12/0004-omap4-common-mount-root-RO.patch
index 0d3655d3..ed340a03 100644
--- a/recipes-bsp/u-boot/u-boot/2011.12/0004-omap4-common-mount-root-RO.patch
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0004-omap4-common-mount-root-RO.patch
@@ -1,7 +1,7 @@
1From 90dfb660575f15ba736884139f35bfd4ba927468 Mon Sep 17 00:00:00 2001 1From e4ac25df241bc2f3e6e2b7116529e82dfa5aab00 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net> 2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Thu, 8 Dec 2011 17:22:59 +0100 3Date: Thu, 8 Dec 2011 17:22:59 +0100
4Subject: [PATCH 4/5] omap4-common: mount root RO 4Subject: [PATCH 04/10] omap4-common: mount root RO
5 5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> 6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7--- 7---
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0005-omap4-common-use-ext4-by-default.patch b/recipes-bsp/u-boot/u-boot/2011.12/0005-omap4-common-use-ext4-by-default.patch
index e28eae57..97dab04d 100644
--- a/recipes-bsp/u-boot/u-boot/2011.12/0005-omap4-common-use-ext4-by-default.patch
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0005-omap4-common-use-ext4-by-default.patch
@@ -1,7 +1,7 @@
1From a1f9453f2450762249aa35bd5ae97150acc53eb2 Mon Sep 17 00:00:00 2001 1From 9e4679bdc5a2f3908f9d5e757c9706c0040e3643 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net> 2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Thu, 8 Dec 2011 17:23:24 +0100 3Date: Thu, 8 Dec 2011 17:23:24 +0100
4Subject: [PATCH 5/5] omap4-common: use ext4 by default 4Subject: [PATCH 05/10] omap4-common: use ext4 by default
5 5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> 6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7--- 7---
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/U-Boot-OMAP-MMC-Add-delay-before-waiting-for-status.patch b/recipes-bsp/u-boot/u-boot/2011.12/0006-OMAP-MMC-Add-delay-before-waiting-for-status.patch
index b334639f..84293651 100644
--- a/recipes-bsp/u-boot/u-boot/2011.12/U-Boot-OMAP-MMC-Add-delay-before-waiting-for-status.patch
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0006-OMAP-MMC-Add-delay-before-waiting-for-status.patch
@@ -1,13 +1,10 @@
1From patchwork Thu Dec 22 09:56:35 2011 1From 64e971ecd4bb1dec118b5687dfa7c57790922bba Mon Sep 17 00:00:00 2001
2Content-Type: text/plain; charset="utf-8" 2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmx.de>
3Date: Wed, 21 Dec 2011 23:56:35 +0000
4Subject: [PATCH 06/10] OMAP MMC: Add delay before waiting for status
3MIME-Version: 1.0 5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
4Content-Transfer-Encoding: 8bit 7Content-Transfer-Encoding: 8bit
5Subject: [U-Boot] OMAP MMC: Add delay before waiting for status
6Date: Wed, 21 Dec 2011 23:56:35 -0000
7From: =?utf-8?q?Andreas_M=C3=BCller_=3Cschnitzeltony=40gmx=2Ede=3E?=
8X-Patchwork-Id: 132795
9Message-Id: <1324547795-19678-1-git-send-email-schnitzeltony@gmx.de>
10To: u-boot@lists.denx.de
11 8
12Loading kernel from MMC created the following error message reproducable: 9Loading kernel from MMC created the following error message reproducable:
13 10
@@ -23,9 +20,8 @@ Tested on overo with OMAP3530:
23 Die ID #112000040000000004035c140101b011 20 Die ID #112000040000000004035c140101b011
24 21
25Signed-off-by: Andreas Müller <schnitzeltony@gmx.de> 22Signed-off-by: Andreas Müller <schnitzeltony@gmx.de>
26
27--- 23---
28drivers/mmc/omap_hsmmc.c | 4 ++++ 24 drivers/mmc/omap_hsmmc.c | 4 ++++
29 1 files changed, 4 insertions(+), 0 deletions(-) 25 1 files changed, 4 insertions(+), 0 deletions(-)
30 26
31diff --git a/drivers/mmc/omap_hsmmc.c b/drivers/mmc/omap_hsmmc.c 27diff --git a/drivers/mmc/omap_hsmmc.c b/drivers/mmc/omap_hsmmc.c
@@ -43,3 +39,6 @@ index c38b9e6..ac91e5d 100644
43 start = get_timer(0); 39 start = get_timer(0);
44 while ((readl(&mmc_base->pstate) & DATI_MASK) == DATI_CMDDIS) { 40 while ((readl(&mmc_base->pstate) & DATI_MASK) == DATI_CMDDIS) {
45 if (get_timer(0) - start > MAX_RETRY_MS) { 41 if (get_timer(0) - start > MAX_RETRY_MS) {
42--
431.7.2.5
44
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch b/recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch
new file mode 100644
index 00000000..15f22b34
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch
@@ -0,0 +1,43 @@
1From 06fe8be6b5c70853c0e3fac93d7bba9cb3d0292f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 21 Dec 2011 08:53:02 -0800
4Subject: [PATCH 07/10] config: Always use GNU ld
5
6This patch makes sure that we always use the GNU ld. u-boot uses certain
7construct e.g. OVERLAY which are not implemented in gold therefore it
8always needs GNU ld for linking. It works well if default linker in
9toolchain is GNU ld but in some cases we can have gold to be the
10default linker and also ship GNU ld but not as default in such cases
11its called $(PREFIX)ld.bfd, with this patch we make sure that if
12$(PREFIX)ld.bfd exists than we use that for our ld. This way it
13does not matter what the default ld is.
14
15Upstream-status: Pending
16
17Signed-off-by: Khem Raj <raj.khem@gmail.com>
18---
19 config.mk | 4 +++-
20 1 files changed, 3 insertions(+), 1 deletions(-)
21
22diff --git a/config.mk b/config.mk
23index ddaa477..59b3e71 100644
24--- a/config.mk
25+++ b/config.mk
26@@ -126,11 +126,13 @@ cc-option = $(strip $(if $(findstring $1,$(CC_OPTIONS)),$1,\
27 $(if $(call cc-option-sys,$1),$1,$2)))
28 endif
29
30+exists_bfd_ld = $(shell if $(CROSS_COMPILE)ld.bfd -v >& /dev/null; \
31+ then echo "$(1)"; else echo "$(2)"; fi; )
32 #
33 # Include the make variables (CC, etc...)
34 #
35 AS = $(CROSS_COMPILE)as
36-LD = $(CROSS_COMPILE)ld
37+LD = $(call exists_bfd_ld, "$(CROSS_COMPILE)ld.bfd", "$(CROSS_COMPILE)ld")
38 CC = $(CROSS_COMPILE)gcc
39 CPP = $(CC) -E
40 AR = $(CROSS_COMPILE)ar
41--
421.7.2.5
43
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0001-Revert-armv7-disable-L2-cache-in-cleanup_before_linu.patch b/recipes-bsp/u-boot/u-boot/2011.12/0008-Revert-armv7-disable-L2-cache-in-cleanup_before_linu.patch
index ea947099..9a13b691 100644
--- a/recipes-bsp/u-boot/u-boot/2011.12/0001-Revert-armv7-disable-L2-cache-in-cleanup_before_linu.patch
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0008-Revert-armv7-disable-L2-cache-in-cleanup_before_linu.patch
@@ -1,7 +1,7 @@
1From 9ac047a112d8c6fe25e71a78946dbe9d707abd98 Mon Sep 17 00:00:00 2001 1From 076f5b5c65a0f0652f5ba8b5328c52c76e951aaa Mon Sep 17 00:00:00 2001
2From: Philip Balister <philip@opensdr.com> 2From: Philip Balister <philip@opensdr.com>
3Date: Mon, 16 Jan 2012 09:45:11 -0500 3Date: Mon, 16 Jan 2012 09:45:11 -0500
4Subject: [PATCH] Revert "armv7: disable L2 cache in cleanup_before_linux()" 4Subject: [PATCH 08/10] Revert "armv7: disable L2 cache in cleanup_before_linux()"
5 5
6This reverts commit dc7100f4080952798413fb63bb4134b22c57623a. 6This reverts commit dc7100f4080952798413fb63bb4134b22c57623a.
7--- 7---
@@ -21,5 +21,5 @@ index 662c496..091e3e0 100644
21 /* 21 /*
22 * After D-cache is flushed and before it is disabled there may 22 * After D-cache is flushed and before it is disabled there may
23-- 23--
241.7.6.5 241.7.2.5
25 25
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0009-Beagleboard-Correct-memory-size-on-rev-C4.patch b/recipes-bsp/u-boot/u-boot/2011.12/0009-Beagleboard-Correct-memory-size-on-rev-C4.patch
new file mode 100644
index 00000000..be95db63
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0009-Beagleboard-Correct-memory-size-on-rev-C4.patch
@@ -0,0 +1,37 @@
1From 588d0e7259e17f302cb79d12ed0f47410a0d8697 Mon Sep 17 00:00:00 2001
2From: robertcnelson@gmail.com <robertcnelson@gmail.com>
3Date: Fri, 27 Jan 2012 07:09:42 +0000
4Subject: [PATCH 09/10] Beagleboard: Correct memory size on rev C4
5
6Beagleboard: Correct memory size on rev C4
7
8The logic for the rev C4 boards was missing one of the cases
9(variant with Micron NAND and 2x128MB).
10
11Signed-off-by: Robert Nelson <robertcnelson@gmail.com>
12Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
13---
14 board/ti/beagle/beagle.c | 7 +++++++
15 1 files changed, 7 insertions(+), 0 deletions(-)
16
17diff --git a/board/ti/beagle/beagle.c b/board/ti/beagle/beagle.c
18index 5ea50d1..4555977 100644
19--- a/board/ti/beagle/beagle.c
20+++ b/board/ti/beagle/beagle.c
21@@ -169,6 +169,13 @@ void get_board_mem_timings(u32 *mcfg, u32 *ctrla, u32 *ctrlb, u32 *rfr_ctrl,
22 *ctrlb = NUMONYX_V_ACTIMB_165;
23 *rfr_ctrl = SDP_3430_SDRC_RFR_CTRL_165MHz;
24 break;
25+ } else if (pop_mfr == NAND_MFR_MICRON && pop_id == 0xba) {
26+ /* Beagleboard Rev C4, 512MB Nand/256MB DDR*/
27+ *mcfg = MICRON_V_MCFG_165(128 << 20);
28+ *ctrla = MICRON_V_ACTIMA_165;
29+ *ctrlb = MICRON_V_ACTIMB_165;
30+ *rfr_ctrl = SDP_3430_SDRC_RFR_CTRL_165MHz;
31+ break;
32 } else if (pop_mfr == NAND_MFR_MICRON && pop_id == 0xbc) {
33 /* Beagleboard Rev C5, 256MB DDR */
34 *mcfg = MICRON_V_MCFG_200(256 << 20);
35--
361.7.2.5
37
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0010-OMAP3-Correct-get_sdr_cs_offset-mask.patch b/recipes-bsp/u-boot/u-boot/2011.12/0010-OMAP3-Correct-get_sdr_cs_offset-mask.patch
new file mode 100644
index 00000000..b9b61e57
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0010-OMAP3-Correct-get_sdr_cs_offset-mask.patch
@@ -0,0 +1,37 @@
1From 351fcc22c10beb005f589584b91298269a81aa52 Mon Sep 17 00:00:00 2001
2From: Tom Rini <trini@ti.com>
3Date: Wed, 18 Jan 2012 08:28:50 +0000
4Subject: [PATCH 10/10] OMAP3: Correct get_sdr_cs_offset mask
5
6OMAP3: Correct get_sdr_cs_offset mask
7
8The function get_sdr_cs_offset reads the CS_CFG register in the SDRC
9to determine where CS1 is mapped to. make_cs1_contiguous() will set
10CS1 to follow after CS0. The CS_CFG register has values in bits 9:8
11and 3:0 but we had erroneously been testing 5:4 and 3:0 resulting in
12incorrect offsets on platforms with less than 128MB as 3:0 describe
13128MB hunks and 9:8 describe 32MB offsets after the 128MB hunk.
14
15Tested-by: Grant Erickson <marathon96@gmail.com>
16Signed-off-by: Tom Rini <trini@ti.com>
17Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
18---
19 arch/arm/cpu/armv7/omap3/sdrc.c | 2 +-
20 1 files changed, 1 insertions(+), 1 deletions(-)
21
22diff --git a/arch/arm/cpu/armv7/omap3/sdrc.c b/arch/arm/cpu/armv7/omap3/sdrc.c
23index a27b4b1..91f42c0 100644
24--- a/arch/arm/cpu/armv7/omap3/sdrc.c
25+++ b/arch/arm/cpu/armv7/omap3/sdrc.c
26@@ -102,7 +102,7 @@ u32 get_sdr_cs_offset(u32 cs)
27 return 0;
28
29 offset = readl(&sdrc_base->cs_cfg);
30- offset = (offset & 15) << 27 | (offset & 0x30) << 17;
31+ offset = (offset & 15) << 27 | (offset & 0x300) << 17;
32
33 return offset;
34 }
35--
361.7.2.5
37
diff --git a/recipes-bsp/u-boot/u-boot_2011.12.bb b/recipes-bsp/u-boot/u-boot_2011.12.bb
index 4e50edb3..36108379 100644
--- a/recipes-bsp/u-boot/u-boot_2011.12.bb
+++ b/recipes-bsp/u-boot/u-boot_2011.12.bb
@@ -6,13 +6,13 @@ UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img"
6UBOOT_SYMLINK = "u-boot-${MACHINE}.img" 6UBOOT_SYMLINK = "u-boot-${MACHINE}.img"
7 7
8PV = "2011.12" 8PV = "2011.12"
9PR = "r3" 9PR = "r4"
10 10
11# No patches for other machines yet 11# No patches for other machines yet
12COMPATIBLE_MACHINE = "(beagleboard|pandaboard|hawkboard|am3517-evm|am37x-evm|omap3evm)" 12COMPATIBLE_MACHINE = "(beagleboard|pandaboard|hawkboard|am3517-evm|am37x-evm|omap3evm)"
13 13
14# Non-omap4 platforms need outer cache turned on 14# Non-omap4 platforms need outer cache turned on
15CACHEFIX = "file://2011.12/0001-Revert-armv7-disable-L2-cache-in-cleanup_before_linu.patch" 15CACHEFIX = "file://2011.12/0008-Revert-armv7-disable-L2-cache-in-cleanup_before_linu.patch"
16CACHEFIX_omap4 = "" 16CACHEFIX_omap4 = ""
17 17
18SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git \ 18SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git \
@@ -21,11 +21,14 @@ SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git \
21 file://2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch \ 21 file://2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch \
22 file://2011.12/0004-omap4-common-mount-root-RO.patch \ 22 file://2011.12/0004-omap4-common-mount-root-RO.patch \
23 file://2011.12/0005-omap4-common-use-ext4-by-default.patch \ 23 file://2011.12/0005-omap4-common-use-ext4-by-default.patch \
24 file://2011.12/U-Boot-OMAP-MMC-Add-delay-before-waiting-for-status.patch \ 24 file://2011.12/0006-OMAP-MMC-Add-delay-before-waiting-for-status.patch \
25 file://0001-config-Always-use-GNU-ld.patch \ 25 file://2011.12/0007-config-Always-use-GNU-ld.patch \
26 ${CACHEFIX} \ 26 ${CACHEFIX} \
27 file://2011.12/0009-Beagleboard-Correct-memory-size-on-rev-C4.patch \
28 file://2011.12/0010-OMAP3-Correct-get_sdr_cs_offset-mask.patch \
27 " 29 "
28 30
31
29# v2011.12 tag 32# v2011.12 tag
30SRCREV = "cba9a894fdb1cb49b60fcd1d1d6919cbd7995dd5" 33SRCREV = "cba9a894fdb1cb49b60fcd1d1d6919cbd7995dd5"
31 34