summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorKarthik Ramanan <a0393906@ti.com>2016-07-12 12:58:40 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-07-19 21:40:30 -0400
commitf0385d19a2aea72566849b20060189ac12c2826f (patch)
treec2dd3ce65c8f75d6f57de764ff0a1e2d92878ef5 /recipes-bsp
parenta00cd08b1173400b0afbeaf8891f8fb9c1861ac0 (diff)
downloadmeta-ti-f0385d19a2aea72566849b20060189ac12c2826f.tar.gz
ipumm-fw: Install map file into the targetfs
This will be required to analyze the remoteproc crash related issues, whenever it occurs. Signed-off-by: Karthik Ramanan <a0393906@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/ipumm-fw/ipumm-fw_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-bsp/ipumm-fw/ipumm-fw_git.bb b/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
index 331c25dc..3f558478 100644
--- a/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
+++ b/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
@@ -53,10 +53,12 @@ do_compile() {
53} 53}
54 54
55TARGET = "dra7-ipu2-fw.xem4" 55TARGET = "dra7-ipu2-fw.xem4"
56TARGET_MAP = "platform/ti/dce/baseimage/package/cfg/out/ipu/release/ipu.xem4.map"
56 57
57do_install() { 58do_install() {
58 install -d ${D}${base_libdir}/firmware 59 install -d ${D}${base_libdir}/firmware
59 install -m 0644 ${S}/${TARGET} ${D}${base_libdir}/firmware/${TARGET}.${BPN} 60 install -m 0644 ${S}/${TARGET} ${D}${base_libdir}/firmware/${TARGET}.${BPN}
61 install -m 0644 ${S}/${TARGET_MAP} ${D}${base_libdir}/firmware/${TARGET}.map
60} 62}
61 63
62ALTERNATIVE_${PN} = "dra7-ipu2-fw.xem4" 64ALTERNATIVE_${PN} = "dra7-ipu2-fw.xem4"
@@ -66,4 +68,4 @@ ALTERNATIVE_PRIORITY = "20"
66 68
67FILES_${PN} += "${base_libdir}/firmware/*" 69FILES_${PN} += "${base_libdir}/firmware/*"
68 70
69PR = "r1" 71PR = "r2"