diff options
author | Denys Dmytriyenko <denys@ti.com> | 2016-04-28 21:39:04 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2016-04-28 15:00:11 -0400 |
commit | a7e4b9560aaa9476e86e507132cc8705a4026db6 (patch) | |
tree | 56a7499ea2545c25148e88c79e0b304d7657ffd0 /recipes-bsp | |
parent | ed03cab5fb9f85d9874b819eeb9b072e965b3b66 (diff) | |
download | meta-ti-a7e4b9560aaa9476e86e507132cc8705a4026db6.tar.gz |
u-boot-ti-staging: add version 2016.05 (rc1)
Set UBOOT_LOCALVERSION by default similar to KERNEL_LOCALVERSION
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/u-boot/u-boot-ti-staging_2016.05.bb | 78 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-ti.inc | 12 |
2 files changed, 90 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging_2016.05.bb b/recipes-bsp/u-boot/u-boot-ti-staging_2016.05.bb new file mode 100644 index 00000000..f061c8c7 --- /dev/null +++ b/recipes-bsp/u-boot/u-boot-ti-staging_2016.05.bb | |||
@@ -0,0 +1,78 @@ | |||
1 | require u-boot-ti.inc | ||
2 | |||
3 | # u-boot needs devtree compiler to parse dts files | ||
4 | DEPENDS += "dtc-native" | ||
5 | |||
6 | DESCRIPTION = "u-boot bootloader for TI devices" | ||
7 | |||
8 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6" | ||
9 | |||
10 | PR = "r0" | ||
11 | PV_append = "+git${SRCPV}" | ||
12 | |||
13 | SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}" | ||
14 | |||
15 | BRANCH ?= "ti-u-boot-2016.05" | ||
16 | |||
17 | SRCREV = "70f44b8fc3dac08f44fba75f1dc25680be208fba" | ||
18 | |||
19 | # Support for secure devices - detailed info is in doc/README.ti-secure | ||
20 | TI_SECURE_DEV_PKG ?= "" | ||
21 | TI_SECURE_DEV_PKG_dra7xx-hs-evm = "${TI_SECURE_DEV_PKG_DRA7}" | ||
22 | TI_SECURE_DEV_PKG_am437x-hs-evm = "${TI_SECURE_DEV_PKG_AM4}" | ||
23 | export TI_SECURE_DEV_PKG | ||
24 | |||
25 | SPL_BINARY = "MLO" | ||
26 | SPL_UART_BINARY = "u-boot-spl.bin" | ||
27 | |||
28 | # Keystone specifics | ||
29 | UBOOT_SUFFIX_keystone = "bin" | ||
30 | SPL_UART_BINARY_keystone = "" | ||
31 | |||
32 | # SPI NOR Flash binaries | ||
33 | UBOOT_SPI_SPL_BINARY = "u-boot-spl.bin" | ||
34 | UBOOT_SPI_BINARY = "u-boot.img" | ||
35 | UBOOT_SPI_GPH_BINARY = "u-boot-spi.gph" | ||
36 | |||
37 | # SPI NOR Flash deployed images | ||
38 | UBOOT_SPI_SPL_IMAGE = "u-boot-spl-${MACHINE}-${PV}-${PR}.bin" | ||
39 | UBOOT_SPI_SPL_SYMLINK = "u-boot-spl-${MACHINE}.bin" | ||
40 | UBOOT_SPI_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img" | ||
41 | UBOOT_SPI_SYMLINK = "u-boot-${MACHINE}.img" | ||
42 | UBOOT_SPI_GPH_IMAGE = "u-boot-spi-${MACHINE}-${PV}-${PR}.gph" | ||
43 | UBOOT_SPI_GPH_SYMLINK = "u-boot-spi-${MACHINE}.gph" | ||
44 | |||
45 | do_compile_append_am437x-hs-evm () { | ||
46 | if [ -f ${S}/u-boot-spl_HS_ISSW ]; then | ||
47 | rm -rf ${S}/MLO | ||
48 | cp ${S}/u-boot-spl_HS_ISSW ${S}/MLO | ||
49 | fi | ||
50 | } | ||
51 | |||
52 | do_install_append_keystone () { | ||
53 | install ${S}/spl/${UBOOT_SPI_SPL_BINARY} ${D}/boot/${UBOOT_SPI_SPL_IMAGE} | ||
54 | ln -sf ${UBOOT_SPI_SPL_IMAGE} ${D}/boot/${UBOOT_SPI_SPL_BINARY} | ||
55 | |||
56 | install ${S}/${UBOOT_SPI_BINARY} ${D}/boot/${UBOOT_SPI_IMAGE} | ||
57 | ln -sf ${UBOOT_SPI_IMAGE} ${D}/boot/${UBOOT_SPI_BINARY} | ||
58 | |||
59 | install ${S}/${UBOOT_SPI_GPH_BINARY} ${D}/boot/${UBOOT_SPI_GPH_IMAGE} | ||
60 | ln -sf ${UBOOT_SPI_GPH_IMAGE} ${D}/boot/${UBOOT_SPI_GPH_BINARY} | ||
61 | } | ||
62 | |||
63 | do_deploy_append_keystone () { | ||
64 | install ${S}/spl/${UBOOT_SPI_SPL_BINARY} ${DEPLOYDIR}/${UBOOT_SPI_SPL_IMAGE} | ||
65 | rm -f ${UBOOT_SPI_SPL_BINARY} ${UBOOT_SPI_SPL_SYMLINK} | ||
66 | ln -sf ${UBOOT_SPI_SPL_IMAGE} ${UBOOT_SPI_SPL_SYMLINK} | ||
67 | ln -sf ${UBOOT_SPI_SPL_IMAGE} ${UBOOT_SPI_SPL_BINARY} | ||
68 | |||
69 | install ${S}/${UBOOT_SPI_BINARY} ${DEPLOYDIR}/${UBOOT_SPI_IMAGE} | ||
70 | rm -f ${UBOOT_SPI_BINARY} ${UBOOT_SPI_SYMLINK} | ||
71 | ln -sf ${UBOOT_SPI_IMAGE} ${UBOOT_SPI_SYMLINK} | ||
72 | ln -sf ${UBOOT_SPI_IMAGE} ${UBOOT_SPI_BINARY} | ||
73 | |||
74 | install ${S}/${UBOOT_SPI_GPH_BINARY} ${DEPLOYDIR}/${UBOOT_SPI_GPH_IMAGE} | ||
75 | rm -f ${UBOOT_SPI_GPH_BINARY} ${UBOOT_SPI_GPH_SYMLINK} | ||
76 | ln -sf ${UBOOT_SPI_GPH_IMAGE} ${UBOOT_SPI_GPH_SYMLINK} | ||
77 | ln -sf ${UBOOT_SPI_GPH_IMAGE} ${UBOOT_SPI_GPH_BINARY} | ||
78 | } | ||
diff --git a/recipes-bsp/u-boot/u-boot-ti.inc b/recipes-bsp/u-boot/u-boot-ti.inc index 0cb53ea9..b0054c96 100644 --- a/recipes-bsp/u-boot/u-boot-ti.inc +++ b/recipes-bsp/u-boot/u-boot-ti.inc | |||
@@ -1,3 +1,15 @@ | |||
1 | # UBOOT_LOCALVERSION can be set to add a tag to the end of the | ||
2 | # U-boot version string. such as the commit id | ||
3 | def get_git_revision(p): | ||
4 | import subprocess | ||
5 | |||
6 | try: | ||
7 | return subprocess.Popen("git rev-parse HEAD 2>/dev/null ", cwd=p, shell=True, stdout=subprocess.PIPE).communicate()[0].rstrip() | ||
8 | except OSError: | ||
9 | return None | ||
10 | |||
11 | UBOOT_LOCALVERSION = "-g${@get_git_revision('${S}').__str__()[:10]}" | ||
12 | |||
1 | UBOOT_SUFFIX ?= "img" | 13 | UBOOT_SUFFIX ?= "img" |
2 | 14 | ||
3 | require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc | 15 | require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc |