summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorJason Kridner <jdk@ti.com>2011-09-19 22:32:57 -0500
committerKoen Kooi <koen@dominion.thruhere.net>2011-09-20 08:41:07 +0200
commitc5db81e4ecffe0e0a41edc408d73242bd26740eb (patch)
treee3cb87dfd99aa7d0083f8c9bb230cbc4604e8e76 /recipes-bsp
parentf99ad0105b79186972415a4782b2be5cb869c939 (diff)
downloadmeta-ti-c5db81e4ecffe0e0a41edc408d73242bd26740eb.tar.gz
u-boot: added version 2011.09
There is a v2011.09 tag on the mainline, but I haven't seen a release notice go out. It didn't make sense to me to try to carry-forward those all patches since the release tag, so I simply picked the latest tag in the maineline. Patched and tested on BeagleBoard-xM revision C. USB Ethernet was tested with: setenv usbethaddr de:ad:be:ef:00:01 usb start dhcp^C setenv ipaddr 10.0.1.2 ping 10.0.1.1 USB Storage was tested with: <above> usb part fatls usb 0 led command was tested with: led all off led all on led 1 on led 1 off gpio command tested with: gpio input 4 <hold USER button> gpio input 4 <release USER button> Also performed boot test. Signed-off-by: Jason Kridner <jdk@ti.com> Signed-off-by: Joel A Fernandes <joelagnel@ti.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.09/0001-HACK-beagleboard-config-disable-cache-for-USB.patch33
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.09/0002-beagleboard-config-enable-gpio-command.patch25
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.09/0003-Increased-some-timeout-durations-for-MMC-and-EHCI.patch39
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.09.bb20
4 files changed, 117 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot/2011.09/0001-HACK-beagleboard-config-disable-cache-for-USB.patch b/recipes-bsp/u-boot/u-boot/2011.09/0001-HACK-beagleboard-config-disable-cache-for-USB.patch
new file mode 100644
index 00000000..a2776e9a
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.09/0001-HACK-beagleboard-config-disable-cache-for-USB.patch
@@ -0,0 +1,33 @@
1From 03b9bca863257cb24d8f11bb773ad2b8dff820c6 Mon Sep 17 00:00:00 2001
2From: Jason Kridner <jdk@ti.com>
3Date: Sun, 18 Sep 2011 12:16:31 -0400
4Subject: [PATCH 1/3] HACK: beagleboard: config: disable cache for USB
5
6There is currently a bug in the USB code for the BeagleBoard that is
7worked-around by disabling the cache.
8
9See http://comments.gmane.org/gmane.comp.boot-loaders.u-boot/108224
10
11Signed-off-by: Jason Kridner <jdk@ti.com>
12---
13 include/configs/omap3_beagle.h | 5 +++++
14 1 files changed, 5 insertions(+), 0 deletions(-)
15
16diff --git a/include/configs/omap3_beagle.h b/include/configs/omap3_beagle.h
17index 1369c89..8a84d7a 100644
18--- a/include/configs/omap3_beagle.h
19+++ b/include/configs/omap3_beagle.h
20@@ -36,6 +36,10 @@
21 #define CONFIG_OMAP3430 1 /* which is in a 3430 */
22 #define CONFIG_OMAP3_BEAGLE 1 /* working with BEAGLE */
23
24+/* TODO: WORK-AROUND for bug in BeagleBoard-specific USB */
25+#define CONFIG_SYS_ICACHE_OFF
26+#define CONFIG_SYS_DCACHE_OFF
27+
28 #define CONFIG_SDRC /* The chip has SDRC controller */
29
30 #include <asm/arch/cpu.h> /* get chip and board defs */
31--
321.7.4.1
33
diff --git a/recipes-bsp/u-boot/u-boot/2011.09/0002-beagleboard-config-enable-gpio-command.patch b/recipes-bsp/u-boot/u-boot/2011.09/0002-beagleboard-config-enable-gpio-command.patch
new file mode 100644
index 00000000..096a1ce3
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.09/0002-beagleboard-config-enable-gpio-command.patch
@@ -0,0 +1,25 @@
1From 79e8280783d445f7630b8a9830f8db73f2e04828 Mon Sep 17 00:00:00 2001
2From: Jason Kridner <jdk@ti.com>
3Date: Tue, 6 Sep 2011 18:56:11 -0400
4Subject: [PATCH 2/3] beagleboard: config: enable gpio command
5
6Now that we are using the generic GPIO framework, enable the command.
7---
8 include/configs/omap3_beagle.h | 1 +
9 1 files changed, 1 insertions(+), 0 deletions(-)
10
11diff --git a/include/configs/omap3_beagle.h b/include/configs/omap3_beagle.h
12index 8a84d7a..43dc94a 100644
13--- a/include/configs/omap3_beagle.h
14+++ b/include/configs/omap3_beagle.h
15@@ -169,6 +169,7 @@
16 #define CONFIG_CMD_PING
17 #define CONFIG_CMD_DHCP
18 #define CONFIG_CMD_SETEXPR /* Evaluate expressions */
19+#define CONFIG_CMD_GPIO
20
21 #undef CONFIG_CMD_FLASH /* flinfo, erase, protect */
22 #undef CONFIG_CMD_FPGA /* FPGA configuration Support */
23--
241.7.4.1
25
diff --git a/recipes-bsp/u-boot/u-boot/2011.09/0003-Increased-some-timeout-durations-for-MMC-and-EHCI.patch b/recipes-bsp/u-boot/u-boot/2011.09/0003-Increased-some-timeout-durations-for-MMC-and-EHCI.patch
new file mode 100644
index 00000000..c3ebf1bd
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.09/0003-Increased-some-timeout-durations-for-MMC-and-EHCI.patch
@@ -0,0 +1,39 @@
1From 316e3a4573bdbbbc395baeca4f7b2208707e30fa Mon Sep 17 00:00:00 2001
2From: Jason Kridner <jdk@ti.com>
3Date: Wed, 7 Sep 2011 08:56:48 -0400
4Subject: [PATCH 3/3] Increased some timeout durations for MMC and EHCI
5
6---
7 drivers/mmc/omap_hsmmc.c | 2 +-
8 include/usb.h | 2 +-
9 2 files changed, 2 insertions(+), 2 deletions(-)
10
11diff --git a/drivers/mmc/omap_hsmmc.c b/drivers/mmc/omap_hsmmc.c
12index ef12ecd..7e35372 100644
13--- a/drivers/mmc/omap_hsmmc.c
14+++ b/drivers/mmc/omap_hsmmc.c
15@@ -33,7 +33,7 @@
16 #include <asm/arch/sys_proto.h>
17
18 /* If we fail after 1 second wait, something is really bad */
19-#define MAX_RETRY_MS 1000
20+#define MAX_RETRY_MS 5000
21
22 static int mmc_read_data(hsmmc_t *mmc_base, char *buf, unsigned int size);
23 static int mmc_write_data(hsmmc_t *mmc_base, const char *buf, unsigned int siz);
24diff --git a/include/usb.h b/include/usb.h
25index 06170cd..0d99b92 100644
26--- a/include/usb.h
27+++ b/include/usb.h
28@@ -46,7 +46,7 @@
29 * This is the timeout to allow for submitting an urb in ms. We allow more
30 * time for a BULK device to react - some are slow.
31 */
32-#define USB_TIMEOUT_MS(pipe) (usb_pipebulk(pipe) ? 5000 : 1000)
33+#define USB_TIMEOUT_MS(pipe) (usb_pipebulk(pipe) ? 5000 : 5000)
34
35 /* device request (setup) */
36 struct devrequest {
37--
381.7.4.1
39
diff --git a/recipes-bsp/u-boot/u-boot_2011.09.bb b/recipes-bsp/u-boot/u-boot_2011.09.bb
new file mode 100644
index 00000000..dad820f4
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot_2011.09.bb
@@ -0,0 +1,20 @@
1require u-boot.inc
2
3# No patches for other machines yet
4COMPATIBLE_MACHINE = "(beagleboard)"
5
6SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git \
7 file://2011.09/0001-HACK-beagleboard-config-disable-cache-for-USB.patch \
8 file://2011.09/0002-beagleboard-config-enable-gpio-command.patch \
9 file://2011.09/0003-Increased-some-timeout-durations-for-MMC-and-EHCI.patch \
10 file://fw_env.config \
11 "
12# v2011.09 tag -> 6ceb0135f96d73063ffbaab5be7ce23933367388
13# The tag below is from the master tree, but 21 patches after.
14# $ git log 6ceb0135f..56fa45d58 | grep commit | wc -l
15# 21
16SRCREV = "56fa45d58116f86f343a9c45ce6d1110f50b8d70"
17
18LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
19
20S = "${WORKDIR}/git"