summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-08 08:10:43 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-08 08:10:43 +0100
commit424830eb541e48eb2d898cfe48ba3c59e279cc94 (patch)
treedd6b759558d82b25d759060b8604db63b242eb18 /recipes-bsp
parent3bb013a14535b40b79fbeaa33799754fb74953be (diff)
downloadmeta-ti-424830eb541e48eb2d898cfe48ba3c59e279cc94.tar.gz
u-boot 2011.10rc: turn on dcache for beaglebone
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.09git/0008-HACK-am335x-evm-turn-d-cache-on-globally-turn-it-off.patch46
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.10rc.bb3
2 files changed, 48 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0008-HACK-am335x-evm-turn-d-cache-on-globally-turn-it-off.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0008-HACK-am335x-evm-turn-d-cache-on-globally-turn-it-off.patch
new file mode 100644
index 00000000..b79a8844
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.09git/0008-HACK-am335x-evm-turn-d-cache-on-globally-turn-it-off.patch
@@ -0,0 +1,46 @@
1From 31d430d8db335b7c3fea08b6aa8309b90b8f2cb9 Mon Sep 17 00:00:00 2001
2From: Tom Rini <trini@ti.com>
3Date: Tue, 8 Nov 2011 08:07:47 +0100
4Subject: [PATCH 8/8] HACK: am335x evm: turn d-cache on globally, turn it off when doing nfs stuff
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 board/ti/am335x/evm.c | 12 ++++++++++++
9 include/configs/am335x_evm.h | 1 +
10 2 files changed, 13 insertions(+), 0 deletions(-)
11
12diff --git a/board/ti/am335x/evm.c b/board/ti/am335x/evm.c
13index bc1119e..e64626a 100644
14--- a/board/ti/am335x/evm.c
15+++ b/board/ti/am335x/evm.c
16@@ -1041,3 +1041,15 @@ U_BOOT_CMD(
17
18 #endif /* CONFIG_NAND_TI81XX */
19 #endif /* CONFIG_SPL_BUILD */
20+
21+/*
22+ * Not all drivers we use (such as ethernet) are dcache safe. But
23+ * we need cache on to boot quickly enough.
24+ */
25+#ifndef CONFIG_SYS_DCACHE_OFF
26+void enable_caches(void)
27+{
28+ /* Enable D-cache. I-cache is already enabled in start.S */
29+ dcache_enable();
30+}
31+#endif
32diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
33index 8bf3ff1..58fa2f6 100755
34--- a/include/configs/am335x_evm.h
35+++ b/include/configs/am335x_evm.h
36@@ -119,6 +119,7 @@
37 "bootm ${loadaddr}\0" \
38 "net_boot=echo Booting from network ...; " \
39 "setenv autoload no; " \
40+ "dcache off; " \
41 "dhcp; " \
42 "tftp ${loadaddr} ${bootfile}; " \
43 "run net_args; " \
44--
451.7.2.5
46
diff --git a/recipes-bsp/u-boot/u-boot_2011.10rc.bb b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
index 2e0115f0..fd7d99c4 100644
--- a/recipes-bsp/u-boot/u-boot_2011.10rc.bb
+++ b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
@@ -4,7 +4,7 @@ require u-boot.inc
4COMPATIBLE_MACHINE = "(ti33x)" 4COMPATIBLE_MACHINE = "(ti33x)"
5DEFAULT_PREFERENCE_ti33x = "99" 5DEFAULT_PREFERENCE_ti33x = "99"
6PV = "2011.09+git" 6PV = "2011.09+git"
7PR = "r20" 7PR = "r21"
8 8
9# SPL build 9# SPL build
10UBOOT_BINARY = "u-boot.img" 10UBOOT_BINARY = "u-boot.img"
@@ -19,6 +19,7 @@ SRC_URI = "git://arago-project.org/git/projects/u-boot-am33x.git;protocol=git;br
19 file://2011.09git/0005-am335x-Change-mmc_load_uimage-to-load-at-a-fixed-add.patch \ 19 file://2011.09git/0005-am335x-Change-mmc_load_uimage-to-load-at-a-fixed-add.patch \
20 file://2011.09git/0006-am335x-evm-Fix-bone-pmic-shut-down-over-USB-power.patch \ 20 file://2011.09git/0006-am335x-evm-Fix-bone-pmic-shut-down-over-USB-power.patch \
21 file://2011.09git/0007-am335x_evm-switch-to-ext4.patch \ 21 file://2011.09git/0007-am335x_evm-switch-to-ext4.patch \
22 file://2011.09git/0008-HACK-am335x-evm-turn-d-cache-on-globally-turn-it-off.patch \
22 " 23 "
23 24
24SRCREV = "f63b270e47f62f4d1a05b2001357e215966c6f5a" 25SRCREV = "f63b270e47f62f4d1a05b2001357e215966c6f5a"