summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-07-20 10:09:29 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-07-20 10:20:57 +0200
commit3240a13c1272b37fda5bc4dc26741aac387a8a74 (patch)
treee5227fa266222e5710d8fa7df0141f750cd557e6 /recipes-bsp
parenteab43c77d7908c2ee095f11597c38c1f8608d2d0 (diff)
downloadmeta-ti-3240a13c1272b37fda5bc4dc26741aac387a8a74.tar.gz
x-load: add 1.46-psp
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/x-load/x-load.inc2
-rw-r--r--recipes-bsp/x-load/x-load_1.46-psp.bb38
2 files changed, 39 insertions, 1 deletions
diff --git a/recipes-bsp/x-load/x-load.inc b/recipes-bsp/x-load/x-load.inc
index db45286a..55cad232 100644
--- a/recipes-bsp/x-load/x-load.inc
+++ b/recipes-bsp/x-load/x-load.inc
@@ -39,7 +39,7 @@ FILES_${PN} = "/boot"
39 39
40inherit deploy 40inherit deploy
41 41
42addtask deploy before do_package after do_compile 42addtask deploy before do_package after do_install
43 43
44do_deploy () { 44do_deploy () {
45 install -d ${DEPLOY_DIR_IMAGE} 45 install -d ${DEPLOY_DIR_IMAGE}
diff --git a/recipes-bsp/x-load/x-load_1.46-psp.bb b/recipes-bsp/x-load/x-load_1.46-psp.bb
new file mode 100644
index 00000000..108e408d
--- /dev/null
+++ b/recipes-bsp/x-load/x-load_1.46-psp.bb
@@ -0,0 +1,38 @@
1require x-load.inc
2
3DEPENDS += "signgp-native"
4
5LIC_FILES_CHKSUM = "file://README;md5=fb7a7e60aceaa99c529b6c667dfcf474"
6
7COMPATIBLE_MACHINE = "am3517-evm"
8
9PV = "1.46+${PR}+gitr${SRCREV}"
10PR ="r0"
11PE = "1"
12
13# TI PSP v1.46_OMAPPSP_03.00.01.06 (Tag is one commit different)
14SRCREV_pn-${PN} = "fc6d5be15c703d21aef0ae0b8c02177721f0445f"
15SRC_URI = "git://arago-project.org/git/projects/x-load-omap3.git;protocol=git"
16
17S = "${WORKDIR}/git"
18
19do_compile () {
20 unset LDFLAGS
21 unset CFLAGS
22 unset CPPFLAGS
23 oe_runmake distclean
24 oe_runmake ${XLOAD_MACHINE}
25 oe_runmake
26}
27
28do_install () {
29 signGP x-load.bin ${XLOAD_LOAD_ADDRESS}
30
31 install -d ${D}/boot
32 install x-load.bin.ift ${D}/boot/${MLO_IMAGE}
33 ln -sf ${MLO_IMAGE} ${D}/boot/${MLO_SYMLINK_NOMACHINE}
34}
35
36FILES_${PN} = "/boot"
37
38PACKAGE_ARCH = "${MACHINE_ARCH}"