summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2017-03-11 03:08:39 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-03-11 10:44:01 -0500
commit08b3f376f8aa1ad945f288ee728d3f2b59c373c6 (patch)
tree0fa27201ed19356125dd58cd8197946f9e1a81ca /recipes-bsp
parentb0d7b46c03cfdbbf2aef8c0bae9751827fa53951 (diff)
downloadmeta-ti-08b3f376f8aa1ad945f288ee728d3f2b59c373c6.tar.gz
wl18xx-fw: add version 8.7.1 (R8.7_SP1)
Previous versions were provided by meta-arago-extras, moving to meta-ti now. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch29
-rw-r--r--recipes-bsp/wl18xx-fw/wl18xx-fw_8.7.1.bb26
2 files changed, 55 insertions, 0 deletions
diff --git a/recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch b/recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch
new file mode 100644
index 00000000..a8db0770
--- /dev/null
+++ b/recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch
@@ -0,0 +1,29 @@
1From 3a8fc3ccf00796254d6cef4b6d4cd70dc37012e1 Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Fri, 10 Mar 2017 13:28:29 -0500
4Subject: [PATCH] Add Makefile to install firmware files
5
6Signed-off-by: Denys Dmytriyenko <denys@ti.com>
7---
8 Makefile | 9 +++++++++
9 1 file changed, 9 insertions(+)
10 create mode 100644 Makefile
11
12diff --git a/Makefile b/Makefile
13new file mode 100644
14index 0000000..1cf38e3
15--- /dev/null
16+++ b/Makefile
17@@ -0,0 +1,9 @@
18+# Installs the the ti-connectivity wlan firmware files into the root file system
19+
20+install:
21+ @if [ ! -d $(DESTDIR) ] ; then \
22+ echo "Target filesystem directory doesn't exist."; \
23+ exit 1; \
24+ fi
25+ install -d $(DEST_DIR)/lib/firmware/ti-connectivity
26+ cp *.bin $(DEST_DIR)/lib/firmware/ti-connectivity/
27--
282.7.4
29
diff --git a/recipes-bsp/wl18xx-fw/wl18xx-fw_8.7.1.bb b/recipes-bsp/wl18xx-fw/wl18xx-fw_8.7.1.bb
new file mode 100644
index 00000000..ec360fef
--- /dev/null
+++ b/recipes-bsp/wl18xx-fw/wl18xx-fw_8.7.1.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "Firmware files for use with TI wl18xx"
2LICENSE = "TI-TSPA"
3LIC_FILES_CHKSUM = "file://LICENCE;md5=4977a0fe767ee17765ae63c435a32a9e"
4
5SRC_URI = " \
6 git://git.ti.com/wilink8-wlan/wl18xx_fw.git;protocol=git;branch=${BRANCH} \
7 file://0001-Add-Makefile-to-install-firmware-files.patch \
8"
9
10# Tag: R8.7-SP1 (8.7.1)
11SRCREV = "fe3909e93d15a4b17e43699dde2bba0e9a3c0abc"
12BRANCH = "master"
13
14S = "${WORKDIR}/git"
15
16CLEANBROKEN = "1"
17
18do_compile() {
19 :
20}
21
22do_install() {
23 oe_runmake 'DEST_DIR=${D}' install
24}
25
26FILES_${PN} = "/lib/firmware/ti-connectivity/*"