summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorIvan Pang <i-pang@ti.com>2017-08-01 11:45:06 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-08-16 13:49:01 -0400
commit9a02ab782d691fb3e34b23b668f32e1437720848 (patch)
treee454f7045750dbf5f07e0922bf43e381bbbf2f26 /recipes-bsp
parenta808c8940555d10c8154a6ce0a171cb520fd417b (diff)
downloadmeta-ti-9a02ab782d691fb3e34b23b668f32e1437720848.tar.gz
ibl-boot-rtos: added recipe for RTOS IBL
This recipe adds the Intermediate Bootloader (IBL) for c665x-evm and c667x-evm. Signed-off-by: Ivan Pang <i-pang@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb b/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb
new file mode 100644
index 00000000..ed30ef45
--- /dev/null
+++ b/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb
@@ -0,0 +1,63 @@
1SUMMARY = "Second stage bootloader for c66x"
2DESCRIPTION = "The Intermediate Bootloader (IBL) is a second stage \
3bootloader for the c66x family of embedded processors. This second \
4stage bootloader takes care of additional initializations, advisory \
5setups, and errata workarounds that are not present in the first stage boot."
6
7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://src/ibl.h;beginline=1;endline=34;md5=ee7d7a3305d1e524955996d1c5e31cb9"
9
10require recipes-ti/includes/ti-paths.inc
11
12DEPENDS = "ti-cgt6x-7-native"
13
14PACKAGE_ARCH = "${MACHINE_ARCH}"
15COMPATIBLE_MACHINE = "c66x"
16
17BRANCH = "master"
18SRC_URI = "git://git.ti.com/keystone-rtos/ibl.git;protocol=git;branch=${BRANCH}"
19SRCREV = "f7ed32cc8911e3353dd01080da9b725b44a12285"
20PR = "r0"
21
22S = "${WORKDIR}/git"
23
24PATH_prepend = "${TI_CGT6X_7_INSTALL_DIR}/bin:"
25
26IBLTARGETS = ""
27IBLTARGETS_c665x-evm = "evm_c6657_i2c"
28IBLTARGETS_c667x-evm = "evm_c6678_i2c"
29
30IBLENDIAN = ""
31IBLENDIAN_c665x-evm = "little big"
32IBLENDIAN_c667x-evm = "little big"
33
34export C6X_BASE_DIR="${TI_CGT6X_7_INSTALL_DIR}"
35export TOOLSC6X="${C6X_BASE_DIR}"
36export TOOLSC6XDOS="${C6X_BASE_DIR}"
37export TOOLSBIOSC6XDOS="${C6X_BASE_DIR}"
38export PDK_INSTALL_PATH = "${PDK_INSTALL_DIR}/packages"
39
40do_compile() {
41 cd src/make
42 for t in ${IBLTARGETS}
43 do
44 for e in ${IBLENDIAN}
45 do
46 make ${t} ENDIAN=${e} I2C_BUS_ADDR=0x51
47 done
48 done
49 cd -
50}
51
52do_install() {
53 install -d ${D}${PDK_INSTALL_DIR_RECIPE}/packages/ti/boot/ibl
54 cp -rP --preserve=mode,links,timestamps --no-preserve=ownership * ${D}${PDK_INSTALL_DIR_RECIPE}/packages/ti/boot/ibl
55}
56
57FILES_${PN} += "${PDK_INSTALL_DIR_RECIPE}/packages"
58
59INHIBIT_PACKAGE_STRIP = "1"
60INHIBIT_SYSROOT_STRIP = "1"
61INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
62
63INSANE_SKIP_${PN} = "arch file-rdeps"