summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2013-02-28 16:52:53 -0500
committerDenys Dmytriyenko <denys@ti.com>2013-03-04 11:34:57 -0500
commita80ec1d7bec835a743701a8f19c87efdaf92a6ba (patch)
treefd28e0adf2e074005c0145c382d57bbb9a4a815e /recipes-bsp
parent39d1a0caa79ff270d0b838cd37250f5c58195de1 (diff)
downloadmeta-ti-a80ec1d7bec835a743701a8f19c87efdaf92a6ba.tar.gz
u-boot 2012.10: add the latest SDK 05.06 version from meta-arago
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot_2012.10.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot_2012.10.bb b/recipes-bsp/u-boot/u-boot_2012.10.bb
new file mode 100644
index 00000000..89d646c6
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot_2012.10.bb
@@ -0,0 +1,32 @@
1# Use the version of u-boot.inc in oe-core not the meta-ti version
2require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
3
4# Reset OEMAKE. Current u-boot.inc sets -02 which breaks this version of u-boot's build.
5# This issue was fixed in oe-core master by removing the -02 statement.
6EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
7
8DESCRIPTION = "u-boot bootloader for ARM MPU devices"
9LICENSE = "GPLv2+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
11
12COMPATIBLE_MACHINE = "ti33x|omap3"
13
14DEFAULT_PREFERENCE = "-1"
15
16PACKAGE_ARCH = "${MACHINE_ARCH}"
17
18PR = "r7+gitr${SRCPV}"
19
20SRC_URI = "git://arago-project.org/git/projects/u-boot-am33x.git;protocol=git;branch=${BRANCH} \
21"
22
23BRANCH = "amsdk-05.06.00.00"
24
25SRCREV = "6536bfa6b7f16bb49fdea8c72959e3ed54e77a82"
26
27S = "${WORKDIR}/git"
28
29UBOOT_SUFFIX = "img"
30
31# Set the name of the SPL that will built so that it is also packaged with u-boot.
32SPL_BINARY = "MLO"