diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2015-05-20 19:30:20 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-05-22 12:31:51 -0400 |
commit | d20340cdf0b99a9cb70c09eeae34cf7879706d8e (patch) | |
tree | 0d817b0f71ce240d6c24b9110b529d8ced8383da /recipes-bsp | |
parent | 2e5b5d7127ffaa82fbd4ccfbc14342229bd27103 (diff) | |
download | meta-ti-d20340cdf0b99a9cb70c09eeae34cf7879706d8e.tar.gz |
libulm: Add ULM library for ARM and DSP.
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/dsptop/libulm_git.bb | 42 |
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes-bsp/dsptop/libulm_git.bb b/recipes-bsp/dsptop/libulm_git.bb new file mode 100644 index 00000000..306d86fa --- /dev/null +++ b/recipes-bsp/dsptop/libulm_git.bb | |||
@@ -0,0 +1,42 @@ | |||
1 | DESCRIPTION = "TI dsptop utility." | ||
2 | LICENSE = "BSD" | ||
3 | LIC_FILES_CHKSUM = "file://../debian/copyright;md5=309825aa8f5edfcf2c44912ac094b979" | ||
4 | |||
5 | DEPENDS = "ti-cgt6x-native" | ||
6 | PR = "${INC_PR}.0" | ||
7 | |||
8 | S = "${WORKDIR}/git/dsptop/ulm" | ||
9 | |||
10 | DEVICE="" | ||
11 | DEVICE_dra7xx = "DRA7xx" | ||
12 | DEVICE_keystone = "C66AK2Hxx" | ||
13 | |||
14 | EXTRA_OEMAKE = "release DEVICE=${DEVICE} CROSS_COMPILE=${TARGET_PREFIX}" | ||
15 | |||
16 | do_compile() { | ||
17 | oe_runmake arm XPORT_ONLY | ||
18 | oe_runmake dsp C6X_C_DIR=${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x/include | ||
19 | } | ||
20 | |||
21 | do_install() { | ||
22 | install -d ${D}${includedir} | ||
23 | install -d ${D}${libdir} | ||
24 | install -d ${D}${datadir}/ti/ulm | ||
25 | cp -f tiulm.h ${D}${includedir} | ||
26 | cp -f release/libtiulm.a ${D}${libdir} | ||
27 | cp -f tiulm.h ${D}${datadir}/ti/ulm | ||
28 | cp -f release/libtiulm.ae66 ${D}${datadir}/ti/ulm | ||
29 | } | ||
30 | |||
31 | COMPATIBLE_MACHINE = "dra7xx|keystone" | ||
32 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
33 | |||
34 | FILES_${PN}-dev += "\ | ||
35 | ${datadir}/ti/ulm \ | ||
36 | " | ||
37 | |||
38 | include dsptop.inc | ||
39 | |||
40 | ALLOW_EMPTY_${PN} = "1" | ||
41 | |||
42 | PARALLEL_MAKE= "" | ||