summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2013-08-31 23:11:32 -0400
committerDenys Dmytriyenko <denys@ti.com>2013-09-03 13:07:49 -0400
commitcb6f542fe85ca6d5afa2ff2c49f3af042e95d949 (patch)
treefa73c5bdac36cccf64aee22a7feb33c3bc8660b4 /recipes-bsp
parent9e07040a0b73f4ea11ff4441e1046269ddc9bc05 (diff)
downloadmeta-ti-cb6f542fe85ca6d5afa2ff2c49f3af042e95d949.tar.gz
libgles-omap3, omap3-sgx-modules: remove old 4.03.00.02 version
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb45
1 files changed, 0 insertions, 45 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb
deleted file mode 100644
index 4f9be7bc..00000000
--- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb
+++ /dev/null
@@ -1,45 +0,0 @@
1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=21228a42e27d1d104b31a83f7c9da935"
4
5TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
6require ../../recipes-ti/includes/ti-eula-unpack.inc
7
8SGXPV = "4_03_00_02"
9IMGPV = "1.6.16.3977"
10BINFILE := "Graphics_SDK_setuplinux_${SGXPV}.bin"
11
12inherit module
13
14MACHINE_KERNEL_PR_append = "b"
15PR = "${MACHINE_KERNEL_PR}"
16
17SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE} \
18 file://Compile-fixes-for-38-kernel.patch \
19 file://kernel-30.patch \
20 "
21SRC_URI[md5sum] = "ff8c1f2b8e4cb42f4ced6a613b081ada"
22SRC_URI[sha256sum] = "cdb0bd3964e107733d632aa8224e0537b05c1ffac34befc036423458c8d75255"
23TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}"
24S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM"
25
26PVRBUILD = "release"
27export KERNELDIR = "${STAGING_KERNEL_DIR}"
28
29INHIBIT_PACKAGE_STRIP = "1"
30
31TI_PLATFORM_omap3 = "omap3630"
32TI_PLATFORM_ti816x = "ti81xx"
33
34MODULESLOCATION_omap3 = "dc_omap3430_linux"
35MODULESLOCATION_ti816x = "dc_ti81xx_linux"
36
37MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM}"
38
39do_install() {
40 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
41 cp ${S}/pvrsrvkm.ko \
42 ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \
43 ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
44 ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
45}