summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorChase Maupin <Chase.Maupin@ti.com>2014-01-13 17:33:07 -0600
committerDenys Dmytriyenko <denys@ti.com>2014-01-14 15:29:55 -0500
commit327187973eb8bf69e8a7620d2aea2008e7839047 (patch)
tree3b80bf0aa859e0209e1c920e8feec928a9c27414 /recipes-bsp
parentc7df1eec2b9376e8b2eb09b34edcd81cdb4a4e72 (diff)
downloadmeta-ti-327187973eb8bf69e8a7620d2aea2008e7839047.tar.gz
Graphics SDK: Add 5.01.00.01 version
* Add the 5.01.00.01 version of the graphics SDK which supports suspend/resume operations for the v3.12 and later kernels. Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.00.01.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.00.01.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.00.01.bb
new file mode 100644
index 00000000..162e4d59
--- /dev/null
+++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.00.01.bb
@@ -0,0 +1,67 @@
1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://GPL-COPYING;md5=60422928ba677faaa13d6ab5f5baaa1e"
4
5TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
6require ../../recipes-ti/includes/ti-eula-unpack.inc
7
8SGXPV = "5_01_00_01"
9IMGPV = "1.10.2359475"
10
11inherit module
12
13MACHINE_KERNEL_PR_append = "a"
14PR = "${MACHINE_KERNEL_PR}"
15
16BINFILE_HARDFP = "Graphics_SDK_setuplinux_hardfp_${SGXPV}.bin"
17MD5SUM_HARDFP = "0ee7d59808330d442a51c0990c2cb30e"
18SHA256SUM_HARDFP = "769daae439677a7a85bbbced14cee4f85b19823e0b99560078d0a864c525c128"
19
20# For now we only have hardfp version
21python __anonymous() {
22 tunes = bb.data.getVar("TUNE_FEATURES", d, 1)
23 if not tunes:
24 return
25 pkgn = bb.data.getVar("PN", d, 1)
26 pkgv = bb.data.getVar("PV", d, 1)
27 if "callconvention-hard" not in tunes:
28 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
29 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
30}
31
32BINFILE := "${BINFILE_HARDFP}"
33
34SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/gfxsdk/${SGXPV}/exports/${BINFILE}"
35
36SRC_URI[md5sum] := "${MD5SUM_HARDFP}"
37SRC_URI[sha256sum] := "${SHA256SUM_HARDFP}"
38
39TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}"
40S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM"
41
42PVRBUILD = "release"
43export KERNELDIR = "${STAGING_KERNEL_DIR}"
44
45INHIBIT_PACKAGE_STRIP = "1"
46
47TI_PLATFORM_omap3 = "omap3630"
48TI_PLATFORM_ti814x = "ti81xx"
49TI_PLATFORM_ti816x = "ti81xx"
50TI_PLATFORM_ti33x = "ti335x"
51TI_PLATFORM_ti43x = "ti43xx"
52
53MODULESLOCATION_omap3 = "dc_omapfb3_linux"
54MODULESLOCATION_ti814x = "dc_ti81xx_linux"
55MODULESLOCATION_ti816x = "dc_ti81xx_linux"
56MODULESLOCATION_ti33x = "dc_ti335x_linux"
57MODULESLOCATION_ti43x = "dc_ti43xx_linux"
58
59MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}"
60
61do_install() {
62 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
63 cp ${S}/pvrsrvkm.ko \
64 ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \
65 ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
66 ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
67}