diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-11-01 12:40:44 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-11-01 12:40:44 +0100 |
commit | a55625975aac51e601961aa3007d837d1a86e541 (patch) | |
tree | a23b3348fb0b200e77a3fcff720d1ab1d72f09a2 /recipes-bsp | |
parent | 6d69cb81e6076473c0af0da5ea5160e2ecac170b (diff) | |
download | meta-ti-a55625975aac51e601961aa3007d837d1a86e541.tar.gz |
u-boot 2011.10rc: update SRCREV and rediff patches
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-bsp')
10 files changed, 58 insertions, 216 deletions
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0001-am335x_evm-only-do-in-kernel-dhcp-when-using-NFS-use.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0001-am335x_evm-only-do-in-kernel-dhcp-when-using-NFS-use.patch new file mode 100644 index 00000000..1ccfe195 --- /dev/null +++ b/recipes-bsp/u-boot/u-boot/2011.09git/0001-am335x_evm-only-do-in-kernel-dhcp-when-using-NFS-use.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | From 557a773eb245f3f2508e40d6d8a6c593738fd46f Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Tue, 1 Nov 2011 12:19:54 +0100 | ||
4 | Subject: [PATCH 1/4] am335x_evm: only do in-kernel dhcp when using NFS, userspace will do dhcp otherwise | ||
5 | |||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
7 | --- | ||
8 | include/configs/am335x_evm.h | 4 ++-- | ||
9 | 1 files changed, 2 insertions(+), 2 deletions(-) | ||
10 | |||
11 | diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h | ||
12 | index 41a3316..93b3161 100755 | ||
13 | --- a/include/configs/am335x_evm.h | ||
14 | +++ b/include/configs/am335x_evm.h | ||
15 | @@ -69,7 +69,7 @@ | ||
16 | "nfsopts=nolock\0" \ | ||
17 | "static_ip=${ipaddr}:${serverip}:${gatewayip}:${netmask}:${hostname}" \ | ||
18 | "::off\0" \ | ||
19 | - "ip_method=dhcp\0" \ | ||
20 | + "ip_method=none\0" \ | ||
21 | "bootenv=uEnv.txt\0" \ | ||
22 | "loadbootenv=fatload mmc ${mmc_dev} ${loadaddr} ${bootenv}\0" \ | ||
23 | "importbootenv=echo Importing environment from mmc ...; " \ | ||
24 | @@ -99,7 +99,7 @@ | ||
25 | "setenv bootargs ${bootargs} " \ | ||
26 | "root=/dev/nfs " \ | ||
27 | "nfsroot=${serverip}:${rootpath},${nfsopts} rw " \ | ||
28 | - "ip=${ip_method}\0" \ | ||
29 | + "ip=dhcp\0" \ | ||
30 | "mmc_boot=run mmc_args; " \ | ||
31 | "run mmc_load_uimage; " \ | ||
32 | "bootm ${loadaddr}\0" \ | ||
33 | -- | ||
34 | 1.7.2.5 | ||
35 | |||
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0001-mach-types-Add-new-beaglebone-machine-type.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0001-mach-types-Add-new-beaglebone-machine-type.patch deleted file mode 100644 index 6f12d6c1..00000000 --- a/recipes-bsp/u-boot/u-boot/2011.09git/0001-mach-types-Add-new-beaglebone-machine-type.patch +++ /dev/null | |||
@@ -1,47 +0,0 @@ | |||
1 | From ec41c3f94a9a498d1f7061abd98e41a66c0ab13e Mon Sep 17 00:00:00 2001 | ||
2 | From: Steve Kipisz <s-kipisz2@ti.com> | ||
3 | Date: Thu, 13 Oct 2011 14:42:35 -0500 | ||
4 | Subject: [PATCH 1/4] mach-types: Add new beaglebone machine type. | ||
5 | |||
6 | * New machine type is 3808 | ||
7 | |||
8 | Signed-off-by: Steve Kipisz <s-kipisz2@ti.com> | ||
9 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
10 | --- | ||
11 | arch/arm/include/asm/mach-types.h | 13 +++++++++++++ | ||
12 | 1 files changed, 13 insertions(+), 0 deletions(-) | ||
13 | |||
14 | diff --git a/arch/arm/include/asm/mach-types.h b/arch/arm/include/asm/mach-types.h | ||
15 | index c6ea523..68ac2ba 100644 | ||
16 | --- a/arch/arm/include/asm/mach-types.h | ||
17 | +++ b/arch/arm/include/asm/mach-types.h | ||
18 | @@ -3314,6 +3314,7 @@ extern unsigned int __machine_arch_type; | ||
19 | #define MACH_TYPE_GOFLEXHOME 3338 | ||
20 | #define MACH_TYPE_TIAM335EVM 3589 | ||
21 | #define MACH_TYPE_TIAM335IAEVM 3684 | ||
22 | +#define MACH_TYPE_BEAGLEBONE 3808 | ||
23 | |||
24 | #ifdef CONFIG_ARCH_EBSA110 | ||
25 | # ifdef machine_arch_type | ||
26 | @@ -42927,6 +42928,18 @@ extern unsigned int __machine_arch_type; | ||
27 | # define machine_is_tiam335evm() (0) | ||
28 | #endif | ||
29 | |||
30 | +#ifdef CONFIG_MACH_BEAGLEBONE | ||
31 | +# ifdef machine_arch_type | ||
32 | +# undef machine_arch_type | ||
33 | +# define machine_arch_type __machine_arch_type | ||
34 | +# else | ||
35 | +# define machine_arch_type MACH_TYPE_BEAGLEBONE | ||
36 | +# endif | ||
37 | +# define machine_is_beaglebone() (machine_arch_type == MACH_TYPE_BEAGLEBONE) | ||
38 | +#else | ||
39 | +# define machine_is_beaglebone() (0) | ||
40 | +#endif | ||
41 | + | ||
42 | /* | ||
43 | * These have not yet been registered | ||
44 | */ | ||
45 | -- | ||
46 | 1.6.6.1 | ||
47 | |||
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0001-am335x_evm-boot-kernel-from-ext2-3-filesystem.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0002-am335x_evm-boot-kernel-from-boot-in-ext2-3-filesyste.patch index 1ed68ea8..612ac981 100644 --- a/recipes-bsp/u-boot/u-boot/2011.09git/0001-am335x_evm-boot-kernel-from-ext2-3-filesystem.patch +++ b/recipes-bsp/u-boot/u-boot/2011.09git/0002-am335x_evm-boot-kernel-from-boot-in-ext2-3-filesyste.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 30c5198d37863d4f1598f7fe2b8f690b6cf6ae53 Mon Sep 17 00:00:00 2001 | 1 | From 206baf5d1d8eb19312c0c8216e6722a63548573d Mon Sep 17 00:00:00 2001 |
2 | From: Koen Kooi <koen@dominion.thruhere.net> | 2 | From: Koen Kooi <koen@dominion.thruhere.net> |
3 | Date: Thu, 13 Oct 2011 12:15:25 +0200 | 3 | Date: Tue, 1 Nov 2011 12:21:07 +0100 |
4 | Subject: [PATCH 1/2] am335x_evm: boot kernel from ext2/3 filesystem | 4 | Subject: [PATCH 2/4] am335x_evm: boot kernel from /boot in ext2/3 filesystem |
5 | 5 | ||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | 6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> |
7 | --- | 7 | --- |
@@ -9,7 +9,7 @@ Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | |||
9 | 1 files changed, 2 insertions(+), 1 deletions(-) | 9 | 1 files changed, 2 insertions(+), 1 deletions(-) |
10 | 10 | ||
11 | diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h | 11 | diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h |
12 | index f1cc2b2..9ce360d 100755 | 12 | index 93b3161..9bbfe3b 100755 |
13 | --- a/include/configs/am335x_evm.h | 13 | --- a/include/configs/am335x_evm.h |
14 | +++ b/include/configs/am335x_evm.h | 14 | +++ b/include/configs/am335x_evm.h |
15 | @@ -74,7 +74,8 @@ | 15 | @@ -74,7 +74,8 @@ |
@@ -19,9 +19,9 @@ index f1cc2b2..9ce360d 100755 | |||
19 | - "mmc_load_uimage=fatload mmc ${mmc_dev} ${loadaddr} ${bootfile}\0" \ | 19 | - "mmc_load_uimage=fatload mmc ${mmc_dev} ${loadaddr} ${bootfile}\0" \ |
20 | + "mmc_load_uimage_fat=fatload mmc ${mmc_dev} ${loadaddr} ${bootfile}\0" \ | 20 | + "mmc_load_uimage_fat=fatload mmc ${mmc_dev} ${loadaddr} ${bootfile}\0" \ |
21 | + "mmc_load_uimage=ext2load mmc 0:2 ${loadaddr} /boot/${bootfile}\0" \ | 21 | + "mmc_load_uimage=ext2load mmc 0:2 ${loadaddr} /boot/${bootfile}\0" \ |
22 | "optargs=\0" \ | ||
22 | "bootargs_defaults=setenv bootargs " \ | 23 | "bootargs_defaults=setenv bootargs " \ |
23 | "console=${console}\0" \ | 24 | "console=${console} " \ |
24 | "mmc_args=run bootargs_defaults;" \ | ||
25 | -- | 25 | -- |
26 | 1.6.6.1 | 26 | 1.7.2.5 |
27 | 27 | ||
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0002-evm-If-beaglebone-is-detected-pass-the-MACH_TYPE_BEA.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0002-evm-If-beaglebone-is-detected-pass-the-MACH_TYPE_BEA.patch deleted file mode 100644 index 7b8e52be..00000000 --- a/recipes-bsp/u-boot/u-boot/2011.09git/0002-evm-If-beaglebone-is-detected-pass-the-MACH_TYPE_BEA.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From 17c0530b1539fb8813efc11c60dd87fd9a3a074b Mon Sep 17 00:00:00 2001 | ||
2 | From: Steve Kipisz <s-kipisz2@ti.com> | ||
3 | Date: Thu, 13 Oct 2011 16:31:26 -0500 | ||
4 | Subject: [PATCH 2/4] evm: If beaglebone is detected, pass the MACH_TYPE_BEAGLEBONE to Linux | ||
5 | |||
6 | Signed-off-by: Steve Kipisz <s-kipisz2@ti.com> | ||
7 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
8 | --- | ||
9 | board/ti/am335x/evm.c | 4 +++- | ||
10 | 1 files changed, 3 insertions(+), 1 deletions(-) | ||
11 | |||
12 | diff --git a/board/ti/am335x/evm.c b/board/ti/am335x/evm.c | ||
13 | index 95e790b..af34bfd 100755 | ||
14 | --- a/board/ti/am335x/evm.c | ||
15 | +++ b/board/ti/am335x/evm.c | ||
16 | @@ -447,7 +447,9 @@ static void detect_daughter_board_profile(void) | ||
17 | int board_evm_init(void) | ||
18 | { | ||
19 | /* mach type passed to kernel */ | ||
20 | - if (board_id == IA_BOARD) | ||
21 | + if (board_id == BONE_BOARD) | ||
22 | + gd->bd->bi_arch_number = MACH_TYPE_BEAGLEBONE; | ||
23 | + else if (board_id == IA_BOARD) | ||
24 | gd->bd->bi_arch_number = MACH_TYPE_TIAM335IAEVM; | ||
25 | else | ||
26 | gd->bd->bi_arch_number = MACH_TYPE_TIAM335EVM; | ||
27 | -- | ||
28 | 1.6.6.1 | ||
29 | |||
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0002-am335x_evm-set-bootdelay-to-0.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0003-am335x_evm-set-bootdelay-to-1.patch index 99b7cadc..32655400 100644 --- a/recipes-bsp/u-boot/u-boot/2011.09git/0002-am335x_evm-set-bootdelay-to-0.patch +++ b/recipes-bsp/u-boot/u-boot/2011.09git/0003-am335x_evm-set-bootdelay-to-1.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 481457db4fe870fcbab47fe29cb768daf235fd1f Mon Sep 17 00:00:00 2001 | 1 | From bf513a05bc37f6d32e14c1e46d090773d1664c99 Mon Sep 17 00:00:00 2001 |
2 | From: Koen Kooi <koen@dominion.thruhere.net> | 2 | From: Koen Kooi <koen@dominion.thruhere.net> |
3 | Date: Thu, 13 Oct 2011 12:17:27 +0200 | 3 | Date: Tue, 1 Nov 2011 12:21:38 +0100 |
4 | Subject: [PATCH 2/2] am335x_evm: set bootdelay to 1 | 4 | Subject: [PATCH 3/4] am335x_evm: set bootdelay to 1 |
5 | 5 | ||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | 6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> |
7 | --- | 7 | --- |
@@ -9,7 +9,7 @@ Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | |||
9 | 1 files changed, 1 insertions(+), 1 deletions(-) | 9 | 1 files changed, 1 insertions(+), 1 deletions(-) |
10 | 10 | ||
11 | diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h | 11 | diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h |
12 | index 9ce360d..78c823b 100755 | 12 | index 9bbfe3b..6143dc3 100755 |
13 | --- a/include/configs/am335x_evm.h | 13 | --- a/include/configs/am335x_evm.h |
14 | +++ b/include/configs/am335x_evm.h | 14 | +++ b/include/configs/am335x_evm.h |
15 | @@ -38,7 +38,7 @@ | 15 | @@ -38,7 +38,7 @@ |
@@ -22,5 +22,5 @@ index 9ce360d..78c823b 100755 | |||
22 | #define CONFIG_MMC | 22 | #define CONFIG_MMC |
23 | #define CONFIG_NAND | 23 | #define CONFIG_NAND |
24 | -- | 24 | -- |
25 | 1.6.6.1 | 25 | 1.7.2.5 |
26 | 26 | ||
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0003-am335x_evm-single-byte-address-EEPROM-for-board-iden.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0003-am335x_evm-single-byte-address-EEPROM-for-board-iden.patch deleted file mode 100644 index d4ea6073..00000000 --- a/recipes-bsp/u-boot/u-boot/2011.09git/0003-am335x_evm-single-byte-address-EEPROM-for-board-iden.patch +++ /dev/null | |||
@@ -1,46 +0,0 @@ | |||
1 | From 52165b34c2fbcfe93f4cfabb616c2feb3ea7344f Mon Sep 17 00:00:00 2001 | ||
2 | From: Jason Kridner <jdk@ti.com> | ||
3 | Date: Thu, 13 Oct 2011 23:50:35 -0400 | ||
4 | Subject: [PATCH 3/4] am335x_evm: single-byte address EEPROM for board identifier | ||
5 | |||
6 | The BeagleBone has an EEPROM that uses a single byte address instead of a | ||
7 | 2-byte address used by the EVM versions. This simply adds a quick attempt | ||
8 | at reading the board identifier header with a 1-byte address if the header | ||
9 | signature isn't correct using a 2-byte address. | ||
10 | |||
11 | This is only build tested. Having a script to program the expected EEPROM | ||
12 | contents would help me reduce my time to test this. | ||
13 | |||
14 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
15 | --- | ||
16 | board/ti/am335x/evm.c | 14 ++++++++++++-- | ||
17 | 1 files changed, 12 insertions(+), 2 deletions(-) | ||
18 | |||
19 | diff --git a/board/ti/am335x/evm.c b/board/ti/am335x/evm.c | ||
20 | index af34bfd..f484a3c 100755 | ||
21 | --- a/board/ti/am335x/evm.c | ||
22 | +++ b/board/ti/am335x/evm.c | ||
23 | @@ -496,8 +496,18 @@ int board_init(void) | ||
24 | } | ||
25 | |||
26 | if (header.magic != 0xEE3355AA) { | ||
27 | - printf("Incorrect magic number in EEPROM\n"); | ||
28 | - goto err_out; | ||
29 | + /* read the eeprom using i2c again, but use only a 1 byte address */ | ||
30 | + if (i2c_read(I2C_BASE_BOARD_ADDR, 0, 1, (uchar *)&header, | ||
31 | + sizeof(header))) { | ||
32 | + printf("Could not read the EEPROM; something fundamentally" | ||
33 | + " wrong on the I2C bus.\n"); | ||
34 | + goto err_out; | ||
35 | + } | ||
36 | + | ||
37 | + if (header.magic != 0xEE3355AA) { | ||
38 | + printf("Incorrect magic number in EEPROM\n"); | ||
39 | + goto err_out; | ||
40 | + } | ||
41 | } | ||
42 | |||
43 | detect_daughter_board(); | ||
44 | -- | ||
45 | 1.6.6.1 | ||
46 | |||
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0004-am335x-evm-fall-back-to-bone-if-header.config-is-emp.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0004-am335x-evm-fall-back-to-bone-if-header.config-is-emp.patch deleted file mode 100644 index db3ae69c..00000000 --- a/recipes-bsp/u-boot/u-boot/2011.09git/0004-am335x-evm-fall-back-to-bone-if-header.config-is-emp.patch +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | From 3e3ac90cdd7fade62e898453f529364e4d9c7589 Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Tue, 18 Oct 2011 19:18:56 +0200 | ||
4 | Subject: [PATCH 4/4] am335x-evm: fall back to bone if header.config is empty | ||
5 | |||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
7 | --- | ||
8 | board/ti/am335x/evm.c | 8 ++++---- | ||
9 | 1 files changed, 4 insertions(+), 4 deletions(-) | ||
10 | |||
11 | diff --git a/board/ti/am335x/evm.c b/board/ti/am335x/evm.c | ||
12 | index f484a3c..1c3ba2c 100755 | ||
13 | --- a/board/ti/am335x/evm.c | ||
14 | +++ b/board/ti/am335x/evm.c | ||
15 | @@ -495,6 +495,7 @@ int board_init(void) | ||
16 | goto err_out; | ||
17 | } | ||
18 | |||
19 | + printf("EEPROM ID:\n magic: %#08x\n name: %8s\n version: %4s\n serial: %12s\n config: %32s\n mac_addr: %s\n", header.magic, header.name, header.version, header.serial, header.config, header.mac_addr); | ||
20 | if (header.magic != 0xEE3355AA) { | ||
21 | /* read the eeprom using i2c again, but use only a 1 byte address */ | ||
22 | if (i2c_read(I2C_BASE_BOARD_ADDR, 0, 1, (uchar *)&header, | ||
23 | @@ -522,11 +523,10 @@ int board_init(void) | ||
24 | board_id = IPP_BOARD; | ||
25 | } else { | ||
26 | printf("Did not find a recognized configuration, " | ||
27 | - "assuming General purpose EVM in Profile 0 with " | ||
28 | - "Daughter board\n"); | ||
29 | - board_id = GP_BOARD; | ||
30 | + "assuming BeagleBone\n"); | ||
31 | + board_id = BONE_BOARD; | ||
32 | profile = 1; /* profile 0 is internally considered as 1 */ | ||
33 | - daughter_board_connected = 1; | ||
34 | + daughter_board_connected = 0; | ||
35 | } | ||
36 | |||
37 | configure_evm_pin_mux(board_id, profile, daughter_board_connected); | ||
38 | -- | ||
39 | 1.6.6.1 | ||
40 | |||
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0003-am335x-evm-make-rootfs-RO-on-boot.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0004-am335x-evm-make-MMC-rootfs-RO-on-boot-so-fsck-works.patch index 4dc053e0..72195547 100644 --- a/recipes-bsp/u-boot/u-boot/2011.09git/0003-am335x-evm-make-rootfs-RO-on-boot.patch +++ b/recipes-bsp/u-boot/u-boot/2011.09git/0004-am335x-evm-make-MMC-rootfs-RO-on-boot-so-fsck-works.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 9f8585887a08e6a9c7ca24c2a9c0e9a8c66a2a54 Mon Sep 17 00:00:00 2001 | 1 | From 63e5b3b4271917e0a3c5a4903a76fdfb30118d3c Mon Sep 17 00:00:00 2001 |
2 | From: Koen Kooi <koen@dominion.thruhere.net> | 2 | From: Koen Kooi <koen@dominion.thruhere.net> |
3 | Date: Sun, 16 Oct 2011 09:57:06 +0200 | 3 | Date: Tue, 1 Nov 2011 12:22:30 +0100 |
4 | Subject: [PATCH 3/3] am335x-evm: make rootfs RO on boot | 4 | Subject: [PATCH 4/4] am335x-evm: make MMC rootfs RO on boot so fsck works |
5 | 5 | ||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | 6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> |
7 | --- | 7 | --- |
@@ -9,7 +9,7 @@ Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | |||
9 | 1 files changed, 1 insertions(+), 1 deletions(-) | 9 | 1 files changed, 1 insertions(+), 1 deletions(-) |
10 | 10 | ||
11 | diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h | 11 | diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h |
12 | index cb45037..5db3d9f 100755 | 12 | index 6143dc3..56e36da 100755 |
13 | --- a/include/configs/am335x_evm.h | 13 | --- a/include/configs/am335x_evm.h |
14 | +++ b/include/configs/am335x_evm.h | 14 | +++ b/include/configs/am335x_evm.h |
15 | @@ -50,7 +50,7 @@ | 15 | @@ -50,7 +50,7 @@ |
@@ -22,5 +22,5 @@ index cb45037..5db3d9f 100755 | |||
22 | "spi_root=/dev/mtdblock4 rw\0" \ | 22 | "spi_root=/dev/mtdblock4 rw\0" \ |
23 | "nor_root=/dev/mtdblock3 rw\0" \ | 23 | "nor_root=/dev/mtdblock3 rw\0" \ |
24 | -- | 24 | -- |
25 | 1.6.6.1 | 25 | 1.7.2.5 |
26 | 26 | ||
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0005-am335x-evm-Read-name-field-in-EEPROM-header-for-Beag.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0005-am335x-evm-Read-name-field-in-EEPROM-header-for-Beag.patch deleted file mode 100644 index ef901a91..00000000 --- a/recipes-bsp/u-boot/u-boot/2011.09git/0005-am335x-evm-Read-name-field-in-EEPROM-header-for-Beag.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | From 186250ee6abca3f080b5321504a1c5881ffbf7c6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Joel A Fernandes <joelagnel@ti.com> | ||
3 | Date: Thu, 20 Oct 2011 19:46:53 -0500 | ||
4 | Subject: [PATCH] am335x-evm: Read name field in EEPROM header for BeagleBoard bone detection | ||
5 | |||
6 | Signed-off-by: Joel A Fernandes <joelagnel@ti.com> | ||
7 | --- | ||
8 | board/ti/am335x/evm.c | 4 ++++ | ||
9 | 1 files changed, 4 insertions(+), 0 deletions(-) | ||
10 | |||
11 | diff --git a/board/ti/am335x/evm.c b/board/ti/am335x/evm.c | ||
12 | index 37e348f..b63dcbe 100755 | ||
13 | --- a/board/ti/am335x/evm.c | ||
14 | +++ b/board/ti/am335x/evm.c | ||
15 | @@ -501,6 +501,10 @@ int board_init(void) | ||
16 | detect_daughter_board_profile(); | ||
17 | } else if (!strncmp("SKU#03", header.config, 6)) { | ||
18 | board_id = IPP_BOARD; | ||
19 | + } else if (!strncmp("A335BONE", header.name, 8)) { | ||
20 | + board_id = BONE_BOARD; | ||
21 | + profile = 1; /* profile 0 is internally considered as 1 */ | ||
22 | + daughter_board_connected = 0; | ||
23 | } else { | ||
24 | printf("Did not find a recognized configuration, " | ||
25 | "assuming BeagleBone\n"); | ||
26 | -- | ||
27 | 1.7.1 | ||
28 | |||
diff --git a/recipes-bsp/u-boot/u-boot_2011.10rc.bb b/recipes-bsp/u-boot/u-boot_2011.10rc.bb index ca7b670a..e4552b86 100644 --- a/recipes-bsp/u-boot/u-boot_2011.10rc.bb +++ b/recipes-bsp/u-boot/u-boot_2011.10rc.bb | |||
@@ -4,7 +4,7 @@ require u-boot.inc | |||
4 | COMPATIBLE_MACHINE = "(ti33x)" | 4 | COMPATIBLE_MACHINE = "(ti33x)" |
5 | DEFAULT_PREFERENCE_ti33x = "99" | 5 | DEFAULT_PREFERENCE_ti33x = "99" |
6 | PV = "2011.09+git" | 6 | PV = "2011.09+git" |
7 | PR = "r15" | 7 | PR = "r16" |
8 | 8 | ||
9 | # SPL build | 9 | # SPL build |
10 | UBOOT_BINARY = "u-boot.img" | 10 | UBOOT_BINARY = "u-boot.img" |
@@ -12,16 +12,13 @@ UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img" | |||
12 | UBOOT_SYMLINK = "u-boot-${MACHINE}.img" | 12 | UBOOT_SYMLINK = "u-boot-${MACHINE}.img" |
13 | 13 | ||
14 | SRC_URI = "git://arago-project.org/git/projects/u-boot-am33x.git;protocol=git;branch=int_am335xpsp_04.06.00.01-v2011.09-for-sdk-05.03.00.00 \ | 14 | SRC_URI = "git://arago-project.org/git/projects/u-boot-am33x.git;protocol=git;branch=int_am335xpsp_04.06.00.01-v2011.09-for-sdk-05.03.00.00 \ |
15 | file://2011.09git/0001-am335x_evm-boot-kernel-from-ext2-3-filesystem.patch \ | 15 | file://2011.09git/0001-am335x_evm-only-do-in-kernel-dhcp-when-using-NFS-use.patch \ |
16 | file://2011.09git/0002-am335x_evm-set-bootdelay-to-0.patch \ | 16 | file://2011.09git/0002-am335x_evm-boot-kernel-from-boot-in-ext2-3-filesyste.patch \ |
17 | file://2011.09git/0003-am335x-evm-make-rootfs-RO-on-boot.patch \ | 17 | file://2011.09git/0003-am335x_evm-set-bootdelay-to-1.patch \ |
18 | file://2011.09git/0001-mach-types-Add-new-beaglebone-machine-type.patch \ | 18 | file://2011.09git/0004-am335x-evm-make-MMC-rootfs-RO-on-boot-so-fsck-works.patch \ |
19 | file://2011.09git/0003-am335x_evm-single-byte-address-EEPROM-for-board-iden.patch \ | ||
20 | file://2011.09git/0004-am335x-evm-fall-back-to-bone-if-header.config-is-emp.patch \ | ||
21 | file://2011.09git/0005-am335x-evm-Read-name-field-in-EEPROM-header-for-Beag.patch \ | ||
22 | " | 19 | " |
23 | 20 | ||
24 | SRCREV = "9158d7f37d596b867039345cb2e3f8f18f54fe46" | 21 | SRCREV = "f63b270e47f62f4d1a05b2001357e215966c6f5a" |
25 | 22 | ||
26 | LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb" | 23 | LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb" |
27 | 24 | ||