summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-02-22 04:13:01 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-22 12:01:30 -0600
commitfa91f87cb00d5d2f8a4525585d86e079b722862f (patch)
treecda6fd4863a1461656035be91a0ac1fff7d576e1 /recipes-bsp
parentccfad70de8e4ac62063806957574a891dbe6e175 (diff)
downloadmeta-ti-fa91f87cb00d5d2f8a4525585d86e079b722862f.tar.gz
ti-ocf-crypto-module: remove OMAP3-specific OCF ctypto module
OMAP3 platforms used OCF-Linux, a Linux port of the OpenBSD/FreeBSD Cryptographic Framework (OCF) for Crypto HW acceleration. Later, an alternative Cryptodev-linux API standard became dominant for newer platforms. Remove deprecated module. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb35
1 files changed, 0 insertions, 35 deletions
diff --git a/recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb b/recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb
deleted file mode 100644
index 946f2ceb..00000000
--- a/recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb
+++ /dev/null
@@ -1,35 +0,0 @@
1DESCRIPTION = "Builds Crypto module used by OCF-Linux driver in OpenSSL example applications"
2HOMEPAGE = "https://gforge.ti.com/gf/project/arm_crypto/"
3LICENSE = "BSD & GPLv2"
4LIC_FILES_CHKSUM = "file://Makefile;beginline=1;endline=16;md5=acc0590f80e72fd64ad5c16cad8f4f76 \
5 file://ocf_omap3_crypto.c;beginline=436;endline=438;md5=a52cad5c37c3aa3f27c6391552967304"
6
7COMPATIBLE_MACHINE = "am37x-evm|am3517-evm"
8
9DEPENDS += "virtual/kernel"
10
11SRC_URI = "svn://gforge.ti.com/svn/arm_crypto/;module=trunk;protocol=https;user=anonymous;pswd=''"
12
13#gforge source revision
14SRCREV = "17"
15
16INHIBIT_PACKAGE_STRIP = "1"
17
18S = "${WORKDIR}/trunk"
19
20inherit module
21
22MACHINE_KERNEL_PR:append = "b"
23PR = "${MACHINE_KERNEL_PR}"
24PV:append = "+svn${SRCPV}"
25
26EXTRA_OEMAKE += "KERNEL_DIR=${STAGING_KERNEL_DIR}"
27
28do_compile:prepend () {
29 sed -i "s/arm-none-linux-gnueabi-/${TARGET_PREFIX}/g" ${S}/Makefile
30}
31
32do_install () {
33 install -d ${D}/lib/modules/${KERNEL_VERSION}/crypto/ocf/
34 install -m 0755 ${S}/ocf_omap3_cryptok.ko ${D}/lib/modules/${KERNEL_VERSION}/crypto/ocf/
35}