summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorChirag Shilwant <c-shilwant@ti.com>2023-01-30 14:22:41 +0530
committerRyan Eatmon <reatmon@ti.com>2023-01-30 10:33:34 -0600
commitca662c2221e890ab856fe2ce5b232985c71af412 (patch)
tree954df857eb378390d19e4df51a3053024b15bec9 /recipes-bsp
parent0988872f39527d28441e91605211b2242646584a (diff)
downloadmeta-ti-ca662c2221e890ab856fe2ce5b232985c71af412.tar.gz
machine: Add AM62x HS-SE evm configuration
Lets add the basic AM62x HS-SE configuration. - Add machine conf for AM62x HS-SE. - The wic images will boot on AM62x GP devices by default. To boot on AM62x HS-SE, simply switch out the SYSFW image: $ cd /mnt/sd-card/boot $ mv tiboot3-am62x-hs-evm.bin tiboot3.bin - Add ti-sci-firmware overrides. - Add support to sign ATF and OPTEE. Signed-off-by: Chirag Shilwant <c-shilwant@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb3
-rw-r--r--recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend4
2 files changed, 6 insertions, 1 deletions
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 0fb3a832..7896c366 100644
--- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -37,7 +37,8 @@ SYSFW_PREFIX_j721s2-evm-k3r5 = "fs"
37SYSFW_PREFIX_j721s2-hs-evm-k3r5 = "fs" 37SYSFW_PREFIX_j721s2-hs-evm-k3r5 = "fs"
38SYSFW_PREFIX_j784s4-evm-k3r5 = "fs" 38SYSFW_PREFIX_j784s4-evm-k3r5 = "fs"
39SYSFW_PREFIX_j784s4-hs-evm-k3r5 = "fs" 39SYSFW_PREFIX_j784s4-hs-evm-k3r5 = "fs"
40SYSFW_PREFIX_am62xx-evm-k3r5 = "fs" 40SYSFW_PREFIX_am62xx-evm-k3r5-gp = "fs"
41SYSFW_PREFIX_am62xx-evm-k3r5-hs-se = "fs"
41SYSFW_PREFIX_am62xx-lp-evm-k3r5 = "fs" 42SYSFW_PREFIX_am62xx-lp-evm-k3r5 = "fs"
42SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-se = "fs" 43SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-se = "fs"
43SYSFW_PREFIX_am62axx-evm-k3r5 = "fs" 44SYSFW_PREFIX_am62axx-evm-k3r5 = "fs"
diff --git a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index caf27328..41071676 100644
--- a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -31,6 +31,10 @@ do_compile_append_am64xx-evm() {
31 tfa_sign_k3hs 31 tfa_sign_k3hs
32} 32}
33 33
34do_compile_append_am62xx-evm() {
35 tfa_sign_k3hs
36}
37
34do_compile_append_am62xx-lp-evm() { 38do_compile_append_am62xx-lp-evm() {
35 tfa_sign_k3hs 39 tfa_sign_k3hs
36} 40}