diff options
author | Franklin S. Cooper Jr <fcooper@ti.com> | 2013-02-11 19:04:39 -0600 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2013-02-12 18:14:57 -0500 |
commit | 98ad55b8eaba67d777382592df2fe9322ebe37b9 (patch) | |
tree | fc54ea3e7b07d4cbbf1678f5b8d3f2393bc79662 /recipes-bsp | |
parent | a98c0c3d2ac6ec218648b9c3d57fea7f3d6cdc00 (diff) | |
download | meta-ti-98ad55b8eaba67d777382592df2fe9322ebe37b9.tar.gz |
ti-pru-sw-edma-driver: Port PRU SW edma driver from Arago
* Add PRU SW edma driver recipe for the omapl138 machines
* This recipe builds and installs an edma driver module that supports the
edma user space libraries built by the ti-pru-sw-edma-library recipe.
Signed-off-by: Franklin S. Cooper Jr <fcooper@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb | 32 |
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb b/recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb new file mode 100644 index 00000000..c7fdfd1e --- /dev/null +++ b/recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | DESCRIPTION = "Builds eDMA module used by eDMA libraries for PRU sw example applications" | ||
2 | HOMEPAGE = "https://gforge.ti.com/gf/project/pru_sw/" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://edmautils.c;beginline=1;endline=23;md5=312e9cb8a37a044c617c98a9e980ad1b" | ||
5 | |||
6 | COMPATIBLE_MACHINE = "omapl138" | ||
7 | |||
8 | INHIBIT_PACKAGE_STRIP = "1" | ||
9 | |||
10 | MACHINE_KERNEL_PR_append = "a+svnr${SRCPV}" | ||
11 | PR = "${MACHINE_KERNEL_PR}" | ||
12 | |||
13 | SRC_URI = "svn://gforge.ti.com/svn/pru_sw/;module=trunk;protocol=https;user=anonymous;pswd=''" | ||
14 | |||
15 | SRCREV = "33" | ||
16 | |||
17 | S = "${WORKDIR}/trunk/peripheral_lib/edma_driver/module" | ||
18 | |||
19 | inherit module | ||
20 | |||
21 | EXTRA_OEMAKE += "KERNEL_DIR='${STAGING_KERNEL_DIR}'" | ||
22 | |||
23 | do_compile_prepend () { | ||
24 | export CCTOOL_PREFIX="${TOOLCHAIN_PATH}/bin/${TARGET_PREFIX}" | ||
25 | } | ||
26 | |||
27 | do_install () { | ||
28 | install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/pru | ||
29 | install -m 0755 ${S}/edmautils.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/pru/ | ||
30 | } | ||
31 | |||
32 | FILES_${PN} = "/lib/modules/${KERNEL_VERSION}/kernel/drivers/pru/edmautils.ko" | ||