summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorYogesh Siraswar <yogeshs@ti.com>2021-12-09 12:07:13 -0600
committerPraneeth Bajjuri <praneeth@ti.com>2021-12-09 13:34:36 -0600
commitd29025f7e868bea6299b55caf78e684fc647be33 (patch)
tree43ef5fbd55368e8054d54895466a776214f1fb02 /recipes-bsp
parent6eaf4592469644dfde32483965e4c4ccd1da9ea8 (diff)
downloadmeta-ti-d29025f7e868bea6299b55caf78e684fc647be33.tar.gz
ti-sci-fw: Fix for k3-image-gen issue for combined boot images
This is temporary fix for combined boot images for KIG in meta-ti till the patch is integrated. Signed-off-by: Yogesh Siraswar <yogeshs@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/ti-sci-fw/files/0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch64
-rw-r--r--recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb5
2 files changed, 69 insertions, 0 deletions
diff --git a/recipes-bsp/ti-sci-fw/files/0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch b/recipes-bsp/ti-sci-fw/files/0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch
new file mode 100644
index 00000000..196f3d3f
--- /dev/null
+++ b/recipes-bsp/ti-sci-fw/files/0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch
@@ -0,0 +1,64 @@
1From 2efc79702a47f9cbbeecbb2f604577f1ec8c95ba Mon Sep 17 00:00:00 2001
2From: Yogesh Siraswar <yogeshs@ti.com>
3Date: Wed, 8 Dec 2021 17:50:19 -0600
4Subject: [KIG PATCH] Makefile: Skip signing of binaries for combined boot hs
5 images
6
7Combined sysfw binaries used in tiboot.bin do not require signed images.
8This fixes issues with AM64x HS and J7200 HS boot images
9
10Upstream-Status: Submitted
11Signed-off-by: Yogesh Siraswar <yogeshs@ti.com>
12---
13 Makefile | 8 +++++++-
14 soc/am64x/Makefile | 1 +
15 soc/j7200/Makefile | 1 +
16 3 files changed, 9 insertions(+), 1 deletion(-)
17
18diff --git a/Makefile b/Makefile
19index 47b3b20..ab465df 100644
20--- a/Makefile
21+++ b/Makefile
22@@ -215,8 +215,14 @@ $(soc_objroot)/%.o: %.c
23 $(CROSS_COMPILE)gcc $(CFLAGS) -c -o $@-pre-validated $<
24 python3 ./scripts/sysfw_boardcfg_validator.py -b $@-pre-validated -i -o $@ -s $(SOC) -l $@.log
25
26-# On HS board configuration binaries must be signed
27+# On HS board configuration binaries must be signed unless it is combined boot image
28 ifdef HS
29+ifndef COMBINED_BOOT_IMAGE
30+SIGN_BINARY=1
31+endif
32+endif
33+
34+ifdef SIGN_BINARY
35 %.bin.unsigned: %.o
36 $(CROSS_COMPILE)objcopy -S -O binary $< $@
37 %.bin: %.bin.unsigned
38diff --git a/soc/am64x/Makefile b/soc/am64x/Makefile
39index bfbe3e5..33ebbd0 100644
40--- a/soc/am64x/Makefile
41+++ b/soc/am64x/Makefile
42@@ -31,6 +31,7 @@
43 #
44
45 SBL_LOADADDDR ?= 0x70000000
46+COMBINED_BOOT_IMAGE = 1
47 COMBINED_SYSFW_BRDCFG_LOADADDR ?= 0x7b000
48 LOADADDR ?= 0x44000
49 SCIFS = sci
50diff --git a/soc/j7200/Makefile b/soc/j7200/Makefile
51index 3b754f7..0baef51 100644
52--- a/soc/j7200/Makefile
53+++ b/soc/j7200/Makefile
54@@ -31,6 +31,7 @@
55 #
56
57 SBL_LOADADDDR ?= 0x41c00000
58+COMBINED_BOOT_IMAGE = 1
59 COMBINED_TIFS_BRDCFG_LOADADDR ?= 0x7f000
60 COMBINED_DM_BRDCFG_LOADADDR ?= 0x41c80000
61 LOADADDR ?= 0x40000
62--
632.17.1
64
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 6d48bf23..13ae1f6b 100644
--- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -47,6 +47,11 @@ LD[unexport] = "1"
47 47
48do_configure[noexec] = "1" 48do_configure[noexec] = "1"
49 49
50SRC_URI_append_j7200-hs-evm-k3r5 = "\
51 file://0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch;patchdir=../imggen"
52SRC_URI_append_am64xx-hs-evm-k3r5 = "\
53 file://0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch;patchdir=../imggen"
54
50EXTRA_OEMAKE = "\ 55EXTRA_OEMAKE = "\
51 CROSS_COMPILE=${TARGET_PREFIX} SYSFW_DL_URL='' SYSFW_HS_DL_URL='' SYSFW_HS_INNER_CERT_DL_URL='' \ 56 CROSS_COMPILE=${TARGET_PREFIX} SYSFW_DL_URL='' SYSFW_HS_DL_URL='' SYSFW_HS_INNER_CERT_DL_URL='' \
52 SYSFW_PATH="${SYSFW_TISCI}" SOC=${SYSFW_SOC} CONFIG=${SYSFW_CONFIG} \ 57 SYSFW_PATH="${SYSFW_TISCI}" SOC=${SYSFW_SOC} CONFIG=${SYSFW_CONFIG} \