summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorPraneeth Bajjuri <praneeth@ti.com>2021-11-18 16:40:26 -0600
committerYogesh Siraswar <yogeshs@ti.com>2021-11-18 23:59:51 +0000
commit9e1ba1f2e4b8994cdf0004689b3d1d0c7fb99d2e (patch)
tree0313a1b6fa3635b80e03cdd4e4fa38f27e3c5130 /recipes-bsp
parent194d0bdc71247f59f0d4713f0f43a216803a75f1 (diff)
downloadmeta-ti-9e1ba1f2e4b8994cdf0004689b3d1d0c7fb99d2e.tar.gz
vxd-dec-fw: Add the recipe for vxd-dec-fw
Add the firmware packaging recipe for the video decoder for j721e. Signed-off-by: Praneeth Bajjuri <praneeth@ti.com> Signed-off-by: Yogesh Siraswar <yogeshs@ti.com> Reviewed-by: Denys Dmytriyenko <denys@konsulko.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb24
-rw-r--r--recipes-bsp/ti-linux-fw/ti-linux-fw.inc5
2 files changed, 27 insertions, 2 deletions
diff --git a/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb b/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
new file mode 100644
index 00000000..cccda6bb
--- /dev/null
+++ b/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Video Decoding Firmware"
2LICENSE = "TI-IMG"
3LIC_FILES_CHKSUM = "file://LICENSE.ti-img;md5=84ca7278930db001870686ad997d6bb1"
4
5require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
6
7PV = "${IMG_DEC_FW_VERSION}"
8PR = "${INC_PR}.0"
9
10CLEANBROKEN = "1"
11
12COMPATIBLE_MACHINE = "j7"
13
14PACKAGE_ARCH = "${MACHINE_ARCH}"
15
16S = "${WORKDIR}/git"
17TARGET = "pvdec_full_bin.fw"
18
19do_install() {
20 install -d ${D}${base_libdir}/firmware/ti-img
21 install -m 0644 ${S}/ti-img/${TARGET} ${D}${base_libdir}/firmware/ti-img/${TARGET}
22}
23
24FILES_${PN} = "${base_libdir}/firmware"
diff --git a/recipes-bsp/ti-linux-fw/ti-linux-fw.inc b/recipes-bsp/ti-linux-fw/ti-linux-fw.inc
index c59120b8..f6d5b8d1 100644
--- a/recipes-bsp/ti-linux-fw/ti-linux-fw.inc
+++ b/recipes-bsp/ti-linux-fw/ti-linux-fw.inc
@@ -13,11 +13,12 @@ NETCP_SA_FW_VERSION = "1.0.0"
13NETCP_PA_FW_VERSION = "3.0.2.3" 13NETCP_PA_FW_VERSION = "3.0.2.3"
14QMSS_PDSP_FW_VERSION = "1.0.0.9" 14QMSS_PDSP_FW_VERSION = "1.0.0.9"
15PRUETH_FW_AM65X_VERSION = "08.00.00.20" 15PRUETH_FW_AM65X_VERSION = "08.00.00.20"
16PRUETH_FW_AM65X_SR2_VERSION = "02.02.09.06" 16PRUETH_FW_AM65X_SR2_VERSION = "02.02.09.07"
17GOODIX_FW_VERSION = "1.0.0.0" 17GOODIX_FW_VERSION = "1.0.0.0"
18CADENCE_MHDP_FW_VERSION = "1.2.17" 18CADENCE_MHDP_FW_VERSION = "1.2.17"
19IMG_DEC_FW_VERSION = "1.0"
19 20
20TI_LINUX_FW_SRCREV ?= "95232a584175a8ac872adf477b2dbb9ca68ba063" 21TI_LINUX_FW_SRCREV ?= "c96a734a059889e571dcf30c0638157c690a6e6e"
21SRCREV = "${TI_LINUX_FW_SRCREV}" 22SRCREV = "${TI_LINUX_FW_SRCREV}"
22 23
23BRANCH ?= "ti-linux-firmware" 24BRANCH ?= "ti-linux-firmware"