diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2015-11-04 01:47:23 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-11-04 09:59:36 -0500 |
commit | bb3b5d10f0c16d807dc6e8451955c33e50f59bb4 (patch) | |
tree | 41eb1fb81a099f70affa261dc34bd4d5f8d6fdaa /recipes-bsp | |
parent | 51c651cf8c7d8ec33ab6b50feee41680fbb87281 (diff) | |
download | meta-ti-bb3b5d10f0c16d807dc6e8451955c33e50f59bb4.tar.gz |
pa-lld: Only build binaries relevent to the machine
* Due to this change, the init script is no longer needed
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rwxr-xr-x | recipes-bsp/pa-lld/files/init_pa.sh | 47 | ||||
-rw-r--r-- | recipes-bsp/pa-lld/pa-lld-test_git.bb | 4 | ||||
-rw-r--r-- | recipes-bsp/pa-lld/pa-lld.inc | 9 | ||||
-rw-r--r-- | recipes-bsp/pa-lld/pa-lld_git.bb | 21 |
4 files changed, 17 insertions, 64 deletions
diff --git a/recipes-bsp/pa-lld/files/init_pa.sh b/recipes-bsp/pa-lld/files/init_pa.sh deleted file mode 100755 index 8f80e355..00000000 --- a/recipes-bsp/pa-lld/files/init_pa.sh +++ /dev/null | |||
@@ -1,47 +0,0 @@ | |||
1 | #* | ||
2 | #* Copyright (C) 2015 Texas Instruments Incorporated - http://www.ti.com/ | ||
3 | #* | ||
4 | #* | ||
5 | #* Redistribution and use in source and binary forms, with or without | ||
6 | #* modification, are permitted provided that the following conditions | ||
7 | #* are met: | ||
8 | #* | ||
9 | #* Redistributions of source code must retain the above copyright | ||
10 | #* notice, this list of conditions and the following disclaimer. | ||
11 | #* | ||
12 | #* Redistributions in binary form must reproduce the above copyright | ||
13 | #* notice, this list of conditions and the following disclaimer in the | ||
14 | #* documentation and/or other materials provided with the | ||
15 | #* distribution. | ||
16 | #* | ||
17 | #* Neither the name of Texas Instruments Incorporated nor the names of | ||
18 | #* its contributors may be used to endorse or promote products derived | ||
19 | #* from this software without specific prior written permission. | ||
20 | #* | ||
21 | |||
22 | #! /bin/sh | ||
23 | compatible=$(cat /proc/device-tree/compatible) | ||
24 | |||
25 | cd /usr/lib | ||
26 | case "$compatible" in | ||
27 | *k2hk*) | ||
28 | device=k2hk | ||
29 | ln -sf libpa.so.1.0.0 libpa_device.so.1 | ||
30 | ;; | ||
31 | *k2l*) | ||
32 | device=k2l | ||
33 | ln -sf libpa2.so.1.0.0 libpa_device.so.1 | ||
34 | ;; | ||
35 | *k2e*) | ||
36 | device=k2e | ||
37 | ln -sf libpa2.so.1.0.0 libpa_device.so.1 | ||
38 | ;; | ||
39 | *) | ||
40 | device=unknown | ||
41 | ;; | ||
42 | esac | ||
43 | |||
44 | if [ $device != unknown ]; then | ||
45 | ln -sf libpa_device.so.1 libpa_device.so | ||
46 | echo PA library link established for device : $device | ||
47 | fi | ||
diff --git a/recipes-bsp/pa-lld/pa-lld-test_git.bb b/recipes-bsp/pa-lld/pa-lld-test_git.bb index 0fb6f079..62ec1222 100644 --- a/recipes-bsp/pa-lld/pa-lld-test_git.bb +++ b/recipes-bsp/pa-lld/pa-lld-test_git.bb | |||
@@ -4,9 +4,7 @@ DEPENDS = "common-csl-ip pa-lld cppi-lld qmss-lld sa-lld" | |||
4 | 4 | ||
5 | include pa-lld.inc | 5 | include pa-lld.inc |
6 | 6 | ||
7 | PR = "${INC_PR}.0" | 7 | PR = "${INC_PR}.1" |
8 | |||
9 | DEVICELIST = "k2h k2k k2l k2e" | ||
10 | 8 | ||
11 | CHOICELIST = "yes no" | 9 | CHOICELIST = "yes no" |
12 | 10 | ||
diff --git a/recipes-bsp/pa-lld/pa-lld.inc b/recipes-bsp/pa-lld/pa-lld.inc index 58f0f424..082d59d0 100644 --- a/recipes-bsp/pa-lld/pa-lld.inc +++ b/recipes-bsp/pa-lld/pa-lld.inc | |||
@@ -2,6 +2,7 @@ LICENSE = "BSD-3-Clause" | |||
2 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/pa/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d" | 2 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/pa/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d" |
3 | 3 | ||
4 | COMPATIBLE_MACHINE = "keystone" | 4 | COMPATIBLE_MACHINE = "keystone" |
5 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
5 | 6 | ||
6 | PA_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/pa-lld.git" | 7 | PA_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/pa-lld.git" |
7 | PA_LLD_GIT_PROTOCOL = "git" | 8 | PA_LLD_GIT_PROTOCOL = "git" |
@@ -19,3 +20,11 @@ PV = "03.00.01.05" | |||
19 | INC_PR = "r2" | 20 | INC_PR = "r2" |
20 | 21 | ||
21 | S = "${WORKDIR}/${PA_LLD_GIT_DESTSUFFIX}" | 22 | S = "${WORKDIR}/${PA_LLD_GIT_DESTSUFFIX}" |
23 | |||
24 | DEVICELIST_k2hk-evm = "k2h k2k" | ||
25 | DEVICELIST_k2l-evm = "k2l" | ||
26 | DEVICELIST_k2e-evm = "k2e" | ||
27 | |||
28 | LIBPA_k2hk-evm = "libpa" | ||
29 | LIBPA_k2e-evm = "libpa2" | ||
30 | LIBPA_k2l-evm = "libpa2" | ||
diff --git a/recipes-bsp/pa-lld/pa-lld_git.bb b/recipes-bsp/pa-lld/pa-lld_git.bb index 0cb3bc50..501ee2d9 100644 --- a/recipes-bsp/pa-lld/pa-lld_git.bb +++ b/recipes-bsp/pa-lld/pa-lld_git.bb | |||
@@ -4,27 +4,20 @@ DEPENDS = "common-csl-ip rm-lld" | |||
4 | 4 | ||
5 | include pa-lld.inc | 5 | include pa-lld.inc |
6 | 6 | ||
7 | PR = "${INC_PR}.0" | 7 | PR = "${INC_PR}.1" |
8 | |||
9 | SRC_URI += "file://init_pa.sh" | ||
10 | |||
11 | inherit update-rc.d | ||
12 | |||
13 | INITSCRIPT_NAME = "init_pa.sh" | ||
14 | INITSCRIPT_PARAMS = "defaults 10" | ||
15 | 8 | ||
16 | do_compile () { | 9 | do_compile () { |
17 | # Now build the lld in the updated directory | 10 | # Now build the lld in the updated directory |
18 | make -f makefile_armv7 DEVICE=k2h clean lib PDK_INSTALL_PATH=${STAGING_INCDIR} | 11 | for device in ${DEVICELIST} |
19 | make -f makefile_armv7 DEVICE=k2l lib PDK_INSTALL_PATH=${STAGING_INCDIR} | 12 | do |
13 | make -f makefile_armv7 DEVICE=$device lib PDK_INSTALL_PATH=${STAGING_INCDIR} | ||
14 | done | ||
20 | } | 15 | } |
21 | 16 | ||
22 | do_install () { | 17 | do_install () { |
23 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} | 18 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} |
19 | |||
24 | # Set the generic device library symbolic link | 20 | # Set the generic device library symbolic link |
25 | ln -sf libpa.so.1.0.0 ${D}${libdir}/libpa_device.so.1 | 21 | ln -sf ${LIBPA}.so.1.0.0 ${D}${libdir}/libpa_device.so.1 |
26 | ln -sf libpa_device.so.1 ${D}${libdir}/libpa_device.so | 22 | ln -sf libpa_device.so.1 ${D}${libdir}/libpa_device.so |
27 | # Copy init scripts | ||
28 | install -d ${D}${sysconfdir}/init.d/ | ||
29 | install -c -m 755 ${WORKDIR}/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} | ||
30 | } | 23 | } |