diff options
author | Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> | 2017-07-19 05:03:29 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2017-08-22 16:04:06 -0400 |
commit | 6b775825d5f23a9faccbcfa19404fb133c364427 (patch) | |
tree | 71663f35758402463e1ed57ae6884f2431ce3aa9 /recipes-bsp | |
parent | cbb14827197de660e73883615845741f51a498a3 (diff) | |
download | meta-ti-6b775825d5f23a9faccbcfa19404fb133c364427.tar.gz |
spi-lld-rtos: Add rtos recipe for spi-lld
Upstreaming TI RTOS driver for Serial Peripheral Interface (SPI)
Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/spi-lld/spi-lld-rtos_git.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-bsp/spi-lld/spi-lld-rtos_git.bb b/recipes-bsp/spi-lld/spi-lld-rtos_git.bb new file mode 100644 index 00000000..4ed72483 --- /dev/null +++ b/recipes-bsp/spi-lld/spi-lld-rtos_git.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | SUMMARY = "TI RTOS low level driver for Serial Peripheral Interface (SPI)" | ||
2 | |||
3 | inherit ti-pdk | ||
4 | |||
5 | LICENSE = "BSD-3-Clause" | ||
6 | LIC_FILES_CHKSUM = "file://SPI.h;beginline=1;endline=31;md5=8580f9c5c0de8d5d13518cf18a0122b8" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|c66x|omapl1" | ||
9 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
10 | |||
11 | SPI_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/spi-lld.git" | ||
12 | SPI_LLD_GIT_PROTOCOL = "git" | ||
13 | SPI_LLD_GIT_BRANCH = "master" | ||
14 | |||
15 | # Below commit ID corresponds to "DEV.SPI_LLD.01.00.00.07A" | ||
16 | SPI_LLD_SRCREV = "d37daaf3a922e893fe845d44324393994321d443" | ||
17 | |||
18 | BRANCH = "${SPI_LLD_GIT_BRANCH}" | ||
19 | SRC_URI = "${SPI_LLD_GIT_URI};protocol=${SPI_LLD_GIT_PROTOCOL};branch=${BRANCH}" | ||
20 | |||
21 | SRCREV = "${SPI_LLD_SRCREV}" | ||
22 | PV = "01.00.00.07A" | ||
23 | PR = "r0" | ||
24 | |||
25 | DEPENDS_append = " osal-rtos \ | ||
26 | edma3-lld-rtos \ | ||
27 | " | ||
28 | DEPENDS_append_ti33x = " starterware-rtos" | ||
29 | DEPENDS_append_ti43x = " starterware-rtos" | ||
30 | |||
31 | # Build with make instead of XDC | ||
32 | TI_PDK_XDCMAKE = "0" | ||
33 | |||
34 | export PDK_SPI_ROOT_PATH ="${WORKDIR}/build" | ||
35 | export DEST_ROOT="${S}" | ||
36 | |||
37 | export EDMA3LLD_BIOS6_INSTALLDIR = "${EDMA3_LLD_INSTALL_DIR}" | ||
38 | XDCPATH_append = ";${EDMA3_LLD_INSTALL_DIR}/packages" | ||
39 | |||
40 | # HTML doc link params | ||
41 | PDK_COMP_LINK_TEXT = "SPI LLD" | ||