summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorLokesh Vutla <lokeshvutla@ti.com>2020-08-26 10:56:25 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-08-27 00:48:57 +0000
commit83f7dd59e1ea981e7f1ba7c5cd04f0d0a499280d (patch)
tree2919365131d31b405a13331e6614c9f521e0c51b /recipes-bsp
parent393834355c810efc6e224c6ff4cd064c1dd817f8 (diff)
downloadmeta-ti-83f7dd59e1ea981e7f1ba7c5cd04f0d0a499280d.tar.gz
prusw-fw: Package the firmware images from ti-linux-firmware
Directly take the images from ti-linux-firmware instead of using pdk Signed-off-by: Lokesh Vutla <lokeshvutla@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/prusw-fw/prusw-fw_3.0.3.bb37
-rw-r--r--recipes-bsp/prusw-fw/prusw-fw_git.bb40
2 files changed, 37 insertions, 40 deletions
diff --git a/recipes-bsp/prusw-fw/prusw-fw_3.0.3.bb b/recipes-bsp/prusw-fw/prusw-fw_3.0.3.bb
new file mode 100644
index 00000000..6eac87c5
--- /dev/null
+++ b/recipes-bsp/prusw-fw/prusw-fw_3.0.3.bb
@@ -0,0 +1,37 @@
1SUMMARY = "PRU Switch firmware for AM57xx, AM437x and AM335x"
2
3LICENSE = "TI-TFL"
4LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76"
5
6PR = "r0"
7
8CLEANBROKEN = "1"
9
10COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14SRCREV = "7ba9722b74608ad4472790972917e1205eb3c049"
15BRANCH ?= "ti-linux-firmware"
16
17SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}"
18
19S = "${WORKDIR}/git"
20
21TARGET = ""
22TARGET_ti33x = "am335x-pru0-prusw-fw.elf am335x-pru1-prusw-fw.elf"
23TARGET_ti43x = "am437x-pru0-prusw-fw.elf am437x-pru1-prusw-fw.elf"
24TARGET_am57xx-evm = "am57xx-pru0-prusw-fw.elf am57xx-pru1-prusw-fw.elf"
25TARGET_am57xx-hs-evm = "am57xx-pru0-prusw-fw.elf am57xx-pru1-prusw-fw.elf"
26
27do_install() {
28 install -d ${D}${base_libdir}/firmware/ti-pruss
29 for f in ${TARGET}; do
30 install -m 0644 ${S}/ti-pruss/$f ${D}${base_libdir}/firmware/ti-pruss/$f
31 done
32}
33
34
35FILES_${PN} = "${base_libdir}/firmware"
36
37INSANE_SKIP_${PN} = "arch"
diff --git a/recipes-bsp/prusw-fw/prusw-fw_git.bb b/recipes-bsp/prusw-fw/prusw-fw_git.bb
deleted file mode 100644
index 2921fb1d..00000000
--- a/recipes-bsp/prusw-fw/prusw-fw_git.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1DESCRIPTION = "PRU Switch firmware for AM57xx"
2
3require recipes-ti/includes/ti-paths.inc
4require recipes-bsp/icss-emac-lld/icss-emac-lld.inc
5
6LICENSE = "TI-TFL"
7LIC_FILES_CHKSUM = "file://icss_dualemac/src/firmware_version.h;beginline=6;endline=53;md5=1f0a640a261059cdcbbcf01e6a739ff3"
8
9PR = "${INC_PR}.0"
10
11TI_PDK_COMP = "ti.drv.icss_emac.firmware"
12
13B = "${S}/icss_switch"
14
15COMPATIBLE_MACHINE = "dra7xx"
16
17PACKAGE_ARCH = "${MACHINE_ARCH}"
18
19DEPENDS = "ti-cgt-pru-native"
20
21PRU_VERSION = ""
22PRU_VERSION_dra7xx = "REV2"
23
24FW_PREFIX = ""
25FW_PREFIX_dra7xx = "am57xx"
26
27
28EXTRA_OEMAKE += "CL_PRU_INSTALL_PATH="${TI_CGT_PRU_INSTALL_DIR}" PRU_VERSION_LIST="${PRU_VERSION}""
29
30do_install() {
31 install -d ${D}${base_libdir}/firmware/ti-pruss
32 install -m 0644 ./elf/${PRU_VERSION}/icss_stp_switch_PRU0.elf \
33 ${D}${base_libdir}/firmware/ti-pruss/${FW_PREFIX}-pru0-prusw-fw.elf
34 install -m 0644 ./elf/${PRU_VERSION}/icss_stp_switch_PRU1.elf \
35 ${D}${base_libdir}/firmware/ti-pruss/${FW_PREFIX}-pru1-prusw-fw.elf
36}
37
38FILES_${PN} = "${base_libdir}/firmware"
39
40INSANE_SKIP_${PN} = "arch"