diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2016-01-27 03:16:42 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2016-01-27 15:53:53 -0500 |
commit | e887c3f2a6166adaf420eb2c5789e468de2633da (patch) | |
tree | ba50b230a6c625c39721a1d7859eb2214dae6163 /recipes-bsp | |
parent | a83eb9039edea25386d320e7a1403d732930c2fa (diff) | |
download | meta-ti-e887c3f2a6166adaf420eb2c5789e468de2633da.tar.gz |
common-csl-ip: Upgrade to version 3.3.0.1B
* Re-implement common-csl-ip-rtos using the ti-pdk class
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb | 43 | ||||
-rw-r--r-- | recipes-bsp/common-csl-ip/common-csl-ip.inc | 11 | ||||
-rw-r--r-- | recipes-bsp/common-csl-ip/common-csl-ip_git.bb | 6 |
3 files changed, 25 insertions, 35 deletions
diff --git a/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb b/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb index f8dc1baa..6f7d3ccc 100644 --- a/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb +++ b/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb | |||
@@ -1,36 +1,23 @@ | |||
1 | require common-csl-ip.inc | 1 | require common-csl-ip.inc |
2 | |||
3 | PR = "${INC_PR}.0" | 2 | PR = "${INC_PR}.0" |
4 | 3 | ||
5 | require recipes-ti/includes/ti-paths.inc | 4 | inherit ti-pdk |
6 | require recipes-ti/includes/ti-staging.inc | ||
7 | |||
8 | DEPENDS = "ti-xdctools ti-cgt6x-native ti-sysbios" | ||
9 | |||
10 | CSL_GIT_DESTSUFFIX = "git/ti/csl" | ||
11 | 5 | ||
12 | export C6X_GEN_INSTALL_PATH="${STAGING_DIR_NATIVE}/usr" | 6 | DEPENDS_remove = "${PN}" |
13 | export XDCCGROOT="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" | ||
14 | export XDCPATH="${XDCCGROOT}/include;${XDC_INSTALL_DIR}/packages;${SYSBIOS_INSTALL_DIR}/packages" | ||
15 | 7 | ||
16 | do_configure() { | 8 | XDCARGS_ti33x = "am335x" |
17 | sed -i "s/\ \"\.\\\\\\\\\"\ +//" src/Module.xs | 9 | XDCARGS_ti43x = "am437x" |
18 | find -name "*.xs" -exec sed -i "s/ofd6x\.exe/ofd6x/" {} \; | 10 | XDCARGS_omap-a15 = "am571x am572x" |
19 | find -name "*.xs" -exec sed -i "s/sectti\.exe/sectti/" {} \; | 11 | XDCARGS_k2hk-evm = "k2h k2k" |
20 | find -name "*.xs" -exec sed -i "/\.chm/d" {} \; | 12 | XDCARGS_k2l-evm = "k2l" |
21 | find -name "*.xs" -exec sed -i "s/pasm\_dos/pasm\_linux/" {} \; | 13 | XDCARGS_k2e-evm = "k2e" |
22 | } | ||
23 | 14 | ||
24 | do_compile() { | 15 | do_configure_append() { |
25 | ${XDC_INSTALL_DIR}/xdc .make | 16 | # Create empty makefile |
26 | ${XDC_INSTALL_DIR}/xdc clean | 17 | # If libraries are supported for this device, then this will be overwritten |
27 | ${XDC_INSTALL_DIR}/xdc release | 18 | cat > ${BUILD_DIR}/makefile << __EOF__ |
28 | } | 19 | # Nothing to do |
20 | all: | ||
29 | 21 | ||
30 | do_install () { | 22 | __EOF__ |
31 | install -d ${D}${PDK_INSTALL_DIR_RECIPE}/packages | ||
32 | find -name "*.tar" -exec tar xf {} -C ${D}${PDK_INSTALL_DIR_RECIPE}/packages \; | ||
33 | } | 23 | } |
34 | |||
35 | ALLOW_EMPTY_${PN} = "1" | ||
36 | FILES_${PN}-dev += "${PDK_INSTALL_DIR_RECIPE}/packages" | ||
diff --git a/recipes-bsp/common-csl-ip/common-csl-ip.inc b/recipes-bsp/common-csl-ip/common-csl-ip.inc index 74abab0c..c81b0f13 100644 --- a/recipes-bsp/common-csl-ip/common-csl-ip.inc +++ b/recipes-bsp/common-csl-ip/common-csl-ip.inc | |||
@@ -5,19 +5,16 @@ LIC_FILES_CHKSUM = "file://COPYING.txt;md5=5857833e20836213677fac33f9aded21" | |||
5 | COMPATIBLE_MACHINE = "keystone|dra7xx" | 5 | COMPATIBLE_MACHINE = "keystone|dra7xx" |
6 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 6 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
7 | 7 | ||
8 | INC_PR = "r4" | 8 | PV = "3.3.0.1B" |
9 | INC_PR = "r0" | ||
9 | 10 | ||
10 | CSL_GIT_URI = "git://git.ti.com/keystone-rtos/common-csl-ip.git" | 11 | CSL_GIT_URI = "git://git.ti.com/keystone-rtos/common-csl-ip.git" |
11 | CSL_GIT_PROTOCOL ="git" | 12 | CSL_GIT_PROTOCOL ="git" |
12 | CSL_GIT_BRANCH = "master" | 13 | CSL_GIT_BRANCH = "master" |
13 | CSL_GIT_BRANCH_dra7xx = "releases/PROCESSOR-SDK.01.00.00" | ||
14 | CSL_GIT_DESTSUFFIX = "git" | 14 | CSL_GIT_DESTSUFFIX = "git" |
15 | 15 | ||
16 | # commit ID corresponds to DEV.CSL_KEYSTONE2.02.01.01.00A | 16 | # commit ID corresponds to DEV.CSL_PROCESSOR-SDK.03.03.00.01B |
17 | CSL_SRCREV = "17bb083f0d5ed4ad6f38c991210a6a8e9aaf9c56" | 17 | CSL_SRCREV = "48bb80a8d5919e17528a21be5d3ea6437dfc0425" |
18 | |||
19 | # commit ID corresponds to PROCESSOR-SDK-ALPHA-1 | ||
20 | CSL_SRCREV_dra7xx = "37c5311ddf289f83b1432a9422816722d264bf55" | ||
21 | 18 | ||
22 | BRANCH="${CSL_GIT_BRANCH}" | 19 | BRANCH="${CSL_GIT_BRANCH}" |
23 | SRC_URI = "${CSL_GIT_URI};protocol=${CSL_GIT_PROTOCOL};branch=${BRANCH};destsuffix=${CSL_GIT_DESTSUFFIX}" | 20 | SRC_URI = "${CSL_GIT_URI};protocol=${CSL_GIT_PROTOCOL};branch=${BRANCH};destsuffix=${CSL_GIT_DESTSUFFIX}" |
diff --git a/recipes-bsp/common-csl-ip/common-csl-ip_git.bb b/recipes-bsp/common-csl-ip/common-csl-ip_git.bb index 77f78589..9ea87d36 100644 --- a/recipes-bsp/common-csl-ip/common-csl-ip_git.bb +++ b/recipes-bsp/common-csl-ip/common-csl-ip_git.bb | |||
@@ -4,6 +4,12 @@ PR = "${INC_PR}.0" | |||
4 | 4 | ||
5 | ALLOW_EMPTY_${PN} = "1" | 5 | ALLOW_EMPTY_${PN} = "1" |
6 | 6 | ||
7 | CLEANBROKEN = "1" | ||
8 | |||
9 | do_compile() { | ||
10 | : | ||
11 | } | ||
12 | |||
7 | do_install () { | 13 | do_install () { |
8 | install -d ${D}${includedir}/ti/csl | 14 | install -d ${D}${includedir}/ti/csl |
9 | find . -name "*.h" -type f | xargs -I {} cp --parents {} ${D}${includedir}/ti/csl | 15 | find . -name "*.h" -type f | xargs -I {} cp --parents {} ${D}${includedir}/ti/csl |