summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-14 10:39:06 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-14 10:43:14 +0100
commit2de08fa6d4208a016b447832601f83fd51cb8f93 (patch)
treeda4a802d6275769c2d9f680e4e4e4fc6d910fc83 /recipes-bsp
parenteceb8e05b9e984e8221fb9a3754c2253d8c980f8 (diff)
downloadmeta-ti-2de08fa6d4208a016b447832601f83fd51cb8f93.tar.gz
u-boot: enhance deploy symlinking logic
It will now deploy: u-boot-<machine>-<version>.suffix u-boot-<machine>.suffix (symlink) u-boot.suffix (symlink) And additionally for SPL builds: MLO-<machine>-<version> MLO-<machine> (symlink) MLO (symlink) Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot.inc10
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.10rc.bb5
2 files changed, 10 insertions, 5 deletions
diff --git a/recipes-bsp/u-boot/u-boot.inc b/recipes-bsp/u-boot/u-boot.inc
index 310d80ca..1621d6b1 100644
--- a/recipes-bsp/u-boot/u-boot.inc
+++ b/recipes-bsp/u-boot/u-boot.inc
@@ -63,6 +63,14 @@ do_deploy () {
63 install ${S}/${UBOOT_BINARY} ${DEPLOY_DIR_IMAGE}/${UBOOT_IMAGE} 63 install ${S}/${UBOOT_BINARY} ${DEPLOY_DIR_IMAGE}/${UBOOT_IMAGE}
64 64
65 cd ${DEPLOY_DIR_IMAGE} 65 cd ${DEPLOY_DIR_IMAGE}
66 rm -f ${UBOOT_SYMLINK} 66 rm -f ${UBOOT_BINARY} ${UBOOT_SYMLINK}
67 ln -sf ${UBOOT_IMAGE} ${UBOOT_SYMLINK} 67 ln -sf ${UBOOT_IMAGE} ${UBOOT_SYMLINK}
68 ln -sf ${UBOOT_IMAGE} ${UBOOT_BINARY}
69
70 if [ -e ${S}/MLO ] ; then
71 install ${S}/MLO ${DEPLOY_DIR_IMAGE}/MLO-${MACHINE}-${PV}
72 rm -f ${DEPLOY_DIR_IMAGE}/MLO-${MACHINE} ${DEPLOY_DIR_IMAGE}/MLO
73 ln -sf MLO-${MACHINE}-${PV} ${DEPLOY_DIR_IMAGE}/MLO-${MACHINE}
74 ln -sf MLO-${MACHINE}-${PV} ${DEPLOY_DIR_IMAGE}/MLO
75 fi
68} 76}
diff --git a/recipes-bsp/u-boot/u-boot_2011.10rc.bb b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
index 1065e53a..51f71843 100644
--- a/recipes-bsp/u-boot/u-boot_2011.10rc.bb
+++ b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
@@ -4,7 +4,7 @@ require u-boot.inc
4COMPATIBLE_MACHINE = "(ti33x)" 4COMPATIBLE_MACHINE = "(ti33x)"
5DEFAULT_PREFERENCE_ti33x = "99" 5DEFAULT_PREFERENCE_ti33x = "99"
6PV = "2011.09+git" 6PV = "2011.09+git"
7PR = "r23" 7PR = "r24"
8 8
9# SPL build 9# SPL build
10UBOOT_BINARY = "u-boot.img" 10UBOOT_BINARY = "u-boot.img"
@@ -28,6 +28,3 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
28 28
29S = "${WORKDIR}/git" 29S = "${WORKDIR}/git"
30 30
31do_deploy_append () {
32 install ${S}/MLO ${DEPLOY_DIR_IMAGE}/MLO
33}