summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorFranklin S. Cooper Jr <fcooper@ti.com>2013-02-11 19:04:40 -0600
committerDenys Dmytriyenko <denys@ti.com>2013-02-12 18:16:22 -0500
commit201b231d721e27ac1d7a88a540b0b2fbbb86ed1e (patch)
tree9e75cc631f62244d54f036ae8364b49f5c39bc8b /recipes-bsp
parent98ad55b8eaba67d777382592df2fe9322ebe37b9 (diff)
downloadmeta-ti-201b231d721e27ac1d7a88a540b0b2fbbb86ed1e.tar.gz
u-boot_2010.12-psp03.21.00.04.sdk: Add latest u-boot recipe for am180x-evm
Signed-off-by: Franklin S. Cooper Jr <fcooper@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-2010.12-psp03.21.00.04.sdk/am180x-evm/0001-da850evm-change-default-memory-to-not-limit-at-32MB.patch34
-rw-r--r--recipes-bsp/u-boot/u-boot_2010.12-psp03.21.00.04.sdk.bb29
2 files changed, 63 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-2010.12-psp03.21.00.04.sdk/am180x-evm/0001-da850evm-change-default-memory-to-not-limit-at-32MB.patch b/recipes-bsp/u-boot/u-boot-2010.12-psp03.21.00.04.sdk/am180x-evm/0001-da850evm-change-default-memory-to-not-limit-at-32MB.patch
new file mode 100644
index 00000000..b19575b3
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-2010.12-psp03.21.00.04.sdk/am180x-evm/0001-da850evm-change-default-memory-to-not-limit-at-32MB.patch
@@ -0,0 +1,34 @@
1From df5c87c4e1be1670475eba1187301a2f7a7aca30 Mon Sep 17 00:00:00 2001
2From: Chase Maupin <Chase.Maupin@ti.com>
3Date: Wed, 22 Jun 2011 12:12:09 -0500
4Subject: [PATCH] da850evm: change default memory to not limit at 32MB
5
6* Change the default mem= option passed to the Linux kernel to
7 not limit the memory to 32MB.
8* This change is used by AM devices that do not need to reserve
9 space for the DSP image. By removing the mem= option we get
10 access to all of the memory on the system.
11* Limiting the memory to 32MB causes out-of-memory errors
12 when running large applications such as web browsers
13
14Signed-off-by: Chase Maupin <Chase.Maupin@ti.com>
15---
16 include/configs/da850evm.h | 2 +-
17 1 files changed, 1 insertions(+), 1 deletions(-)
18
19diff --git a/include/configs/da850evm.h b/include/configs/da850evm.h
20index 4a1e0af..55badc9 100755
21--- a/include/configs/da850evm.h
22+++ b/include/configs/da850evm.h
23@@ -184,7 +184,7 @@
24 #define CONFIG_CMDLINE_TAG
25 #define CONFIG_REVISION_TAG
26 #define CONFIG_SETUP_MEMORY_TAGS
27-#define CONFIG_BOOTARGS "mem=32M console=ttyS2,115200n8 root=/dev/mmcblk0p2 rw rootwait ip=off"
28+#define CONFIG_BOOTARGS "console=ttyS2,115200n8 root=/dev/mmcblk0p2 rw rootwait ip=off"
29 #define CONFIG_BOOTCOMMAND "if mmc rescan 0; then if fatload mmc 0 0xc0600000 boot.scr; then source 0xc0600000; else fatload mmc 0 0xc0700000 uImage; bootm c0700000; fi; else sf probe 0; sf read 0xc0700000 0x80000 0x220000; bootm 0xc0700000; fi"
30 #define CONFIG_BOOTDELAY 3
31
32--
331.7.0.4
34
diff --git a/recipes-bsp/u-boot/u-boot_2010.12-psp03.21.00.04.sdk.bb b/recipes-bsp/u-boot/u-boot_2010.12-psp03.21.00.04.sdk.bb
new file mode 100644
index 00000000..7652521b
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot_2010.12-psp03.21.00.04.sdk.bb
@@ -0,0 +1,29 @@
1# Use the version of u-boot.inc in oe-core not the meta-ti version
2require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
3
4DESCRIPTION = "u-boot bootloader for DaVinci devices"
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=4c6cde5df68eff615d36789dc18edd3b"
8
9COMPATIBLE_MACHINE = "am180x-evm"
10
11PACKAGE_ARCH = "${MACHINE_ARCH}"
12
13PR = "r0"
14
15SRC_URI = "git://arago-project.org/git/projects/u-boot-davinci.git;protocol=git;branch=${BRANCH}"
16
17# For the am180x we want to enable all the memory on the EVM, but for other
18# devices that use the DSP we do not want this change because that memory
19# is used for the DSP
20SRC_URI_append_am180x-evm = " file://0001-da850evm-change-default-memory-to-not-limit-at-32MB.patch"
21
22BRANCH = "03.21.00.03"
23
24# Use literal tags in SRCREV, when available, instead of commit IDs
25SRCREV = "v2010.12_DAVINCIPSP_03.21.00.04"
26
27S = "${WORKDIR}/git"
28
29UBOOT_SUFFIX = "bin"