diff options
author | Ramprasad N <x0038811@ti.com> | 2020-05-28 13:24:16 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2020-06-01 19:02:46 +0000 |
commit | 33b0e937b77894e0402d42e3798f48309a03fdce (patch) | |
tree | bf769d97af56fa9f6bb2e924074596c0b7662685 /recipes-bsp | |
parent | f2419cdd2dd3bf442b7abb9101168fb6a1243a1d (diff) | |
download | meta-ti-33b0e937b77894e0402d42e3798f48309a03fdce.tar.gz |
HACK: ipumm: Temporary work-around for linker error with XDC tools upgrade
IPUMM build is showing linker error for a function
ti_sdo_ce_utils_syscbuf_SysCBuf_Module_startup__E with latest xdc tool.
A dummy version of this function is added in ipumm as a temporary solution.
Signed-off-by: Ramprasad N <x0038811@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/ipumm-fw/files/0001-HACK-ipumm-Workaround-for-linker-error.patch | 48 | ||||
-rw-r--r-- | recipes-bsp/ipumm-fw/ipumm-fw_git.bb | 6 |
2 files changed, 53 insertions, 1 deletions
diff --git a/recipes-bsp/ipumm-fw/files/0001-HACK-ipumm-Workaround-for-linker-error.patch b/recipes-bsp/ipumm-fw/files/0001-HACK-ipumm-Workaround-for-linker-error.patch new file mode 100644 index 00000000..0bea358f --- /dev/null +++ b/recipes-bsp/ipumm-fw/files/0001-HACK-ipumm-Workaround-for-linker-error.patch | |||
@@ -0,0 +1,48 @@ | |||
1 | From 7226700841c62e6a42690eaa8b3e31b2c329b341 Mon Sep 17 00:00:00 2001 | ||
2 | From: Ramprasad N <x0038811@ti.com> | ||
3 | Date: Thu, 28 May 2020 09:53:59 +0530 | ||
4 | Subject: [PATCH] HACK: ipumm: Workaround for linker error | ||
5 | |||
6 | * HACK: ti_sdo_ce_utils_syscbuf_SysCBuf_Module_startup__E is no longer | ||
7 | * defined with latest XDC tools. To temporarily get around the issue | ||
8 | * until the real fix can be made, dummy defination of the missing function | ||
9 | * is added in ipu_main.c | ||
10 | |||
11 | *IPUMM dependent tool chain components are upgraded to latest version | ||
12 | * BIOS : 6_82_01_17_eng | ||
13 | * XDC : 3_61_00_16_core | ||
14 | * This issue is seen only with xdc tools upgrade. | ||
15 | |||
16 | Signed-off-by: Angela Stegmaier <angelabaker@ti.com> | ||
17 | Signed-off-by: Ramprasad N <x0038811@ti.com> | ||
18 | --- | ||
19 | platform/ti/dce/baselib/ipumm_main.c | 13 +++++++++++++ | ||
20 | 1 file changed, 13 insertions(+) | ||
21 | |||
22 | diff --git a/platform/ti/dce/baselib/ipumm_main.c b/platform/ti/dce/baselib/ipumm_main.c | ||
23 | index 76ccd34..f4ca6e5 100644 | ||
24 | --- a/platform/ti/dce/baselib/ipumm_main.c | ||
25 | +++ b/platform/ti/dce/baselib/ipumm_main.c | ||
26 | @@ -50,6 +50,19 @@ | ||
27 | #include <string.h> | ||
28 | #include <stdlib.h> | ||
29 | |||
30 | +/* | ||
31 | + * HACK: ti_sdo_ce_utils_syscbuf_SysCBuf_Module_startup__E is no longer | ||
32 | + * defined with latest XDC tools. To temporarily get around the issue | ||
33 | + * until the real fix can be made, define the missing function | ||
34 | + * here. | ||
35 | + */ | ||
36 | +extern ti_sdo_ce_utils_syscbuf_SysCBuf_Module_startup__F(xdc_Int state); | ||
37 | + | ||
38 | +/* Module_startup */ | ||
39 | +xdc_Int ti_sdo_ce_utils_syscbuf_SysCBuf_Module_startup__E( xdc_Int state ) | ||
40 | +{ | ||
41 | + return ti_sdo_ce_utils_syscbuf_SysCBuf_Module_startup__F(state); | ||
42 | +} | ||
43 | |||
44 | /* Legacy function to allow Linux side rpmsg sample tests to work: */ | ||
45 | extern void start_ping_tasks(); | ||
46 | -- | ||
47 | 1.9.1 | ||
48 | |||
diff --git a/recipes-bsp/ipumm-fw/ipumm-fw_git.bb b/recipes-bsp/ipumm-fw/ipumm-fw_git.bb index 4f6ae89e..e53d0a98 100644 --- a/recipes-bsp/ipumm-fw/ipumm-fw_git.bb +++ b/recipes-bsp/ipumm-fw/ipumm-fw_git.bb | |||
@@ -15,10 +15,14 @@ SRC_URI = "git://git.ti.com/ivimm/ipumm.git;protocol=git" | |||
15 | 15 | ||
16 | SRCREV = "df4c50aecc9aad7ab3eb1ca9ebacfe473fcad7c5" | 16 | SRCREV = "df4c50aecc9aad7ab3eb1ca9ebacfe473fcad7c5" |
17 | 17 | ||
18 | SRC_URI += " \ | ||
19 | file://0001-HACK-ipumm-Workaround-for-linker-error.patch \ | ||
20 | " | ||
21 | |||
18 | S = "${WORKDIR}/git" | 22 | S = "${WORKDIR}/git" |
19 | 23 | ||
20 | PV = "3.00.15.00" | 24 | PV = "3.00.15.00" |
21 | PR = "r5" | 25 | PR = "r6" |
22 | 26 | ||
23 | require recipes-ti/includes/ti-paths.inc | 27 | require recipes-ti/includes/ti-paths.inc |
24 | 28 | ||