diff options
author | Praneeth Bajjuri <praneeth@ti.com> | 2022-02-02 00:34:37 -0600 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2022-02-02 12:17:30 -0600 |
commit | 5023dca1dec156ea6ee0865c9c95100e80ff2833 (patch) | |
tree | 86b21e456eb3c63131417ecbf725d099e5abab00 /recipes-bsp | |
parent | 4b92727781e577c2bc2c2e36f87c13b9b2e18ec8 (diff) | |
download | meta-ti-5023dca1dec156ea6ee0865c9c95100e80ff2833.tar.gz |
Revert "ti-sci-fw: Fix for k3-image-gen issue for combined boot images"
This reverts commit d29025f7e868bea6299b55caf78e684fc647be33.
* associated fix in k3-image-gen is picked up now.
commit 892c86501ff7 ("Makefile: Skip signing of binaries for HS combined boot")
hence its no longer needed to carry the same fix from meta-ti here.
Signed-off-by: Praneeth Bajjuri <praneeth@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'recipes-bsp')
3 files changed, 1 insertions, 70 deletions
diff --git a/recipes-bsp/ti-linux-fw/ti-linux-fw.inc b/recipes-bsp/ti-linux-fw/ti-linux-fw.inc index fea0c783..014e89c8 100644 --- a/recipes-bsp/ti-linux-fw/ti-linux-fw.inc +++ b/recipes-bsp/ti-linux-fw/ti-linux-fw.inc | |||
@@ -24,7 +24,7 @@ SRCREV = "${TI_LINUX_FW_SRCREV}" | |||
24 | 24 | ||
25 | BRANCH ?= "ti-linux-firmware" | 25 | BRANCH ?= "ti-linux-firmware" |
26 | 26 | ||
27 | K3_IMAGE_GEN_SRCREV ?= "9abbe130d47a7fa6f8e02b740ad3ad27bc81d327" | 27 | K3_IMAGE_GEN_SRCREV ?= "892c86501ff745dfde4d535923ce686f45700da3" |
28 | SRCREV_imggen = "${K3_IMAGE_GEN_SRCREV}" | 28 | SRCREV_imggen = "${K3_IMAGE_GEN_SRCREV}" |
29 | SRCREV_FORMAT = "imggen" | 29 | SRCREV_FORMAT = "imggen" |
30 | 30 | ||
diff --git a/recipes-bsp/ti-sci-fw/files/0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch b/recipes-bsp/ti-sci-fw/files/0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch deleted file mode 100644 index 196f3d3f..00000000 --- a/recipes-bsp/ti-sci-fw/files/0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch +++ /dev/null | |||
@@ -1,64 +0,0 @@ | |||
1 | From 2efc79702a47f9cbbeecbb2f604577f1ec8c95ba Mon Sep 17 00:00:00 2001 | ||
2 | From: Yogesh Siraswar <yogeshs@ti.com> | ||
3 | Date: Wed, 8 Dec 2021 17:50:19 -0600 | ||
4 | Subject: [KIG PATCH] Makefile: Skip signing of binaries for combined boot hs | ||
5 | images | ||
6 | |||
7 | Combined sysfw binaries used in tiboot.bin do not require signed images. | ||
8 | This fixes issues with AM64x HS and J7200 HS boot images | ||
9 | |||
10 | Upstream-Status: Submitted | ||
11 | Signed-off-by: Yogesh Siraswar <yogeshs@ti.com> | ||
12 | --- | ||
13 | Makefile | 8 +++++++- | ||
14 | soc/am64x/Makefile | 1 + | ||
15 | soc/j7200/Makefile | 1 + | ||
16 | 3 files changed, 9 insertions(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/Makefile b/Makefile | ||
19 | index 47b3b20..ab465df 100644 | ||
20 | --- a/Makefile | ||
21 | +++ b/Makefile | ||
22 | @@ -215,8 +215,14 @@ $(soc_objroot)/%.o: %.c | ||
23 | $(CROSS_COMPILE)gcc $(CFLAGS) -c -o $@-pre-validated $< | ||
24 | python3 ./scripts/sysfw_boardcfg_validator.py -b $@-pre-validated -i -o $@ -s $(SOC) -l $@.log | ||
25 | |||
26 | -# On HS board configuration binaries must be signed | ||
27 | +# On HS board configuration binaries must be signed unless it is combined boot image | ||
28 | ifdef HS | ||
29 | +ifndef COMBINED_BOOT_IMAGE | ||
30 | +SIGN_BINARY=1 | ||
31 | +endif | ||
32 | +endif | ||
33 | + | ||
34 | +ifdef SIGN_BINARY | ||
35 | %.bin.unsigned: %.o | ||
36 | $(CROSS_COMPILE)objcopy -S -O binary $< $@ | ||
37 | %.bin: %.bin.unsigned | ||
38 | diff --git a/soc/am64x/Makefile b/soc/am64x/Makefile | ||
39 | index bfbe3e5..33ebbd0 100644 | ||
40 | --- a/soc/am64x/Makefile | ||
41 | +++ b/soc/am64x/Makefile | ||
42 | @@ -31,6 +31,7 @@ | ||
43 | # | ||
44 | |||
45 | SBL_LOADADDDR ?= 0x70000000 | ||
46 | +COMBINED_BOOT_IMAGE = 1 | ||
47 | COMBINED_SYSFW_BRDCFG_LOADADDR ?= 0x7b000 | ||
48 | LOADADDR ?= 0x44000 | ||
49 | SCIFS = sci | ||
50 | diff --git a/soc/j7200/Makefile b/soc/j7200/Makefile | ||
51 | index 3b754f7..0baef51 100644 | ||
52 | --- a/soc/j7200/Makefile | ||
53 | +++ b/soc/j7200/Makefile | ||
54 | @@ -31,6 +31,7 @@ | ||
55 | # | ||
56 | |||
57 | SBL_LOADADDDR ?= 0x41c00000 | ||
58 | +COMBINED_BOOT_IMAGE = 1 | ||
59 | COMBINED_TIFS_BRDCFG_LOADADDR ?= 0x7f000 | ||
60 | COMBINED_DM_BRDCFG_LOADADDR ?= 0x41c80000 | ||
61 | LOADADDR ?= 0x40000 | ||
62 | -- | ||
63 | 2.17.1 | ||
64 | |||
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb index d70d664c..646833a7 100644 --- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb +++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | |||
@@ -49,11 +49,6 @@ LD[unexport] = "1" | |||
49 | 49 | ||
50 | do_configure[noexec] = "1" | 50 | do_configure[noexec] = "1" |
51 | 51 | ||
52 | SRC_URI_append_j7200-hs-evm-k3r5 = "\ | ||
53 | file://0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch;patchdir=../imggen" | ||
54 | SRC_URI_append_am64xx-hs-evm-k3r5 = "\ | ||
55 | file://0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch;patchdir=../imggen" | ||
56 | |||
57 | EXTRA_OEMAKE = "\ | 52 | EXTRA_OEMAKE = "\ |
58 | CROSS_COMPILE=${TARGET_PREFIX} SYSFW_DL_URL='' SYSFW_HS_DL_URL='' SYSFW_HS_INNER_CERT_DL_URL='' \ | 53 | CROSS_COMPILE=${TARGET_PREFIX} SYSFW_DL_URL='' SYSFW_HS_DL_URL='' SYSFW_HS_INNER_CERT_DL_URL='' \ |
59 | SYSFW_PATH="${SYSFW_TISCI}" SOC=${SYSFW_SOC} CONFIG=${SYSFW_CONFIG} \ | 54 | SYSFW_PATH="${SYSFW_TISCI}" SOC=${SYSFW_SOC} CONFIG=${SYSFW_CONFIG} \ |