diff options
author | Nikhil Devshatwar <nikhil.nd@ti.com> | 2019-09-30 14:44:06 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2019-09-30 23:14:41 +0000 |
commit | a1b9985e59028080acf934ffcd22cc0b30262e77 (patch) | |
tree | 518cd72ed071cc939433549b52494d626abb525e /recipes-bsp | |
parent | d14685394d188733d58e169ba90a68c34a1cabc2 (diff) | |
download | meta-ti-a1b9985e59028080acf934ffcd22cc0b30262e77.tar.gz |
recipes-bsp: ivshmem-uio: Add new recipe for ivshmem-uio driver
This is external kernel module which enables userspace io over the
Jailhouse ivhsmem (inter VM shared memory)
This driver is useful to test the inter VM communication.
Signed-off-by: Nikhil Devshatwar <nikhil.nd@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/ivshmem-uio/ivshmem-uio-driver_git.bb | 27 |
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-bsp/ivshmem-uio/ivshmem-uio-driver_git.bb b/recipes-bsp/ivshmem-uio/ivshmem-uio-driver_git.bb new file mode 100644 index 00000000..a9f14552 --- /dev/null +++ b/recipes-bsp/ivshmem-uio/ivshmem-uio-driver_git.bb | |||
@@ -0,0 +1,27 @@ | |||
1 | SUMMARY = "Kernel driver for IVSHMEM based UIO driver" | ||
2 | DESCRIPTION = "Kernel module which registers a UIO (userspace io) device for inter VM shared memory" | ||
3 | HOMEPAGE = "https://github.com/henning-schild-work/ivshmem-guest-code" | ||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=0546a27aad86c83b75ad4ee6133e9d5e" | ||
6 | |||
7 | inherit module | ||
8 | |||
9 | RDEPENDS_${PN} = "jailhouse" | ||
10 | |||
11 | PROTOCOL = "git" | ||
12 | BRANCH = "jailhouse" | ||
13 | SRCREV = "f3ad79881bebb6c6068966ee3d265d8034c20492" | ||
14 | SRC_URI = "git://github.com/henning-schild-work/ivshmem-guest-code.git;protocol=${PROTOCOL};branch=${BRANCH}" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | EXTRA_OEMAKE += 'KDIR="${STAGING_KERNEL_DIR}"' | ||
19 | |||
20 | do_compile_prepend() { | ||
21 | cd ${S}/kernel_module/uio | ||
22 | } | ||
23 | |||
24 | do_install() { | ||
25 | install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra | ||
26 | install -m 644 ${S}/kernel_module/uio/uio_ivshmem.ko ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra | ||
27 | } | ||