summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2022-08-04 21:49:29 -0500
committerRyan Eatmon <reatmon@ti.com>2022-08-06 19:04:37 -0500
commit5102d150e78cc1457782d969503dc544b26f55a3 (patch)
tree07cce6820cc58ee6c92d95570443bcc0274d4c7e /recipes-bsp
parent1d9d7c6e4e1d2473bc4b41741cda13c07b691f69 (diff)
downloadmeta-ti-5102d150e78cc1457782d969503dc544b26f55a3.tar.gz
trusted-firmware-a: Allow build to continue without TI_SECURE_DEV_PKG set
Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend38
1 files changed, 16 insertions, 22 deletions
diff --git a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index 9645137e..965c99d4 100644
--- a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -9,42 +9,36 @@ TFA_SPD_k3 = "opteed"
9EXTRA_OEMAKE_append_k3 = "${@ 'K3_USART=' + d.getVar('TFA_K3_USART') if d.getVar('TFA_K3_USART') else ''}" 9EXTRA_OEMAKE_append_k3 = "${@ 'K3_USART=' + d.getVar('TFA_K3_USART') if d.getVar('TFA_K3_USART') else ''}"
10EXTRA_OEMAKE_append_k3 = "${@ 'K3_PM_SYSTEM_SUSPEND=' + d.getVar('TFA_K3_SYSTEM_SUSPEND') if d.getVar('TFA_K3_SYSTEM_SUSPEND') else ''}" 10EXTRA_OEMAKE_append_k3 = "${@ 'K3_PM_SYSTEM_SUSPEND=' + d.getVar('TFA_K3_SYSTEM_SUSPEND') if d.getVar('TFA_K3_SYSTEM_SUSPEND') else ''}"
11 11
12do_compile_append_am65xx-hs-evm() { 12# Signing procedure for K3 HS devices
13tfa_sign_k3hs() {
13 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 14 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
14 ( cd ${B}/${BUILD_DIR}/release/; \ 15 ( cd ${B}/${BUILD_DIR}/release/; \
15 mv bl31.bin bl31.bin.unsigned; \ 16 mv bl31.bin bl31.bin.unsigned; \
16 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \ 17 if [ -f ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ]; then \
18 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
19 else \
20 echo "Warning: TI_SECURE_DEV_PKG not set, TF-A not signed."; \
21 cp bl31.bin.unsigned bl31.bin; \
22 fi; \
17 ) 23 )
18} 24}
19 25
26do_compile_append_am65xx-hs-evm() {
27 tfa_sign_k3hs
28}
29
20do_compile_append_am64xx-hs-evm() { 30do_compile_append_am64xx-hs-evm() {
21 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 31 tfa_sign_k3hs
22 ( cd ${B}/${BUILD_DIR}/release/; \
23 mv bl31.bin bl31.bin.unsigned; \
24 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
25 )
26} 32}
27 33
28do_compile_append_j7-hs-evm() { 34do_compile_append_j7-hs-evm() {
29 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 35 tfa_sign_k3hs
30 ( cd ${B}/${BUILD_DIR}/release/; \
31 mv bl31.bin bl31.bin.unsigned; \
32 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
33 )
34} 36}
35 37
36do_compile_append_j7200-hs-evm() { 38do_compile_append_j7200-hs-evm() {
37 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 39 tfa_sign_k3hs
38 ( cd ${B}/${BUILD_DIR}/release/; \
39 mv bl31.bin bl31.bin.unsigned; \
40 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
41 )
42} 40}
43 41
44do_compile_append_j721s2-hs-evm() { 42do_compile_append_j721s2-hs-evm() {
45 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 43 tfa_sign_k3hs
46 ( cd ${B}/${BUILD_DIR}/release/; \
47 mv bl31.bin bl31.bin.unsigned; \
48 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
49 )
50} 44}