diff options
author | Khem Raj <raj.khem@gmail.com> | 2012-03-08 23:49:01 -0800 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2012-03-15 00:49:33 -0400 |
commit | 0d0e2c1e274e1885d8b5cb07421449e9d0016c2c (patch) | |
tree | d10c42bdff939a3fd7fb3d5d4d4e512a418b17c1 /recipes-bsp | |
parent | cf056a6ae089c8078609ee6b644f39b19965fbcb (diff) | |
download | meta-ti-0d0e2c1e274e1885d8b5cb07421449e9d0016c2c.tar.gz |
u-boot: Fix config-Always-use-GNU-ld patch to work with dash
>& /dev/null is not ok for dash so use > /dev/null 2>&1
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
4 files changed, 11 insertions, 11 deletions
diff --git a/recipes-bsp/u-boot/u-boot/0001-config-Always-use-GNU-ld.patch b/recipes-bsp/u-boot/u-boot/0001-config-Always-use-GNU-ld.patch index 2564d1d4..64685e39 100644 --- a/recipes-bsp/u-boot/u-boot/0001-config-Always-use-GNU-ld.patch +++ b/recipes-bsp/u-boot/u-boot/0001-config-Always-use-GNU-ld.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From dff01fc9346e6f4e3386536df309d2e78f03f3ee Mon Sep 17 00:00:00 2001 | 1 | From a8dc33253472328f2af04973575f26e9106db1c3 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Wed, 21 Dec 2011 08:53:02 -0800 | 3 | Date: Wed, 21 Dec 2011 08:53:02 -0800 |
4 | Subject: [PATCH] config: Always use GNU ld | 4 | Subject: [PATCH] config: Always use GNU ld |
@@ -20,14 +20,14 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
20 | 1 files changed, 3 insertions(+), 1 deletions(-) | 20 | 1 files changed, 3 insertions(+), 1 deletions(-) |
21 | 21 | ||
22 | diff --git a/config.mk b/config.mk | 22 | diff --git a/config.mk b/config.mk |
23 | index ddaa477..59b3e71 100644 | 23 | index ddaa477..139dfa0 100644 |
24 | --- a/config.mk | 24 | --- a/config.mk |
25 | +++ b/config.mk | 25 | +++ b/config.mk |
26 | @@ -126,11 +126,13 @@ cc-option = $(strip $(if $(findstring $1,$(CC_OPTIONS)),$1,\ | 26 | @@ -126,11 +126,13 @@ cc-option = $(strip $(if $(findstring $1,$(CC_OPTIONS)),$1,\ |
27 | $(if $(call cc-option-sys,$1),$1,$2))) | 27 | $(if $(call cc-option-sys,$1),$1,$2))) |
28 | endif | 28 | endif |
29 | 29 | ||
30 | +exists_bfd_ld = $(shell if $(CROSS_COMPILE)ld.bfd -v >& /dev/null; \ | 30 | +exists_bfd_ld = $(shell if $(CROSS_COMPILE)ld.bfd -v > /dev/null 2>&1; \ |
31 | + then echo "$(1)"; else echo "$(2)"; fi; ) | 31 | + then echo "$(1)"; else echo "$(2)"; fi; ) |
32 | # | 32 | # |
33 | # Include the make variables (CC, etc...) | 33 | # Include the make variables (CC, etc...) |
@@ -39,5 +39,5 @@ index ddaa477..59b3e71 100644 | |||
39 | CPP = $(CC) -E | 39 | CPP = $(CC) -E |
40 | AR = $(CROSS_COMPILE)ar | 40 | AR = $(CROSS_COMPILE)ar |
41 | -- | 41 | -- |
42 | 1.7.5.4 | 42 | 1.7.9.1 |
43 | 43 | ||
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch b/recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch index 15f22b34..64685e39 100644 --- a/recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch +++ b/recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 06fe8be6b5c70853c0e3fac93d7bba9cb3d0292f Mon Sep 17 00:00:00 2001 | 1 | From a8dc33253472328f2af04973575f26e9106db1c3 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Wed, 21 Dec 2011 08:53:02 -0800 | 3 | Date: Wed, 21 Dec 2011 08:53:02 -0800 |
4 | Subject: [PATCH 07/10] config: Always use GNU ld | 4 | Subject: [PATCH] config: Always use GNU ld |
5 | 5 | ||
6 | This patch makes sure that we always use the GNU ld. u-boot uses certain | 6 | This patch makes sure that we always use the GNU ld. u-boot uses certain |
7 | construct e.g. OVERLAY which are not implemented in gold therefore it | 7 | construct e.g. OVERLAY which are not implemented in gold therefore it |
@@ -20,14 +20,14 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
20 | 1 files changed, 3 insertions(+), 1 deletions(-) | 20 | 1 files changed, 3 insertions(+), 1 deletions(-) |
21 | 21 | ||
22 | diff --git a/config.mk b/config.mk | 22 | diff --git a/config.mk b/config.mk |
23 | index ddaa477..59b3e71 100644 | 23 | index ddaa477..139dfa0 100644 |
24 | --- a/config.mk | 24 | --- a/config.mk |
25 | +++ b/config.mk | 25 | +++ b/config.mk |
26 | @@ -126,11 +126,13 @@ cc-option = $(strip $(if $(findstring $1,$(CC_OPTIONS)),$1,\ | 26 | @@ -126,11 +126,13 @@ cc-option = $(strip $(if $(findstring $1,$(CC_OPTIONS)),$1,\ |
27 | $(if $(call cc-option-sys,$1),$1,$2))) | 27 | $(if $(call cc-option-sys,$1),$1,$2))) |
28 | endif | 28 | endif |
29 | 29 | ||
30 | +exists_bfd_ld = $(shell if $(CROSS_COMPILE)ld.bfd -v >& /dev/null; \ | 30 | +exists_bfd_ld = $(shell if $(CROSS_COMPILE)ld.bfd -v > /dev/null 2>&1; \ |
31 | + then echo "$(1)"; else echo "$(2)"; fi; ) | 31 | + then echo "$(1)"; else echo "$(2)"; fi; ) |
32 | # | 32 | # |
33 | # Include the make variables (CC, etc...) | 33 | # Include the make variables (CC, etc...) |
@@ -39,5 +39,5 @@ index ddaa477..59b3e71 100644 | |||
39 | CPP = $(CC) -E | 39 | CPP = $(CC) -E |
40 | AR = $(CROSS_COMPILE)ar | 40 | AR = $(CROSS_COMPILE)ar |
41 | -- | 41 | -- |
42 | 1.7.2.5 | 42 | 1.7.9.1 |
43 | 43 | ||
diff --git a/recipes-bsp/u-boot/u-boot_2011.09.bb b/recipes-bsp/u-boot/u-boot_2011.09.bb index 4a9d3cb1..b164c777 100644 --- a/recipes-bsp/u-boot/u-boot_2011.09.bb +++ b/recipes-bsp/u-boot/u-boot_2011.09.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | require u-boot.inc | 1 | require u-boot.inc |
2 | 2 | ||
3 | PR = "r6" | 3 | PR = "r7" |
4 | 4 | ||
5 | # SPL build | 5 | # SPL build |
6 | UBOOT_BINARY = "u-boot.img" | 6 | UBOOT_BINARY = "u-boot.img" |
diff --git a/recipes-bsp/u-boot/u-boot_2011.12.bb b/recipes-bsp/u-boot/u-boot_2011.12.bb index 35ffd4b7..9bbd31e2 100644 --- a/recipes-bsp/u-boot/u-boot_2011.12.bb +++ b/recipes-bsp/u-boot/u-boot_2011.12.bb | |||
@@ -6,7 +6,7 @@ UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img" | |||
6 | UBOOT_SYMLINK = "u-boot-${MACHINE}.img" | 6 | UBOOT_SYMLINK = "u-boot-${MACHINE}.img" |
7 | 7 | ||
8 | PV = "2011.12" | 8 | PV = "2011.12" |
9 | PR = "r5" | 9 | PR = "r6" |
10 | 10 | ||
11 | # No patches for other machines yet | 11 | # No patches for other machines yet |
12 | COMPATIBLE_MACHINE = "(beagleboard|pandaboard|hawkboard|am3517-evm|am37x-evm|omap3evm)" | 12 | COMPATIBLE_MACHINE = "(beagleboard|pandaboard|hawkboard|am3517-evm|am37x-evm|omap3evm)" |