diff options
author | Denys Dmytriyenko <denys@ti.com> | 2020-05-19 06:32:41 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2020-05-19 20:30:29 +0000 |
commit | 0f99cfb94cc368911e386c248ba3fb2abf9e3fcc (patch) | |
tree | 205e7bf5b0778be100dd0dc5815d84711619cb32 /recipes-bsp | |
parent | f152e696d9466a14e536d4bdece27897bdfacc55 (diff) | |
download | meta-ti-0f99cfb94cc368911e386c248ba3fb2abf9e3fcc.tar.gz |
trusted-firmware-a: upstreamed and unified to meta-arm, drop locally
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2.2.bb | 79 | ||||
-rw-r--r-- | recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend | 23 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-ti.inc | 2 |
3 files changed, 24 insertions, 80 deletions
diff --git a/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2.2.bb b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2.2.bb deleted file mode 100644 index ae957bf8..00000000 --- a/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2.2.bb +++ /dev/null | |||
@@ -1,79 +0,0 @@ | |||
1 | SUMMARY = "ARM Trusted Firmware" | ||
2 | DESCRIPTION = "ARM Trusted Firmware provides a reference implementation of \ | ||
3 | Secure World software for ARMv8-A, including Exception Level 3 (EL3) software. \ | ||
4 | It provides implementations of various ARM interface standards such as the \ | ||
5 | Power State Coordination Interface (PSCI), Trusted Board Boot Requirements \ | ||
6 | (TBBR) and Secure monitor code." | ||
7 | HOMEPAGE = "http://infocenter.arm.com/help/topic/com.arm.doc.dui0928e/CJHIDGJF.html" | ||
8 | |||
9 | LICENSE = "BSD" | ||
10 | LIC_FILES_CHKSUM = "file://docs/license.rst;md5=189505435dbcdcc8caa63c46fe93fa89" | ||
11 | |||
12 | inherit deploy | ||
13 | |||
14 | DEPENDS += "dtc-native openssl-native" | ||
15 | |||
16 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
17 | |||
18 | S = "${WORKDIR}/git" | ||
19 | |||
20 | PV_append = "+git${SRCPV}" | ||
21 | |||
22 | BRANCH = "ti-atf" | ||
23 | SRC_URI = "git://git.ti.com/atf/arm-trusted-firmware.git;branch=${BRANCH}" | ||
24 | |||
25 | SRCREV ?= "e516a389ac12fbe1597f61fea80ed3f230b9c5fd" | ||
26 | |||
27 | # Make ATF "aware" of OPTEE, no build dependency | ||
28 | PACKAGECONFIG[optee] = "SPD=opteed" | ||
29 | |||
30 | COMPATIBLE_MACHINE = "k3" | ||
31 | ATFPLATFORM_k3 = "k3" | ||
32 | ATFBOARD_k3 = "generic" | ||
33 | |||
34 | PACKAGECONFIG_k3 = "optee" | ||
35 | |||
36 | CFLAGS[unexport] = "1" | ||
37 | LDFLAGS[unexport] = "1" | ||
38 | AS[unexport] = "1" | ||
39 | LD[unexport] = "1" | ||
40 | |||
41 | do_configure[noexec] = "1" | ||
42 | |||
43 | EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" PLAT="${ATFPLATFORM}" TARGET_BOARD="${ATFBOARD}" ${PACKAGECONFIG_CONFARGS}' | ||
44 | |||
45 | do_compile() { | ||
46 | oe_runmake all | ||
47 | } | ||
48 | |||
49 | do_compile_append_am65xx-hs-evm() { | ||
50 | export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} | ||
51 | ( cd ${S}/build/${ATFPLATFORM}/${ATFBOARD}/release/; \ | ||
52 | mv bl31.bin bl31.bin.unsigned; \ | ||
53 | ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \ | ||
54 | ) | ||
55 | } | ||
56 | |||
57 | do_compile_append_j7-hs-evm() { | ||
58 | export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} | ||
59 | ( cd ${S}/build/${ATFPLATFORM}/${ATFBOARD}/release/; \ | ||
60 | mv bl31.bin bl31.bin.unsigned; \ | ||
61 | ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \ | ||
62 | ) | ||
63 | } | ||
64 | |||
65 | do_install() { | ||
66 | install -d ${D}/boot | ||
67 | install -m 0644 ${S}/build/${ATFPLATFORM}/${ATFBOARD}/release/bl31.bin ${D}/boot/ | ||
68 | install -m 0644 ${S}/build/${ATFPLATFORM}/${ATFBOARD}/release/bl31/bl31.elf ${D}/boot/ | ||
69 | } | ||
70 | |||
71 | do_deploy() { | ||
72 | install -d ${DEPLOYDIR} | ||
73 | install -m 0644 ${S}/build/${ATFPLATFORM}/${ATFBOARD}/release/bl31.bin ${DEPLOYDIR}/ | ||
74 | install -m 0644 ${S}/build/${ATFPLATFORM}/${ATFBOARD}/release/bl31/bl31.elf ${DEPLOYDIR}/ | ||
75 | } | ||
76 | addtask deploy before do_build after do_compile | ||
77 | |||
78 | FILES_${PN} = "/boot" | ||
79 | SYSROOT_DIRS += "/boot" | ||
diff --git a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend new file mode 100644 index 00000000..d43e7c5a --- /dev/null +++ b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend | |||
@@ -0,0 +1,23 @@ | |||
1 | BRANCH_k3 = "ti-atf" | ||
2 | SRC_URI_k3 = "git://git.ti.com/atf/arm-trusted-firmware.git;branch=${BRANCH}" | ||
3 | SRCREV_k3 = "5b907a2813faf039d752cdeb6a7b94e95580c46b" | ||
4 | COMPATIBLE_MACHINE_k3 = "k3" | ||
5 | TFA_BUILD_TARGET_k3 = "all" | ||
6 | TFA_INSTALL_TARGET_k3 = "bl31" | ||
7 | TFA_SPD_k3 = "opteed" | ||
8 | |||
9 | do_compile_append_am65xx-hs-evm() { | ||
10 | export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} | ||
11 | ( cd ${B}/${BUILD_DIR}/release/; \ | ||
12 | mv bl31.bin bl31.bin.unsigned; \ | ||
13 | ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \ | ||
14 | ) | ||
15 | } | ||
16 | |||
17 | do_compile_append_j7-hs-evm() { | ||
18 | export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} | ||
19 | ( cd ${B}/${BUILD_DIR}/release/; \ | ||
20 | mv bl31.bin bl31.bin.unsigned; \ | ||
21 | ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \ | ||
22 | ) | ||
23 | } | ||
diff --git a/recipes-bsp/u-boot/u-boot-ti.inc b/recipes-bsp/u-boot/u-boot-ti.inc index 8f8f0afe..062a692a 100644 --- a/recipes-bsp/u-boot/u-boot-ti.inc +++ b/recipes-bsp/u-boot/u-boot-ti.inc | |||
@@ -33,7 +33,7 @@ PV_append = "+git${SRCPV}" | |||
33 | # u-boot needs devtree compiler to parse dts files | 33 | # u-boot needs devtree compiler to parse dts files |
34 | DEPENDS += "dtc-native bc-native lzop-native flex-native bison-native" | 34 | DEPENDS += "dtc-native bc-native lzop-native flex-native bison-native" |
35 | 35 | ||
36 | PACKAGECONFIG[atf] = "ATF=${STAGING_DIR_HOST}/boot/bl31.bin,,arm-trusted-firmware" | 36 | PACKAGECONFIG[atf] = "ATF=${STAGING_DIR_HOST}/firmware/bl31.bin,,trusted-firmware-a" |
37 | PACKAGECONFIG[optee] = "TEE=${STAGING_DIR_HOST}/boot/bl32.bin,,optee-os" | 37 | PACKAGECONFIG[optee] = "TEE=${STAGING_DIR_HOST}/boot/bl32.bin,,optee-os" |
38 | 38 | ||
39 | PACKAGECONFIG_append_aarch64 = " atf optee" | 39 | PACKAGECONFIG_append_aarch64 = " atf optee" |