summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2014-06-20 18:10:18 -0400
committerDenys Dmytriyenko <denys@ti.com>2014-06-23 17:57:05 -0400
commit4b79986d032bfd9cc40a7cf832de3e772a1e2e81 (patch)
tree9f4ec12248929a3cf24325dfbef7fb8948a0cc39 /recipes-bsp
parent171d3312e50793281d99f06d4248478d5777aa7c (diff)
downloadmeta-ti-4b79986d032bfd9cc40a7cf832de3e772a1e2e81.tar.gz
recipes: consolidate firmware recipes under recipes-bsp in own directories
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/am33x-cm3/am33x-cm3/init-am33x-cm3 (renamed from recipes-bsp/ti/am33x-cm3/init-am33x-cm3)0
-rw-r--r--recipes-bsp/am33x-cm3/am33x-cm3/init-am43x-cm3 (renamed from recipes-bsp/ti/am33x-cm3/init-am43x-cm3)0
-rw-r--r--recipes-bsp/am33x-cm3/am33x-cm3_git.bb (renamed from recipes-bsp/ti/am33x-cm3_git.bb)0
-rw-r--r--recipes-bsp/dspdce-fw/dspdce-fw_1.00.00.02.bb24
-rw-r--r--recipes-bsp/ipumm-fw/ipumm-fw_3.00.04.02.bb30
-rw-r--r--recipes-bsp/vis-fw/vis_01.50.07.15.bb31
-rw-r--r--recipes-bsp/vpe-vpdma/vpe-vpdma_git.bb (renamed from recipes-bsp/ti/vpe-vpdma_git.bb)0
7 files changed, 85 insertions, 0 deletions
diff --git a/recipes-bsp/ti/am33x-cm3/init-am33x-cm3 b/recipes-bsp/am33x-cm3/am33x-cm3/init-am33x-cm3
index 56c17b33..56c17b33 100644
--- a/recipes-bsp/ti/am33x-cm3/init-am33x-cm3
+++ b/recipes-bsp/am33x-cm3/am33x-cm3/init-am33x-cm3
diff --git a/recipes-bsp/ti/am33x-cm3/init-am43x-cm3 b/recipes-bsp/am33x-cm3/am33x-cm3/init-am43x-cm3
index 0a75c1fd..0a75c1fd 100644
--- a/recipes-bsp/ti/am33x-cm3/init-am43x-cm3
+++ b/recipes-bsp/am33x-cm3/am33x-cm3/init-am43x-cm3
diff --git a/recipes-bsp/ti/am33x-cm3_git.bb b/recipes-bsp/am33x-cm3/am33x-cm3_git.bb
index 42f20da4..42f20da4 100644
--- a/recipes-bsp/ti/am33x-cm3_git.bb
+++ b/recipes-bsp/am33x-cm3/am33x-cm3_git.bb
diff --git a/recipes-bsp/dspdce-fw/dspdce-fw_1.00.00.02.bb b/recipes-bsp/dspdce-fw/dspdce-fw_1.00.00.02.bb
new file mode 100644
index 00000000..69e9814c
--- /dev/null
+++ b/recipes-bsp/dspdce-fw/dspdce-fw_1.00.00.02.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Firmware for DSP "
2LICENSE = "TI-TSPA"
3LIC_FILES_CHKSUM = "file://DSPDCE-${PV}-Manifest.doc;md5=587a7b9fdd99f98fbe99af4a4ba3362a"
4
5COMPATIBLE_MACHINE = "dra7xx-evm"
6PACKAGE_ARCH = "${MACHINE_ARCH}"
7
8SRC_URI = "http://downloads.ti.com/dsps/dsps_public_sw/glsdk/dspdce/1_00_00_02/exports/dspdce-${MACHINE}-1.00.00.02.tar.gz;protocol=http"
9
10S = "${WORKDIR}/dspdce-${MACHINE}-${PV}"
11
12SRC_URI[md5sum] = "df19baf16f828b5d32b4eed50f0364f5"
13SRC_URI[sha256sum] = "0c0f34674110d1ef0300b61b572a326daffb95a31cc9d45888b2e50a83c6f555"
14
15TARGET = "dra7-dsp1-fw.xe66"
16
17do_install() {
18 mkdir -p ${D}${base_libdir}/firmware
19 cp ${S}/firmware/${TARGET} ${D}${base_libdir}/firmware/${TARGET}
20}
21
22FILES_${PN} += "${base_libdir}/firmware/${TARGET}"
23
24INSANE_SKIP_${PN} = "arch"
diff --git a/recipes-bsp/ipumm-fw/ipumm-fw_3.00.04.02.bb b/recipes-bsp/ipumm-fw/ipumm-fw_3.00.04.02.bb
new file mode 100644
index 00000000..c3017fed
--- /dev/null
+++ b/recipes-bsp/ipumm-fw/ipumm-fw_3.00.04.02.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "Firmware for IPU "
2
3LICENSE = "TI-TSPA"
4LIC_FILES_CHKSUM_dra7xx-evm = "file://MMIP-${PV}-Manifest.doc;md5=64ca6f9d7e5243b8a4084eb918a543bc"
5LIC_FILES_CHKSUM_omap5-evm = "file://MMIP-${PV}-Manifest.doc;md5=39a593dd8fc2a9654c74f679ed329c45"
6
7COMPATIBLE_MACHINE = "omap-a15"
8PACKAGE_ARCH = "${MACHINE_ARCH}"
9
10SRC_URI = "http://downloads.ti.com/dsps/dsps_public_sw/glsdk/ipumm/3_00_04_02/exports/ipumm-${MACHINE}-3.00.04.02.tar.gz;protocol=http;name=${MACHINE}"
11
12# DRA7xx checksums
13SRC_URI[dra7xx-evm.md5sum] = "da04c03b0fd57901e8283afa80f81379"
14SRC_URI[dra7xx-evm.sha256sum] = "0b26fd13f9c318b52c18b9bff56862ef1f58a768b19285b87c035e65bc828ddc"
15
16# OMAP5 checksums
17SRC_URI[omap5-evm.md5sum] = "1572073ebd4f6d127c4e8cf47d270b6a"
18SRC_URI[omap5-evm.sha256sum] = "2fdb469f19e3c9984854f5bc82444fca4d7da869f5e645da22ec0d5beaa5cc65"
19
20S = "${WORKDIR}/ipumm-${MACHINE}-${PV}"
21
22TARGET_dra7xx-evm = "dra7-ipu2-fw.xem4"
23TARGET_omap5-evm = "ducati-m3-core0.xem3"
24
25do_install() {
26 mkdir -p ${D}${base_libdir}/firmware
27 cp ${S}/firmware/${TARGET} ${D}${base_libdir}/firmware/${TARGET}
28}
29
30FILES_${PN} += "${base_libdir}/firmware/${TARGET}"
diff --git a/recipes-bsp/vis-fw/vis_01.50.07.15.bb b/recipes-bsp/vis-fw/vis_01.50.07.15.bb
new file mode 100644
index 00000000..85d85397
--- /dev/null
+++ b/recipes-bsp/vis-fw/vis_01.50.07.15.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "Radio Application Firmware"
2LICENSE = "TI-TSPA"
3LIC_FILES_CHKSUM = "file://${S}/J6_VIS_DEMO_LINUX_BINARY_01.50.07.15-Manifest.html;md5=a59aa54b9470f555cf086b91dca0afa3"
4
5COMPATIBLE_MACHINE = "dra7xx-evm"
6PACKAGE_ARCH = "${MACHINE_ARCH}"
7
8SRC_URI = "http://downloads.ti.com/dsps/dsps_public_sw/glsdk/vis/01_50_07_15/exports/vis-${MACHINE}-01.50.07.15.tar.gz;protocol=http"
9
10SRC_URI[md5sum] = "fe8b00e398fb3b7ada0c15b601867acb"
11SRC_URI[sha256sum] = "6e2aa47ae892910616ebdc96646af778af9a59ca0657716ab4fa4b24a9afae69"
12
13S = "${WORKDIR}"
14
15DSPAPP = "dra7-dsp1-fw-radio.xe66"
16GPPAPP = "RadioApp"
17
18do_install() {
19 install -d ${D}${base_libdir}/firmware
20 install -d ${D}${bindir}
21 install ${S}/prebuilt/${DSPAPP} ${D}${base_libdir}/firmware/${DSPAPP}
22 install -m 0755 ${S}/prebuilt/${GPPAPP} ${D}${bindir}/${GPPAPP}
23}
24
25PACKAGES += "${PN}-fw"
26RDEPENDS_${PN} += "${PN}-fw"
27
28FILES_${PN}-fw += "${base_libdir}/firmware/${DSPAPP}"
29
30INSANE_SKIP_${PN}-fw = "arch"
31INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
diff --git a/recipes-bsp/ti/vpe-vpdma_git.bb b/recipes-bsp/vpe-vpdma/vpe-vpdma_git.bb
index fb3012a7..fb3012a7 100644
--- a/recipes-bsp/ti/vpe-vpdma_git.bb
+++ b/recipes-bsp/vpe-vpdma/vpe-vpdma_git.bb